Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 23:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание внешней обработки HELP  (Прочитано 5488 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mister-q88

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Уважаемые участники форума прошу у вас помощи, имеется 1С Предприятие 8.2  Бухглатерия для Казахстана редакция 2.0
 Необходимо установить внешнюю обработку форму 3-2 Накладную на отпуск запасов на сторону, но она не устанавливается ошибки в модуле
 
Файл во вложении ошибки проверял через конфигуратор.

Очень прошу помогите :trhregerhg:




Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
У меня нет казахтанской бухгалтерии проверять не на чем. Может скажешь какие ошибки посоветую как исправлять.

Оффлайн mister-q88

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Ошибки: {ВнешняяОбработка.НакладнаяНаОтпускЗапасовЗ2.МодульОбъекта(173,108)}: Переменная не определена (ФормированиеПечатныхФорм)
      ОбластьМакета.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрокТовары.Номенклатура.НаименованиеПолное) + <<?>>ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары); (Проверка: Толстый клиент (обычное приложение))
{ВнешняяОбработка.НакладнаяНаОтпускЗапасовЗ2.МодульОбъекта(380,108)}: Переменная не определена (ФормированиеПечатныхФорм)
      ОбластьМакета.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрокТовары.Номенклатура.НаименованиеПолное) + <<?>>ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары); (Проверка: Толстый клиент (обычное приложение))
 
А вот так выглядит код.

 // Функция формирует табличный документ унифицированной формы З-8
//
// Параметры:
//  Нет.
//
// Возвращаемое значение:
//  Табличный документ по форме З-8.
//
Функция ПечатьРеализацияТоваровиУслуг() Экспорт

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекДокумент", СсылкаНаОбъект);
Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект.Дата);

Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| РеализацияТоваровУслуг.Номер,
| РеализацияТоваровУслуг.Дата КАК ДатаДокумента,
| РеализацияТоваровУслуг.Организация,
| РеализацияТоваровУслуг.Контрагент,
| РеализацияТоваровУслуг.Склад,
| ВЫБОР
| КОГДА РеализацияТоваровУслуг.Ответственный.ФизЛицо <> ЗНАЧЕНИЕ(Справочник.ФизическиеЛица.ПустаяСсылка)
| ТОГДА РеализацияТоваровУслуг.Ответственный.ФизЛицо
| ИНАЧЕ РеализацияТоваровУслуг.Ответственный
| КОНЕЦ КАК Ответственный,
| ОтветственныеЛицаСклад.ФизическоеЛицо КАК МОЛ,
| РеализацияТоваровУслуг.ВалютаДокумента,
| РеализацияТоваровУслуг.ВалютаДокумента.Представление КАК ВалютаПредставление,
| РеализацияТоваровУслуг.Доверенность,
| РеализацияТоваровУслуг.ДоверенностьЧерезКого КАК ЧерезКого,
| РеализацияТоваровУслуг.ОтпускПроизвел,
| РеализацияТоваровУслуг.ОтпускРазрешил
|ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних(&Дата, ) КАК ОтветственныеЛицаСклад
| ПО РеализацияТоваровУслуг.Склад = ОтветственныеЛицаСклад.СтруктурнаяЕдиница
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекДокумент";

Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();

ЗапросПоТоварам = Новый Запрос();
ЗапросПоТоварам.УстановитьПараметр("ТекДокумент", СсылкаНаОбъект);
ЗапросПоТоварам.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| РеализацияТоваровУслугТовары.НомерСтроки КАК НомерСтроки,
| РеализацияТоваровУслугТовары.Номенклатура,
| РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Наименование КАК ЕдиницаИзмеренияНаименование,
| РеализацияТоваровУслугТовары.Номенклатура.Код КАК ТоварКод,
| РеализацияТоваровУслугТовары.Номенклатура.Артикул КАК Артикул,
| СУММА(РеализацияТоваровУслугТовары.Количество) КАК Количество,
| ВЫБОР
| КОГДА ЕСТЬNULL(РеализацияТоваровУслугТовары.Количество, 0) = 0
| ТОГДА 0
| ИНАЧЕ ВЫРАЗИТЬ(РеализацияТоваровУслугТовары.Сумма / РеализацияТоваровУслугТовары.Количество КАК ЧИСЛО(15, 2))
| КОНЕЦ КАК Цена,
| СУММА(РеализацияТоваровУслугТовары.Сумма) КАК Сумма,
| СУММА(РеализацияТоваровУслугТовары.СуммаНДС) КАК СуммаНДС,
| СУММА(ВЫБОР
| КОГДА РеализацияТоваровУслугТовары.Ссылка.УчитыватьНДС
| И РеализацияТоваровУслугТовары.Ссылка.СуммаВключаетНДС
| ИЛИ НЕ РеализацияТоваровУслугТовары.Ссылка.УчитыватьНДС
| ТОГДА РеализацияТоваровУслугТовары.Сумма
| ИНАЧЕ ВЫБОР
| КОГДА РеализацияТоваровУслугТовары.Ссылка.УчитыватьНДС
| И НЕ РеализацияТоваровУслугТовары.Ссылка.СуммаВключаетНДС
| ТОГДА РеализацияТоваровУслугТовары.Сумма + РеализацияТоваровУслугТовары.СуммаНДС
| КОНЕЦ
| КОНЕЦ) КАК СуммаСНДС,
| РеализацияТоваровУслугТовары.ХарактеристикаНоменклатуры КАК Характеристика,
| РеализацияТоваровУслугТовары.СерияНоменклатуры КАК Серия
|ИЗ
| Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
|ГДЕ
| РеализацияТоваровУслугТовары.Ссылка = &ТекДокумент
|
|СГРУППИРОВАТЬ ПО
| РеализацияТоваровУслугТовары.НомерСтроки,
| РеализацияТоваровУслугТовары.Номенклатура,
| РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Наименование,
| РеализацияТоваровУслугТовары.Номенклатура.Код,
| ВЫБОР
| КОГДА ЕСТЬNULL(РеализацияТоваровУслугТовары.Количество, 0) = 0
| ТОГДА 0
| ИНАЧЕ ВЫРАЗИТЬ(РеализацияТоваровУслугТовары.Сумма / РеализацияТоваровУслугТовары.Количество КАК ЧИСЛО(15, 2))
| КОНЕЦ,
| РеализацияТоваровУслугТовары.ХарактеристикаНоменклатуры,
| РеализацияТоваровУслугТовары.СерияНоменклатуры
|
|УПОРЯДОЧИТЬ ПО
| НомерСтроки
|ИТОГИ
| СУММА(СуммаНДС),
| СУММА(СуммаСНДС)
|ПО
| ОБЩИЕ";

ВыборкаСтрокТоварыИтоги = ЗапросПоТоварам.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
ВыборкаСтрокТоварыИтоги.Следующий();

ВыборкаСтрокТовары = ВыборкаСтрокТоварыИтоги.Выбрать();

Макет = ПолучитьМакет("З2");

ТабДокумент = Новый ТабличныйДокумент;

// Зададим параметры макета
ТабДокумент.ПолеСверху         = 0;
ТабДокумент.ПолеСлева          = 10;
ТабДокумент.ПолеСнизу          = 0;
ТабДокумент.ПолеСправа         = 0;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
   
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПередачаТоваров_З2";

// Выводим общие реквизиты шапки
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");

СведенияОбОрганизации = ОбщегоНазначения.СведенияОЮрФизЛице(Шапка.Организация, Шапка.ДатаДокумента);
ТекстРНН_БИН   = "";

ОбластьМакета.Параметры.Заполнить(Шапка);
ОбластьМакета.Параметры.ПредставлениеОрганизации = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,");
ОбластьМакета.Параметры.ПредставлениеОтправителя = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,");
ОбластьМакета.Параметры.ОрганизацияРНН_БИН = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "БИН_ИИН,", Ложь, Шапка.ДатаДокумента, "ru");
ОбластьМакета.Параметры.НомерДокумента           = ОбщегоНазначения.ПолучитьНомерНаПечать(СсылкаНаОбъект, глСписокПрефиксовУзлов);

ОтветственныйДляПечати  = "";
ДолжностьОтветственного = "";

Если ТипЗнч(Шапка.Ответственный) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
ДанныеОтветственного = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, Шапка.Ответственный, СсылкаНаОбъект.Дата);
ОтветственныйДляПечати = ДанныеОтветственного.Представление;
ДолжностьОтветственного = ДанныеОтветственного.Должность;
Иначе
ОтветственныйДляПечати = Шапка.Ответственный;
КонецЕсли;

ОбластьМакета.Параметры.ОтветственныйЗаПоставку = ОтветственныйДляПечати;

ПредставлениеПолучателя = ОбщегоНазначения.ОписаниеОрганизации(ОбщегоНазначения.СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.ДатаДокумента), "ПолноеНаименование,");
ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;

ТабДокумент.Вывести(ОбластьМакета);

// Выводим заголовок таблицы
ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
//ЗаголовокТаблицы.Параметры.Валюта = Шапка.ВалютаПредставление;
ТабДокумент.Вывести(ЗаголовокТаблицы);

КоличествоСтрок = ВыборкаСтрокТовары.Количество();

// Выводим многострочную часть документа
ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы");

Пока ВыборкаСтрокТовары.Следующий() Цикл

Если НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.Номенклатура) Тогда
Сообщить("В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.", СтатусСообщения.Важное);
Продолжить;
КонецЕсли;

Если Не УниверсальныеМеханизмы.ПроверитьВыводДляТабличногоДокумента(ТабДокумент, ОбластьМакета) Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
            ТабДокумент.Вывести(ЗаголовокТаблицы);
КонецЕсли;

ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
    ОбластьМакета.Параметры.НомерПП = ВыборкаСтрокТовары.НомерСтроки;
ОбластьМакета.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрокТовары.Номенклатура.НаименованиеПолное) + ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары);
       
ТабДокумент.Вывести(ОбластьМакета);

КонецЦикла;

// Выводим итоги по документу
ОбластьМакета    = Макет.ПолучитьОбласть("Итого");
//ОбластьМакета.Параметры.Валюта = Шапка.ВалютаПредставление;

ОбластьМакета.Параметры.КоличествоПорядковыхНомеровЗаписейПрописью = ЧислоПрописью(КоличествоСтрок, ,",,,,,,,,0");
ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначения.СформироватьСуммуПрописью(?(ЗначениеЗаполнено(ВыборкаСтрокТоварыИтоги.СуммаСНДС),ВыборкаСтрокТоварыИтоги.СуммаСНДС,0), Шапка.ВалютаДокумента);

ТабДокумент.Вывести(ОбластьМакета);

// вывод подписей
ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ОбластьМакета.Параметры.Заполнить(Шапка);

ОбластьМакета.Параметры.Доверенность = СокрЛП(Шапка.Доверенность);
ОбластьМакета.Параметры.ЧерезКого    = СокрЛП(Шапка.ЧерезКого);

Руководители = ОбщегоНазначения.ОтветственныеЛицаОрганизаций(Шапка.Организация, Шапка.ДатаДокумента,);
Бухгалтер    = ?(НЕ ЗначениеЗаполнено(Руководители.ГлавныйБухгалтер), "Не предусмотрен", Руководители.ГлавныйБухгалтер);
ОбластьМакета.Параметры.ГлБухгалтер = Бухгалтер;

// заполняем ответстенного за разрешения отпуска товара
Если ЗначениеЗаполнено(Шапка.ОтпускРазрешил) Тогда
ДанныеМОЛ = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, Шапка.ОтпускРазрешил, СсылкаНаОбъект.Дата);
ОбластьМакета.Параметры.ОтпускРазрешил          = ДанныеМОЛ.Представление;
ОбластьМакета.Параметры.ОтпускРазрешилДолжность = ДанныеМОЛ.Должность;
Иначе
ОбластьМакета.Параметры.ОтпускРазрешил          = ОтветственныйДляПечати;
ОбластьМакета.Параметры.ОтпускРазрешилДолжность = ДолжностьОтветственного;
КонецЕсли;

// заполняем ответстенного за отпуск товара
Если ЗначениеЗаполнено(Шапка.ОтпускПроизвел) Тогда
ДанныеМОЛ = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, Шапка.ОтпускПроизвел, СсылкаНаОбъект.Дата);
ОбластьМакета.Параметры.МОЛОтпустил = ДанныеМОЛ.Представление;
Иначе
Если ЗначениеЗаполнено(Шапка.Склад) Тогда
ДанныеМОЛ = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, Шапка.МОЛ, СсылкаНаОбъект.Дата);
ОбластьМакета.Параметры.МОЛОтпустил = ДанныеМОЛ.Представление;
КонецЕсли;
КонецЕсли;                    
   
ТабДокумент.Вывести(ОбластьМакета);

Возврат ТабДокумент;

КонецФункции // Печать()

// Функция формирует табличный документ унифицированной формы З-8
//
// Параметры:
//  Нет.
//
// Возвращаемое значение:
//  Табличный документ по форме З-8.
//
Функция ПечатьРасходныйОрдерНаТовары() Экспорт

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекДокумент", СсылкаНаОбъект);
Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект.Дата);

Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| РасходныйОрдерНаТовары.Номер,
| РасходныйОрдерНаТовары.Дата КАК ДатаДокумента,
| РасходныйОрдерНаТовары.Контрагент КАК Получатель,
| РасходныйОрдерНаТовары.Контрагент КАК Контрагент,
| РасходныйОрдерНаТовары.Организация,
| РасходныйОрдерНаТовары.Организация КАК Поставщик,
| ВЫБОР
| КОГДА РасходныйОрдерНаТовары.Ответственный.ФизЛицо <> ЗНАЧЕНИЕ(Справочник.ФизическиеЛица.ПустаяСсылка)
| ТОГДА РасходныйОрдерНаТовары.Ответственный.ФизЛицо
| ИНАЧЕ РасходныйОрдерНаТовары.Ответственный
| КОНЕЦ КАК Ответственный,
| ОтветственныеЛицаСклад.ФизическоеЛицо КАК МОЛОтпустил,
| Константы.ВалютаРегламентированногоУчета КАК ВалютаДокумента,
| Константы.ВалютаРегламентированногоУчета.Представление КАК ВалютаПредставление
|ИЗ
| Документ.РасходныйОрдерНаТовары КАК РасходныйОрдерНаТовары
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних(&Дата, ) КАК ОтветственныеЛицаСклад
| ПО РасходныйОрдерНаТовары.Склад = ОтветственныеЛицаСклад.СтруктурнаяЕдиница,
| Константы КАК Константы
|ГДЕ
| РасходныйОрдерНаТовары.Ссылка = &ТекДокумент";

Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();

ЗапросПоТоварам = Новый Запрос();
ЗапросПоТоварам.УстановитьПараметр("ТекДокумент", СсылкаНаОбъект);
ЗапросПоТоварам.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| РасходныйОрдерНаТовары.Номенклатура КАК Номенклатура,
| ВЫРАЗИТЬ(РасходныйОрдерНаТовары.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК ТоварНаименование,
| РасходныйОрдерНаТовары.ХарактеристикаНоменклатуры КАК Характеристика,
| РасходныйОрдерНаТовары.СерияНоменклатуры КАК Серия,
| РасходныйОрдерНаТовары.Номенклатура.Код КАК ТоварКод,
| ЕСТЬNULL(РасходныйОрдерНаТовары.Количество, 0) КАК Количество,
| РасходныйОрдерНаТовары.ЕдиницаИзмерения КАК ЕдиницаИзмеренияНаименование,
| РасходныйОрдерНаТовары.НомерСтроки КАК НомерСтроки,
| 0 КАК Метка
|ИЗ
| Документ.РасходныйОрдерНаТовары.Товары КАК РасходныйОрдерНаТовары
|ГДЕ
| РасходныйОрдерНаТовары.Ссылка = &ТекДокумент
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ
| РасходныйОрдерНаТовары.Номенклатура,
| ВЫРАЗИТЬ(РасходныйОрдерНаТовары.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)),
| NULL,
| NULL,
| РасходныйОрдерНаТовары.Номенклатура.Код,
| ЕСТЬNULL(РасходныйОрдерНаТовары.Количество, 0),
| РасходныйОрдерНаТовары.Номенклатура.ЕдиницаХраненияОстатков.Представление,
| РасходныйОрдерНаТовары.НомерСтроки,
| 1
|ИЗ
| Документ.РасходныйОрдерНаТовары.ВозвратнаяТара КАК РасходныйОрдерНаТовары
|ГДЕ
| РасходныйОрдерНаТовары.Ссылка = &ТекДокумент
|
|УПОРЯДОЧИТЬ ПО
| Метка,
| НомерСтроки";


ВыборкаСтрокТовары =  ЗапросПоТоварам.Выполнить().Выбрать();

Макет = ПолучитьМакет("З2");

ТабДокумент = Новый ТабличныйДокумент;

// Зададим параметры макета
ТабДокумент.ПолеСверху         = 0;
ТабДокумент.ПолеСлева          = 10;
ТабДокумент.ПолеСнизу          = 0;
ТабДокумент.ПолеСправа         = 0;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПередачаТоваров_З2";

// Выводим общие реквизиты шапки
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");

СведенияОбОрганизации = ОбщегоНазначения.СведенияОЮрФизЛице(Шапка.Организация, Шапка.ДатаДокумента);
ТекстРНН_БИН   = "";

ОбластьМакета.Параметры.Заполнить(Шапка);
ОбластьМакета.Параметры.ПредставлениеОрганизации = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,");
ОбластьМакета.Параметры.ПредставлениеОтправителя = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,");
ОбластьМакета.Параметры.ОрганизацияРНН_БИН = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "БИН_ИИН,", Ложь, Шапка.ДатаДокумента, "ru");
ОбластьМакета.Параметры.НомерДокумента           = ОбщегоНазначения.ПолучитьНомерНаПечать(СсылкаНаОбъект, глСписокПрефиксовУзлов);

ОтветственныйДляПечати  = "";
ДолжностьОтветственного = "";

Если ТипЗнч(Шапка.Ответственный) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
ДанныеОтветственного = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, Шапка.Ответственный, СсылкаНаОбъект.Дата);
ОтветственныйДляПечати = ДанныеОтветственного.Представление;
ДолжностьОтветственного = ДанныеОтветственного.Должность;
Иначе
ОтветственныйДляПечати = Шапка.Ответственный;
КонецЕсли;

ОбластьМакета.Параметры.ОтветственныйЗаПоставку = ОтветственныйДляПечати;

ПредставлениеПолучателя = ОбщегоНазначения.ОписаниеОрганизации(ОбщегоНазначения.СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.ДатаДокумента), "ПолноеНаименование,");
ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;

ТабДокумент.Вывести(ОбластьМакета);

// Выводим заголовок таблицы
ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
// ЗаголовокТаблицы.Параметры.Валюта = Шапка.ВалютаПредставление;
ТабДокумент.Вывести(ЗаголовокТаблицы);

КоличествоСтрок = ВыборкаСтрокТовары.Количество();

// Выводим многострочную часть документа
ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы");

ИтогоКоличество  = 0;
ИтогоСумма       = 0;


Пока ВыборкаСтрокТовары.Следующий() Цикл

Если НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.Номенклатура) Тогда
Сообщить("В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.", СтатусСообщения.Важное);
Продолжить;
КонецЕсли;

Если Не УниверсальныеМеханизмы.ПроверитьВыводДляТабличногоДокумента(ТабДокумент, ОбластьМакета) Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
            ТабДокумент.Вывести(ЗаголовокТаблицы);
КонецЕсли;

ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
    ОбластьМакета.Параметры.НомерПП = ВыборкаСтрокТовары.НомерСтроки;
ОбластьМакета.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрокТовары.Номенклатура.НаименованиеПолное) + ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары);
       
ТабДокумент.Вывести(ОбластьМакета);

ИтогоКоличество = ИтогоКоличество + ВыборкаСтрокТовары.Количество;

КонецЦикла;

// Выводим итоги по документу
ОбластьМакета    = Макет.ПолучитьОбласть("Итого");
//ОбластьМакета.Параметры.Валюта = Шапка.ВалютаПредставление;

ОбластьМакета.Параметры.КоличествоПорядковыхНомеровЗаписейПрописью = ЧислоПрописью(КоличествоСтрок, ,",,,,,,,,0");
ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначения.СформироватьСуммуПрописью(ИтогоСумма, Шапка.ВалютаДокумента);

ТабДокумент.Вывести(ОбластьМакета);

// вывод подписей
ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ОбластьМакета.Параметры.Заполнить(Шапка);

Руководители = ОбщегоНазначения.ОтветственныеЛицаОрганизаций(Шапка.Организация, Шапка.ДатаДокумента,);
Бухгалтер    = ?(НЕ ЗначениеЗаполнено(Руководители.ГлавныйБухгалтер), "Не предусмотрен", Руководители.ГлавныйБухгалтер);
ОбластьМакета.Параметры.ГлБухгалтер = Бухгалтер;

// заполняем ответсвтенного за отпуск товара
Если ЗначениеЗаполнено(Шапка.МОЛОтпустил) Тогда
ДанныеМОЛ = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, Шапка.МОЛОтпустил, Шапка.ДатаДокумента);
ОбластьМакета.Параметры.МОЛОтпустил = ДанныеМОЛ.Представление;
КонецЕсли;
   
ТабДокумент.Вывести(ОбластьМакета);

Возврат ТабДокумент;

КонецФункции // Печать()
     
Функция Печать() Экспорт
Если ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
Возврат ПечатьРеализацияТоваровиУслуг();
ИначеЕсли ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.РасходныйОрдерНаТовары") Тогда
        Возврат ПечатьРасходныйОрдерНаТовары() ;
КонецЕсли;
КонецФункции

Последний раз редактировалось: MuI_I_Ika; 05 Фев 2014, 14:56

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Блин! без тегов кода глаза ломает текст :dfbsdfbsdf:
Добавлено: 05 Фев 2014, 14:55

У Вас вообще нет общего модуля "ФормированиеПечатныхФорм" в конфигурации - вот что.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн mister-q88

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
как по умному его выложить с цветными буквами?

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А вы уверены что эта обработка подходит для этой конфигурации?

Если нет общего модуля ФормированиеПечатныхФорм, то может не быть многих функций и процедур и других модулей.

Оффлайн mister-q88

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Я ее нашел на нашем сайте, там человек пишет что она идет кросплатформенная и что другие люди ее скачивали, что вроде рабочая.
 

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Значит поиском в конфигурации найдите функцию ПредставлениеСерий()

Определите в каком она модуле. Если в том же, то проверьте у него галочку глобальный. Если модуль глобальный, то просто поменяйте в обработке вызов функции без указания модуля.

Если функция в другом модуле, то переделайте вызов на него.

Если функции нет, то придется дописать ее самостоятельно в обработку.

Оффлайн mister-q88

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Вот честно я полный ноль во все этих делах то что вы мне сказали найти в коде ПредставлениеСерий через поиск нашел а что дальше с ним делать глобальный он или не глобальный я понятия не имею. Вроде с компами и на ты общаюсь, а во все эти програмные дебри никогда не совался. :dfbsdfbsdf::dfbsdfbsdf::dfbsdfbsdf:   

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Я ее нашел на нашем сайте, там человек пишет что она идет кросплатформенная и что другие люди ее скачивали, что вроде рабочая.
 
Могли скачивать под другую конфигурацию. У каждой конфигурации могут быть свои механизмы, а соответственно свои общие отличные модули и процедуры.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4458
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4437
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3868
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание заказаов на производство на основании заказа на производство.

Автор Елена1986Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 7819
Последний ответ 09 Сен 2015, 13:01
от Елена1986
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1180
Последний ответ 26 Сен 2016, 16:25
от NataVl

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 277
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal