Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 04:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите найти ошибку в коде  (Прочитано 1188 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ivan3333567

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2014-01-27
  • Сайт: 
  • Профессия: Ученик 1С
Почему то не правильно заполняет печатную форму в колонке "Колличество", вместо например 4шт, пишет 15

Вот код, помогите пожалуйста:
Строка   = Макет.ПолучитьОбласть("Строка");
ПоследняяСтрока = Макет.ПолучитьОбласть("ПоследняяСтрока");

Для Каждого СтрокаТовар Из ВыборкаСтрокТовары Цикл

НомерСтроки = НомерСтроки + 1;

// Проверим, помещается ли строка с данными и последняя строка (или итоги) на странице.
СтрокаТаблицы = Новый Массив;
СтрокаТаблицы.Добавить(Строка);
Если НЕ (НомерСтроки = ВыборкаСтрокТовары.Количество()) Тогда
СтрокаТаблицы.Добавить(ПоследняяСтрока);
Иначе
СтрокаТаблицы.Добавить(Итого);
КонецЕсли;

Если НЕ ТабДокумент.ПроверитьВывод(СтрокаТаблицы) Тогда

НомерСтраницы = НомерСтраницы + 1;

ТабДокумент.Вывести(ПоследняяСтрока);
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
ЗаголовокТаблицы.Параметры.НомерСтраницы = "Страница " + НомерСтраницы;
ТабДокумент.Вывести(ЗаголовокТаблицы);

КонецЕсли;

СчетДт = СтрокаТовар.СчетДт;
//Поз = Найти(СчетДт, ".");
//СчетДт = ?(Поз>0, Лев(СчетДт, Поз-1), СчетДт);

СчетКт = СтрокаТовар.СчетКт;
//Поз = Найти(СчетКт, ".");
//СчетКт = ?(Поз>0, Лев(СчетКт, Поз-1), СчетКт);

Строка.Параметры.Заполнить(СтрокаТовар);
        Строка.Параметры.ПричинаСписания = СокрЛП(СсылкаНаОбъект.Комментарий);
Строка.Параметры.СчетДт = СчетДт;
Строка.Параметры.СчетКт = СчетКт;

ТабДокумент.Вывести(Строка);

ИтогоКоличество  = ИтогоКоличество + Строка.Параметры.Количество;
ИтогоСуммаПервоначальнойСтоимости = ИтогоСуммаПервоначальнойСтоимости + Строка.Параметры.СуммаПервоначальнойСтоимости;

КонецЦикла;

// Выводим итоги по документу
Итого.Параметры.КоличествоПорядковыхНомеровЗаписейПрописью = ЧислоПрописью(ВыборкаСтрокТовары.Итог("Количество"), ,",,,,,,,,0");
Итого.Параметры.ИтогоСуммаПервоначальнойСтоимости = Формат(ИтогоСуммаПервоначальнойСтоимости, "ЧЦ=15; ЧДЦ=2; ЧРД=.; ЧРГ=' '");
ТабДокумент.Вывести(Итого);

// Проверим, помещается ли подвал
Если НЕ ТабДокумент.ПроверитьВывод(Подвал) Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
посмотри в отладчике ТЗ "ВыборкаСтрокТовары"
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4290
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5545
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5880
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4360
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 216
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal