Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 20:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Движение документа в регистр при условии  (Прочитано 1662 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Есть документы, которые должны попадать в регистр сведений когда будет определенная дата, как это осуществить у кого ни будь может есть примеры, помогите пожалуйста


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Если Дата = НужнаяДата Тогда

//Делаем движение

КонецЕсли;

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Если Дата = НужнаяДата Тогда

//Делаем движение

КонецЕсли;
наверное не совсем корректно вопрос задал, допустим в документе ставится дата начала (20.03.2014) курса и дата окончания (20.04.2014),
нужно чтобы когда дата достигнет 20.04.2014 на компьютере, в 1с совершилось движение документов у которых дата окончания 20.04.2014 в регистр сведений, пишется на сколько знаю это в модуле документа, а вот какую процедуру выбрать так и не могу понять

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Для начала нужно что-то написать в виде обработины, которая бы при загрузки клиентской части проверяла текущую дату и сравнивала с нужной. А потом допилить в модуле проверку по регистрам при проведении, мол
 ТекущаяДата = РабочаяДата();
Если РабочаяДата >= НужнаяДата Тогда
.... // тут мы пилим все что нужно по регистрам
КонецЕсли;
А в обработине, которая грузится по загрузке тоже  ставим

Если ТекущаяДата >= НужнаяДата Тогда
.... //Тут собираем кучу доков, которые нужны и перепроводим их по своим условиям
КонецЕсли;
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
... которая бы при загрузки клиентской части ...

Или при помощи регламентного задания.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Для начала нужно что-то написать в виде обработины, которая бы при загрузки клиентской части проверяла текущую дату и сравнивала с нужной. А потом допилить в модуле проверку по регистрам при проведении, мол
 ТекущаяДата = РабочаяДата();
Если РабочаяДата >= НужнаяДата Тогда
.... // тут мы пилим все что нужно по регистрам
КонецЕсли;
А в обработине, которая грузится по загрузке тоже  ставим

Если ТекущаяДата >= НужнаяДата Тогда
.... //Тут собираем кучу доков, которые нужны и перепроводим их по своим условиям
КонецЕсли;
Спасибо буду пробовать
Добавлено: 04 Фев 2014, 11:17

... которая бы при загрузки клиентской части ...

Или при помощи регламентного задания.
Спасибо


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4485
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15967
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4210
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 643
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7760
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 284
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal