Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите пожалуйста  (Прочитано 1976 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн uliana2009

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-03
  • Сайт: 
  • Профессия: Ученик 1С
Доброй ночи всем
У меня возникла вот такая проблема! При сосдании шахматной ведомости вслівает окошко с ошибкой : Значение не является значением объектного типа (Свойство). Не знаю что мне делать! Программа предлогает перейти в конфигуратор в котором  в модуле вот что прописано :
 
Перем ВысотаЗаголовка;
////////////////////////////////////////////////////////////////////////////////// ПРОЦЕДУРЫ И ФУНКЦИИ ОБЩЕГО НАЗНАЧЕНИЯ
// Обновляет таблицу отчета//// Параметры://      Нет.//Процедура ОбновитьОтчет() Экспорт            СформироватьОтчет(ЭлементыФормы.ДокументРезультат, ПоказыватьЗаголовок, ВысотаЗаголовка);
ЭтаФорма.ТекущийЭлемент = ЭлементыФормы.ДокументРезультат;            БухгалтерскиеОтчеты.УправлениеПометкамиКнопокЗаголовковКоманднойПанели(ЭтаФорма, ПоказыватьЗаголовок);      КонецПроцедуры // ОбновитьОтчет()
//  Управляет выводом заголовка//// Параметры://      Нет.//Процедура ВыводЗаголовка()
БухгалтерскиеОтчеты.ОбработатьВыводЗаголовка(ЭтаФорма, ЭтотОбъект, ВысотаЗаголовка, ПоказыватьЗаголовок);
КонецПроцедуры // ВыводЗаголовка()
// Формирует заголовок формы//// Параметры://      Нет.//Процедура СформироватьЗаголовокФормы()
ОписаниеПериода = БухгалтерскиеОтчеты.СформироватьСтрокуОграниченийПоДатамДляФормы(ДатаНач, ДатаКон);
Заголовок = ЗаголовокОтчета()+" (" + ОписаниеПериода + ") " +       ?(ЗначениеЗаполнено(Организация.НаименованиеПолное), Организация.НаименованиеПолное, Организация);
КонецПроцедуры // СформироватьЗаголовокФормы()
////////////////////////////////////////////////////////////////////////////////// ПРОЦЕДУРЫ - ДЕЙСТВИЯ КОМАНДНЫХ ПАНЕЛЕЙ ФОРМЫ
Процедура КнопкаНастройкаПериодаНажатие(Элемент)
БухгалтерскиеОтчеты.ОбработчикНастройкаПериодаНажатие(ДатаНач, ДатаКон);
КонецПроцедуры // КнопкаНастройкаПериодаНажатие()
////////////////////////////////////////////////////////////////////////////////// ПРОЦЕДУРЫ - ОБРАБОТЧИКИ НАЖАТИЯ КНОПОК КОМАНДНОЙ ПАНЕЛИ
Процедура КоманднаяПанельФормыСформировать(Кнопка)
ОбновитьОтчет();
КонецПроцедуры // КоманднаяПанельФормыСформировать()
Процедура КоманднаяПанельЗаголовок(Кнопка)
ПоказыватьЗаголовок = Не ПоказыватьЗаголовок;      ВыводЗаголовка();
КонецПроцедуры // КоманднаяПанельЗаголовок()
////////////////////////////////////////////////////////////////////////////////// ПРОЦЕДУРЫ - ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ
Процедура ПриЗакрытии()
СтруктураОбщихПараметров = Новый Структура;      СтруктураОбщихПараметров.Вставить("Организация", Организация);      СтруктураОбщихПараметров.Вставить("ДатаНач", ДатаНач);      СтруктураОбщихПараметров.Вставить("ДатаКон", ДатаКон);      СтруктураОбщихПараметров.Вставить("ПоЗабалансовымСчетам", ПоЗабалансовымСчетам);      СтруктураОбщихПараметров.Вставить("ПоВалютам", ПоВалютам);      СтруктураОбщихПараметров.Вставить("ПоСубсчетам", ПоСубсчетам);      СтруктураОбщихПараметров.Вставить("ПоказыватьЗаголовок", ПоказыватьЗаголовок);
СохранитьЗначение("ОбщиеПараметрыОтчетов"+ИмяРегистраБухгалтерии, СтруктураОбщихПараметров);
КонецПроцедуры // ПриЗакрытии()
Процедура ОбновлениеОтображения()
СформироватьЗаголовокФормы();
КонецПроцедуры // ОбновлениеОтображения()
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
ТиповыеОтчеты.НазначитьФормеУникальныйКлючИдентификации(ЭтаФорма);            Если РегламентированнаяОтчетность.ИДКонфигурации() <> "БП" Тогда            // Проверка ведения однофирменности            УчетПоВсемОрганизациям = Истина;      Иначе            УчетПоВсемОрганизациям = глЗначениеПеременной("УчетПоВсемОрганизациям");      КонецЕсли;
СтруктураОбщихПараметров = ВосстановитьЗначение("ОбщиеПараметрыОтчетов"+ИмяРегистраБухгалтерии);      Если ТипЗнч(СтруктураОбщихПараметров) = Тип("Структура") Тогда                        СтруктураОбщихПараметров.Свойство("Организация", Организация);            СтруктураОбщихПараметров.Свойство("ПоСубсчетам",    ПоСубсчетам);            СтруктураОбщихПараметров.Свойство("ПоЗабалансовымСчетам", ПоЗабалансовымСчетам);            СтруктураОбщихПараметров.Свойство("ПоВалютам",   ПоВалютам);            СтруктураОбщихПараметров.Свойство("ДатаНач", ДатаНач);            СтруктураОбщихПараметров.Свойство("ДатаКон", ДатаКон);                  КонецЕсли;
ПоказыватьЗаголовок = Истина;            ВысотаЗаголовка = 0;            БухгалтерскиеОтчеты.ПоддержкаОднофирменностиДляБухОтчетов(ЭтаФорма, Организация, глЗначениеПеременной("УчетПоВсемОрганизациям"));
КонецПроцедуры // ПередОткрытием()
Процедура ПриОткрытии()            ОбновитьОтчет();      СформироватьЗаголовокФормы();   
КонецПроцедуры // ПриОткрытии()
Процедура ДокументРезультатОбработкаРасшифровки(ЭлементУправления, Расшифровка, СтандартнаяОбработка)      Перем СчетДт, СчетКт, ВалютаДт, ВалютаКт;
Если ТипЗнч(Расшифровка) =  Тип("Структура") Тогда                        СчетДт = Неопределено;            ВалютаДт = Неопределено;                        Если Не Расшифровка.Свойство("СчетДт", СчетДт) Тогда                  СтандартнаяОбработка = Ложь;                  Возврат;            КонецЕсли;                        Если Не Расшифровка.Свойство("ВалютаДт", ВалютаДт) Тогда                  СтандартнаяОбработка = Ложь;                  Возврат;            КонецЕсли;                  Иначе            Если ЭлементУправления.ТекущаяОбласть.Верх = ВысотаЗаголовка + 2 Тогда                  СчетДт = Неопределено;            Иначе                  СчетДт = Расшифровка;            КонецЕсли;      КонецЕсли;            // Расшифровка колонки находится в заголовке колонки      РасшифровкаКолонки = ЭлементУправления.Область(ВысотаЗаголовка + 2, ЭлементУправления.ТекущаяОбласть.Лево).Расшифровка;            Если ТипЗнч(РасшифровкаКолонки) =  Тип("Структура") Тогда            СчетКт = РасшифровкаКолонки.СчетКт;            ВалютаКт = РасшифровкаКолонки.ВалютаКт;      Иначе            СчетКт = РасшифровкаКолонки;      КонецЕсли;            ВыбраннаяРасшифровка = Новый Структура("СчетДт, СчетКт, ВалютаДт, ВалютаКт", СчетДт, СчетКт, ВалютаДт, ВалютаКт);            // Добавим общую расшифровку из левого верхнего угла      ОбщаяРасшифровка = ЭлементУправления.Область(1,1).Расшифровка;            Если ТипЗнч(ОбщаяРасшифровка) = Тип("Структура")             ИЛИ ТипЗнч(ОбщаяРасшифровка) = Тип("Соответствие") Тогда                        Для Каждого Элемент Из ОбщаяРасшифровка Цикл                  ВыбраннаяРасшифровка.Вставить(Элемент.Ключ, Элемент.Значение);            КонецЦикла;      КонецЕсли;
ОбработкаРасшифровкиСтандартногоОтчета(ВыбраннаяРасшифровка);            СтандартнаяОбработка = Ложь;
КонецПроцедуры // ДокументРезультатОбработкаРасшифровки()
Процедура ПередСохранениемЗначений(Отказ)
СохраняемыеРеквизиты = Новый Структура;
СохраняемыеРеквизиты.Вставить("Организация", Организация);      СохраняемыеРеквизиты.Вставить("ПоВалютам", ПоВалютам);      СохраняемыеРеквизиты.Вставить("ПоЗабалансовымСчетам", ПоЗабалансовымСчетам);      СохраняемыеРеквизиты.Вставить("ПоСубсчетам", ПоСубсчетам);
КонецПроцедуры // ПередСохранениемЗначений()
Процедура ПослеВосстановленияЗначений()
СохраняемыеРеквизиты.Свойство("Организация", Организация);      СохраняемыеРеквизиты.Свойство("ПоВалютам", ПоВалютам);      СохраняемыеРеквизиты.Свойство("ПоЗабалансовымСчетам", ПоЗабалансовымСчетам);      СохраняемыеРеквизиты.Свойство("ПоСубсчетам", ПоСубсчетам);
КонецПроцедуры // ПослеВосстановленияЗначений()

Я студентка и еще совсем не освояла 1С. Буду благодарна если мне кто то поможет уж очень нужно!!!

Последний раз редактировалось: MuI_I_Ika; 03 Фев 2014, 14:01


Оффлайн Alex56

  • *****
  • Сообщений: 828
  • РЕПУТАЦИЯ: 11
  • КПД: 1%
  • Регистрация: 2013-10-02
  • Сайт: itoren.ucoz.ru
  • Профессия: Ученик 1С
Нужно постоянно трудиться.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
uliana2009, оформляйте код тегом пжл, так не читабельно выглядит

Оффлайн tepliym

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-01-28
  • Сайт: 
  • Профессия: Программист 8.1
uliana2009, оформляйте код тегом пжл, так не читабельно выглядит

Это само собой, и пжл какая конф ? стандартный отчет, нет? выложите весь отчет как внешний.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
У вас в коде очень много "свойств". Укажите на какую строчку ругается программа.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5891
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4373
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 287
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal