Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 23:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1c 8.2 конфигурация салон красоты  (Прочитано 3481 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн x2ermak

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-02
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
Помогите разобраться с конфигурацией 1с салон красоты

суть вопроса в следующем:
 
При создании "графика работы сотрудников" в окне "отмеченные дни" пусто, хотя в рабочей конфигурации должна быть таблица.
Я так подозреваю, что я не заполнил какое-то поле.... может кто сталкивался с подобной проблемой.

Если в "графике работы" нажимаю сохранить, возникает следующая ошибка :
 
{Обработка.ГрафикРаботыСотрудников.Форма.Форма.Форма(530)}: Индекс находится за границами массива
    НаборЗаписейРегистра.Отбор.СтруктурнаяЕдиница.Установить(ГрафикПериодовРаботы[0].СтруктурнаяЕдиница);


В конфигураторе это выглядит так:

Процедура СохранитьИзменения(Период)
   
   НаборЗаписейРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьНаборЗаписей();
   НаборЗаписейРегистра.Отбор.СтруктурнаяЕдиница.Установить(ГрафикПериодовРаботы[0].СтруктурнаяЕдиница);
   НаборЗаписейРегистра.Отбор.МесяцОтбор.Установить(НачалоМесяца(ГрафикПериодовРаботы[0].Период));
   НаборЗаписейРегистра.Прочитать();
   ТаблицаЗаписейРегистра = НаборЗаписейРегистра.Выгрузить();
   
   // Удаляем период удаленные из графика
   Для Каждого СтрокаРегистра Из ТаблицаЗаписейРегистра Цикл
      СтруктураЗаписи = Новый Структура("СтруктурнаяЕдиница, Сотрудник", СтрокаРегистра.СтруктурнаяЕдиница, СтрокаРегистра.Сотрудник);
      МассивСтрокГрафика = ГрафикПериодовРаботы.НайтиСтроки(СтруктураЗаписи);
      СтрокаРегистраАктуальна = Ложь;
      Для Каждого СтрокаГрафика Из МассивСтрокГрафика Цикл
         Для Каждого ПериодДняГрафика Из СтрокаГрафика["День" + День(СтрокаРегистра.ДатаВремяНачала)] Цикл
            Если ПериодДняГрафика.Значение.НачалоСмены = СтрокаРегистра.ДатаВремяНачала И ПериодДняГрафика.Значение.ОкончаниеСмены = СтрокаРегистра.ДатаВремяОкончания Тогда
               СтрокаРегистраАктуальна = Истина;
            КонецЕсли;
         КонецЦикла;
      КонецЦикла;
      Если СтрокаРегистраАктуальна = Ложь Тогда
         МенеджерЗаписиРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьМенеджерЗаписи();
         ЗаполнитьЗначенияСвойств(МенеджерЗаписиРегистра, СтрокаРегистра);
         МенеджерЗаписиРегистра.Удалить();
      КонецЕсли;      
   КонецЦикла;
   
   // Удаляем периоды добавленные в график
   Для Каждого СтрокаГрафика Из ГрафикПериодовРаботы Цикл
      Для ДеньГрафика = 1 По 31 Цикл
         Для Каждого ПериодДняГрафика Из СтрокаГрафика["День" + ДеньГрафика] Цикл
            СтруктураЗаписи = Новый Структура("СтруктурнаяЕдиница, Сотрудник, ДатаВремяНачала, ДатаВремяОкончания", СтрокаГрафика.СтруктурнаяЕдиница, СтрокаГрафика.Сотрудник, ПериодДняГрафика.Значение.НачалоСмены, ПериодДняГрафика.Значение.ОкончаниеСмены);
            Если ТаблицаЗаписейРегистра.НайтиСтроки(СтруктураЗаписи).Количество() = 0 Тогда
               МенеджерЗаписиРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьМенеджерЗаписи();
               МенеджерЗаписиРегистра.СтруктурнаяЕдиница = СтрокаГрафика.СтруктурнаяЕдиница;
               МенеджерЗаписиРегистра.Сотрудник = СтрокаГрафика.Сотрудник;
               МенеджерЗаписиРегистра.МесяцОтбор = СтрокаГрафика.Период;
               МенеджерЗаписиРегистра.ДатаВремяНачала = ПериодДняГрафика.Значение.НачалоСмены;
               МенеджерЗаписиРегистра.ДатаВремяОкончания = ПериодДняГрафика.Значение.ОкончаниеСмены;
               МенеджерЗаписиРегистра.Минуты = (ПериодДняГрафика.Значение.ОкончаниеСмены - ПериодДняГрафика.Значение.НачалоСмены) / 60;
               МенеджерЗаписиРегистра.Записать();
            КонецЕсли;
         КонецЦикла;
      КонецЦикла;
   КонецЦикла;
   
   МодифицированностьГрафикаРаботы = Ложь;





Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Платформа какая? :xfbnsdfb:
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн x2ermak

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-02
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Если обновление конфигурации - одно из последних, то думаю что с этой платформой эта конфигурация работать не будет нормально.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн x2ermak

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-02
  • Сайт: 
  • Профессия: Ученик 1С
Обновил платформу на 8.2.19.83... такая-же ситуация. Может дело в конфигурации ??:(


Теги:
 

Конфигурация "1С:Оценка персонала"

Автор lyuberРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4675
Последний ответ 05 Авг 2011, 11:09
от chuevsf
конфигурация "Управление торговлей 10.3" для 8.2

Автор bahtovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3234
Последний ответ 18 Окт 2011, 13:22
от bahtovar
Права и конфигурация "кладовщик"

Автор DetsleРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 589
Последний ответ 14 Июн 2017, 13:13
от xdto
При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 497
Последний ответ 20 Сен 2017, 09:10
от Геннадий ОбьГЭС
Разыскивается Конфигурация "Инпро:Мука 8"

Автор aapospelovРаздел Беседка

Ответов: 0
Просмотров: 2220
Последний ответ 08 Мар 2011, 10:02
от aapospelov

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 296
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal