Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 22:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как в модуле объекта обратиться к реквизиту другого документа?  (Прочитано 10351 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Как в модуле объекта одного документа обратиться к реквизиту другого документа?
В моём случае, нужно получить значение реквезита ДатаПриёма из документа ПриёмНаРаботу в организацию. Подскажите как это правильнее осуществить?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
получаешь ссылку на нужный тебе документ (запросом или выборкой или как там тебе нужно) и через точку обращаешься к реквизиту

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Как можно получить ссылку на документ при помощи выборки?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Пока Выборка.Следуюший() Цикл

    Если Выборка.Номер = "0001" Тогда//это примерный код
        ТекущийДокумент = Выборка.Ссылка;
        Прервать;
    КонецЕсли;

КонецЦикла
;

А вообще учитесь пользоваться запросами.

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Документы.РеализацияТоваровУслуг.НайтиПоНомеру("БФ00-000001", дата("20140101")).Дата

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Пока Выборка.Следуюший() Цикл

    Если Выборка.Номер = "0001" Тогда//это примерный код
        ТекущийДокумент = Выборка.Ссылка;
        Прервать;
    КонецЕсли;

КонецЦикла
;

А вообще учитесь пользоваться запросами.

Этот цикл надо писать после запроса?
Добавлено: 31 Янв 2014, 14:56

Забыл сказать, что нужно получить "ДатаПриёма" в соответствии с выбранным работником.(Настраиваю автозамену в макете Active document)
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Последний раз редактировалось: TreeDogNight; 31 Янв 2014, 14:56. Причина: Объединение сообщений

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Либо после выборки либо после запроса.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Сделал через выборку, вышла ошибка:
Цитировать
{Документ.УвольнениеИзОрганизаций(526)}: Метод объекта не обнаружен (Следуюший)
   Пока Выборка.Следуюший() Цикл
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Учитесь работать с синтакс- помошником

ДокументМенеджер.<Имя документа> (DocumentManager.<Имя документа>)
Выбрать (Select)
Синтаксис:

Выбрать(<ДатаНачала>, <ДатаОкончания>, <Отбор>, <Порядок>)
Параметры:

<ДатаНачала> (необязательный)

Тип: Дата.
Дата и время начала периода выборки документов. Если параметр не указан, то выбираются все документы, начиная с самого первого документа в базе данных.
Значение по умолчанию: Пустая дата.
<ДатаОкончания> (необязательный)

Тип: Дата.
Дата окончания периода выбираемых документов. Если параметр не указан, то выбираются все документы, заканчивая самым последним документом в базе данных.
Значение по умолчанию: Пустая дата.
<Отбор> (необязательный)

Тип: Структура.
Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться только поля "Дата" и реквизиты документа, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядочиванием".
Важно! Структура может содержать только один элемент.
Если параметр не указан, то отбор не используется.
<Порядок> (необязательный)

Тип: Строка.
Строка с именем реквизита документа, определяющая упорядочивание документов в выборке. Может быть указано поле "Дата" или имя реквизита документа, для которого признак индексирования в конфигураторе установлен в значения "Индексировать" или "Индексировать с доп. упорядочиванием". После указания имени через пробел может быть указано направление сортировки. Направление определяется: "Убыв" ("Desc") - упорядочивать по убыванию, и "Возр" ("Asc") - упорядочивать по возрастанию. По умолчанию выборка упорядочивается по возрастанию.
Если параметр не задан, выборка упорядочивается по хронологии документов.
Возвращаемое значение:

Тип: ДокументВыборка.

Описание:

Формирует выборку документов за определенный период. Получаемая выборка может быть упорядочена по реквизитам документа.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
Пример:

Выборка = Документы.РасходнаяНакладная.Выбрать(ДатаНач, ДатаКон);
 

Добавлено: 31 Янв 2014, 15:53

ДокументВыборка.<Имя документа> (DocumentSelection.<Имя документа>)
Свойства:

<Имя общего реквизита> (<Common attribute name>)
<Имя реквизита> (<Attribute name>)
<Имя табличной части> (<Tabular section name>)
ВерсияДанных (DataVersion)
Дата (Date)
Номер (Number)
ПометкаУдаления (DeletionMark)
Проведен (Posted)
Ссылка (Ref)

Методы:

ПолучитьОбъект (GetObject)
Следующий (Next)

Описание:

Объект этого типа возвращается методом Выбрать у объекта типа ДокументМенеджер.<Имя документа> и представляет собой специализированный способ перебора документов.
Обход документов выполняется системой динамически. Это означает, что использование выборки не считывает все документы сразу, а выбирает их порциями из базы данных. Такой подход позволяет достаточно быстро обходить с помощью выборки большие списки документов и не загружает в память всех элементов выборки.
Важно! Данному объекту доступны все свойства объекта ДокументСсылка.<Имя документа>.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
См. также:

ДокументМенеджер, метод Выбрать
ДокументОбъект
ДокументСсылка
ЖурналДокументовМенеджер, метод Выбрать
Добавлено: 31 Янв 2014, 15:54

ДокументВыборка.<Имя документа> (DocumentSelection.<Имя документа>)
Следующий (Next)
Синтаксис:

Следующий()
Возвращаемое значение:

Тип: Булево.
Истина - следующий документ выбран. Ложь - достигнут конец выборки.
Описание:

Получает следующий документ из выборки. Для обхода списка документов нужно после получения выборки использовать данный метод для позиционирования на первый и последующие документы выборки до тех пор, пока он не вернет значение Ложь.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
Пример:

Выборка = Документы.ПоступлениеТоваров.Выбрать();
Пока Выборка.Следующий() Цикл
    // обработка записи выборки
КонецЦикла;
 


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4467
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 616
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7734
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4768
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 334
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal