Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 21:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не отрабатывает запрос  (Прочитано 1102 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн CARtMEN

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-03
  • Сайт: 
  • Профессия: Программист 8.1

Прибыл я из 8.2. В запросах 7.7 работал только с документами. Что-то получалось. Решил выборку по справочнику сделать и не получается. Вот 2 запроса, которые я пробовал.
"//{{ЗАПРОС(Сформировать11)
|ТекущийЭлемент = Справочник.Модель.ТекущийЭлемент;
|Наименование = Справочник.Модель.Наименование;
|ОсновнойЧехол = Справочник.Модель.ОсновнойЧехол;
|Группировка ТекущийЭлемент;
|Условие(Наименование = пНаименование);
|"//}}ЗАПРОС
|";




// 2ой запрос
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать11)
|ТекущийЭлемент = Справочник.Модель.ТекущийЭлемент;
|Наименование = Справочник.Модель.Наименование;
|ОсновнойЧехол = Справочник.Модель.ОсновнойЧехол;
|Группировка ТекущийЭлемент;
|Группировка Наименование;
|Группировка ОсновнойЧехол;
|Условие(Наименование = пНаименование);
|"//}}ЗАПРОС
|";

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Сообщить("Ошибка запроса 11");   
Иначе
Если Запрос.Группировка() = 1 Тогда
пМодель = Запрос.ТекущийЭлемент;
пЧехол  = Запрос.ОсновнойЧехол;
КонецЕсли;
КонецЕсли;


Запросы отрабатывают, но ничего не возвращают, хотя искомый элемент в справочнике есть? И да я понимаю, что можно осуществить поиск выборкой, но у меня есть еще и другие запросы, где не только по наименованию поиск ведется. Хочу понять в чем дело!


Оффлайн Mitay_D

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-02-02
  • Сайт: 
  • Профессия: Программист 7.7
1. воспользуйтесь конструктором запрос.
2.
	
|"//}}ЗАПРОС
;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Пока Запрос.Группировка(1) = 1 Цикл   
    ......
            ......
        КонецЦикла;

   
Это если одна группировка, а если больше, то и Циклов больше
      


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 314
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal