Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 12:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как поместить в одну ячейку сразу два параметра?  (Прочитано 4157 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ivan3233567

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-01-28
  • Сайт: 
  • Профессия: Ученик 1С
Я создал внешнюю обработку с нужным мне макетом, но столкнулся с проблемой, что Данные Склада у обоих документов отличаются. Во время обработки я выбираю оба эти документа и мне нужно чтобы с обоих этих документов мне печатало Склад.
Добавлять новую колонку нельзя, менять в документе Данные Склада тоже нельзя.
Я пока еще плохо разбираюсь в 1с, поэтому прошу показать рабочий код на такой случай и желательно с объяснением куда его поместить.


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6571
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
При выборе смотрите на тип документа и в зависимости от этого берите нужный реквизит.

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Строка.Параметры["Склады"] = Склад.Наименование + ", " + Склад.Наименование;


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6571
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Если ЭтотОбъект.Метаданные().Имя = "ПоступлениеТоваровИУслуг" Тода
    Строка.Параметры["Склады"] = СкладОрдер.Наименование + ", " + СкладОрдер.Наименование;
Иначе
    Строка.Параметры["Склады"] = Склад.Наименование + ", " + Склад.Наименование;
КонецЕсли;

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6571
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПечатьРеестра(МассивДокументов,ИндикаторОбработки = Неопределено) Экспорт

Макет = ПолучитьМакет("РеестрДокументов");
ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент.Вывести(Макет.ПолучитьОбласть("Заголовок"));
ТабличныйДокумент.Вывести(Макет.ПолучитьОбласть("ШапкаТаблицы"));

индекс = 1;
Для каждого Ссылка Из МассивДокументов Цикл

Область = Макет.ПолучитьОбласть("Строка");
Область.Параметры.Заполнить(Ссылка);
Область.Параметры.ВидДокумента = Ссылка.Метаданные().Синоним;
Область.Параметры.НомерСтроки = индекс;
   
индекс = индекс + 1;
//Область.Параметры.ДокРасшифровка = Ссылка;

                Если Ссылка.Метаданные().Имя = "ПоступлениеТоваровУслуг" Тогда
                Область.Параметры["Склады"] = Ссылка.СкладОрдер.Наименование + ", " + Ссылка.СкладОрдер.Наименование;
        Иначе
              Область.Параметры["Склады"] = Ссылка.Склад.Наименование + ", " + Ссылка.Склад.Наименование;
        КонецЕсли;

ТабличныйДокумент.Вывести(Область);

Сообщить(Ссылка);

Если Не ИндикаторОбработки = Неопределено Тогда
ИндикаторОбработки = ИндикаторОбработки + 1;
КонецЕсли;

КонецЦикла;



ТабличныйДокумент.ПолеСверху = 0;
ТабличныйДокумент.ПолеСлева  = 0;
ТабличныйДокумент.ПолеСнизу  = 0;
ТабличныйДокумент.ПолеСправа = 0;
ТабличныйДокумент.Автомасштаб = Истина;
ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;

ТабличныйДокумент.ОтображатьЗаголовки = Ложь;
ТабличныйДокумент.ОтображатьСетку     = Ложь;
ТабличныйДокумент.ТолькоПросмотр      = Истина;
ТабличныйДокумент.Показать();
Сообщить("-----------------------------------------------------------", СтатусСообщения.БезСтатуса);
Сообщить("Выполнение обработки завершено", СтатусСообщения.БезСтатуса);
КонецПроцедуры // ПечатьРеестра()

Оффлайн Ivan3233567

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-01-28
  • Сайт: 
  • Профессия: Ученик 1С
А где смотреть Наименование?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6571
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Ivan3233567, Наименование чего?

Оффлайн Ivan3233567

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-01-28
  • Сайт: 
  • Профессия: Ученик 1С
Ivan3233567, Наименование чего?
Все я сам разобрался, спасибо огромное!!
Но появляется ошибка что поле "Склад" не обнаружено, если в обработку добавить документ без поля склад.
Как доработать это условие, чтобы он игнорировал отсутствие поля "Склад" и просто не писал там ничего?

Оффлайн Ivan3333567

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2014-01-27
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 

Регламентные задания "Недопустимое значение параметра (параметр номер "1")

Автор pyvfРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 17560
Последний ответ 27 Фев 2013, 11:57
от reshkra
СКД. Результат запроса с исключенными значениями из параметра запроса

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1733
Последний ответ 03 Июл 2015, 13:49
от Kironten
выбор параметра "Склад" в отчёте.

Автор The KAINРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 860
Последний ответ 22 Июн 2016, 08:11
от The KAIN
Значение параметра "ВыбраннаяСтрока" в событии Выбор Табличного поля.

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7854
Последний ответ 09 Дек 2013, 15:03
от Katish
Помогите! Надо вернуть срез последних курсов из документа либо из параметра.

Автор alexzmРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1040
Последний ответ 11 Фев 2015, 10:07
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
21 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal