Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 18:45

В чем проблема тут?

Автор andryscha92, 26 янв 2014, 22:59

0 Пользователей и 1 гость просматривают эту тему.

andryscha92

Вот код подстановки договора при выборе контрагента.ЧТо тут не так?присваивание происходит но на форме подстановка не работает?
&НаКлиенте
Процедура РасшифровкаПлатежаКонтрагентОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
ДоговорК = УзнатьДоговорКонтрагента(ВыбранноеЗначение);
Элементы.РасшифровкаПлатежа.ТекущиеДанные.ДоговорКонтрагента = ДоговорК;
КонецПроцедуры




&НаСервере
Функция УзнатьДоговорКонтрагента(ВыбранноеЗначение)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДоговорыКонтрагентов.Ссылка
|ИЗ
| Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
|ГДЕ
| ДоговорыКонтрагентов.Владелец = &Владелец";
Запрос.УстановитьПараметр("Владелец", ВыбранноеЗначение);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Возврат Выборка.Ссылка;
КонецЦикла;


КонецФункции// УзнатьДоговорКонтрагента()



andryscha92

Не заметил!
Стандартная обработка = Ложь;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск