Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Мая 2021, 04:48
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Выборка в запросе  (Прочитано 3344 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Plastilin

  • *
  • Регистрация: 2010-04-17
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
Уважаемые профессионалы.столкнулся с такой проблемой:
Имеется справочник Ставки в котором 2 реквезита: от и процент.В запросе выбираю все значения "от" и "процент".а вот дальше сама сложность.Как организовать правильно организовать цикл если есть значение(параметр1) допустим 3500р.
есть ставки в справочнике:
от               Процент
1000р             30%
3000р             35%
5000р             40%
7000р             45%
нужно вернуть процент соответствующий значению 3500р(параметр1) ?????????????

вот набросок запроса
Функция Запросить(параметр1)
   
    Запрос3= Новый Запрос;
    Запрос3.Текст = 
    "ВЫБРАТЬ
    |от,ПроцентСервисИнженера
    |ИЗ
    |Справочник.Ставки
    |УПОРЯДОЧИТЬ ПО
    |от,ПроцентСервисИнженера ВОЗР
    |";
    Рез3= Запрос3.Выполнить().Выбрать();
    Пока Рез3.Следующий() Цикл
       
        Если параметр1 <= Рез3.от Тогда
            параметр1 =  Рез3.ПроцентСервисИнженера;
            //Прервать;
 
           
            Возврат(параметр1);
        КонецЕсли;
    КонецЦикла;
КонецФункции


Оффлайн BabySG

Сортируйте в запросе по убыванию, и находите первое значение, которое меньше вашего и получайте результат. Это же просто :)
Спрашивайте - отвечу...

Оффлайн andr2510

  • ООО "ДиГри"
  • *
  • Регистрация: 2010-04-27
  • Сообщений: 18
  • РЕПУТАЦИЯ: 1
  • КПД: 6%
  • anfr2510
Мда.... добавить нечего:)
Ан нет:)
Можно передать в запрос как параметр, а в запросе искать все, которые меньше. А из результата потом брать первоую строку, если она есть. Плюс в том, что все делает запрос.
ЗЫ: и указать в запросе "ПЕРВЫЕ 1", тогда онвыберет максимум 1 строку - экономия на трафике.
ООО "ДиГри"
www.di-gri.ru


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
32 Сообщений
kiokiosan
17 Сообщений
alexandr_ll
13 Сообщений
DmitriyF DmitriyF
11 Сообщений
antoneus antoneus
9 Сообщений
Мария2021
9 Сообщений
alex0402 alex0402
8 Сообщений
Ивашка
7 Сообщений
kah
7 Сообщений

* Кто онлайн

  • Точка Гостей: 145
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск