Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Сен 2020, 14:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборка в запросе  (Прочитано 3223 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Plastilin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-17
  • Сайт: 
Уважаемые профессионалы.столкнулся с такой проблемой:
Имеется справочник Ставки в котором 2 реквезита: от и процент.В запросе выбираю все значения "от" и "процент".а вот дальше сама сложность.Как организовать правильно организовать цикл если есть значение(параметр1) допустим 3500р.
есть ставки в справочнике:
от               Процент
1000р             30%
3000р             35%
5000р             40%
7000р             45%
нужно вернуть процент соответствующий значению 3500р(параметр1) ?????????????

вот набросок запроса
Функция Запросить(параметр1)
   
    Запрос3= Новый Запрос;
    Запрос3.Текст = 
    "ВЫБРАТЬ
    |от,ПроцентСервисИнженера
    |ИЗ
    |Справочник.Ставки
    |УПОРЯДОЧИТЬ ПО
    |от,ПроцентСервисИнженера ВОЗР
    |";
    Рез3= Запрос3.Выполнить().Выбрать();
    Пока Рез3.Следующий() Цикл
       
        Если параметр1 <= Рез3.от Тогда
            параметр1 =  Рез3.ПроцентСервисИнженера;
            //Прервать;
 
           
            Возврат(параметр1);
        КонецЕсли;
    КонецЦикла;
КонецФункции


Оффлайн BabySG

Сортируйте в запросе по убыванию, и находите первое значение, которое меньше вашего и получайте результат. Это же просто :)
Спрашивайте - отвечу...

Оффлайн andr2510

  • ООО "ДиГри"
  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 1
  • КПД: 6%
  • anfr2510
  • Регистрация: 2010-04-27
  • Сайт: 
Мда.... добавить нечего:)
Ан нет:)
Можно передать в запрос как параметр, а в запросе искать все, которые меньше. А из результата потом брать первоую строку, если она есть. Плюс в том, что все делает запрос.
ЗЫ: и указать в запросе "ПЕРВЫЕ 1", тогда онвыберет максимум 1 строку - экономия на трафике.
ООО "ДиГри"
www.di-gri.ru


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 8192
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
РС "СостояниеОСОрганизаций" в запросе

Автор ILLUMIРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2140
Последний ответ 07 Янв 2015, 05:33
от ILLUMI
Объединить и Объединить все в одном запросе

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1520
Последний ответ 16 Янв 2018, 21:35
от Tsaiger
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4591
Последний ответ 26 Апр 2018, 06:45
от Геннадий ОбьГЭС
"Поле не найдено" в запросе, но оно есть.

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6838
Последний ответ 27 Окт 2015, 10:29
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
71 Сообщений
oooo800
40 Сообщений
LexaK
30 Сообщений
IL2016
29 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
antoneus antoneus
25 Сообщений
DmitriyF DmitriyF
16 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
11 Сообщений

* Кто онлайн

  • Точка Гостей: 513
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal