Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Апр 2019, 03:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись в регистр накоплений  (Прочитано 4147 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн D-503

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-16
  • Сайт: 
Вопрос такой:
В документе (например ПриходнаяНакладная) при формировании движения в регистре накопления (например ОстаткиМатериалов) помощью конструктора движений, конструктор генерирует код:

Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
      // регистр ОстаткиМатериалов Приход
      Движение = Движения.ОстаткиМатериалов.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Материал = ТекСтрокаМатериалы.Материал;
      Движение.Склад = Склад;
      Движение.Количество = ТекСтрокаМатериалы.Количество;
   //КонецЦикла;
   //Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
      // регистр СтоимостьМатериалов Приход
      Движение = Движения.СтоимостьМатериалов.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Материал = ТекСтрокаМатериалы.Материал;
      Движение.Стоимость = ТекСтрокаМатериалы.Сумма;
   КонецЦикла;
   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

В коде отсутствует строчка: Движения.ОстаткиМатериалов.Записать(); И при этом все равно записи в регистре появляются!!! Что за фигня? И в чем тогда назначение метода Записать?

З.Ы. Не ругайте, я пока новичок jytykk


Slin
  • Гость
После обработки проведения движения автоматически записываются. Такое неявное поведение рекомендуется фирмой 1С, особенно в конфигурациях, ориентированных на многопользовательскую работу.
Назначение метода "Записать" обычное, какое всегда было :). Его рекомендуется использовать только, если необходимо получить записи в регистрах до окончания обработки проведения. Обычно используется при выполнении расчетных задач.

P.S. Насколько помню, автоматическая запись движений появилось в 8.1.


Теги:
 

Регистр сведений "Товары организаций", измерение "АналитикаУчетаНоменклатуры"

Автор GanG031Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 167
Последний ответ 20 Дек 2018, 14:35
от GanG031
Регистр сведений "Версии объектов"

Автор ЕвгенийЗерноРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 2343
Последний ответ 20 Июл 2017, 17:00
от ЕвгенийЗерно
Не формируется регистр НУ "Расходы на оплату труда"

Автор DOKA@Раздел Пользователям "1С - Предприятие 8"

Ответов: 14
Просмотров: 13354
Последний ответ 23 Дек 2013, 17:22
от LordWizard
регистр "Данные о времени для расчета среднего"

Автор AlexRasmusРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4078
Последний ответ 15 Сен 2015, 19:14
от Дмитрий@
Как В Запрос=Новый Запрос Из Регистр Накопление Остати Выбрать СуммаПриход По Нужный Реквизитам

Автор Samir OmarovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 2185
Последний ответ 17 Ноя 2016, 08:34
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
84 Сообщений
AIFrame AIFrame
78 Сообщений
alexandr_ll
43 Сообщений
alex0402
30 Сообщений
wise wise
21 Сообщений
LexaK
21 Сообщений
pavl_vs
18 Сообщений
BuhRust
15 Сообщений
byte777
14 Сообщений
Weidermail
13 Сообщений

* Кто онлайн

  • Точка Гостей: 90
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal