Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Мая 2021, 04:32
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Запись в регистр накоплений  (Прочитано 4644 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн D-503

  • *
  • Регистрация: 2010-04-16
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
Вопрос такой:
В документе (например ПриходнаяНакладная) при формировании движения в регистре накопления (например ОстаткиМатериалов) помощью конструктора движений, конструктор генерирует код:

Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
      // регистр ОстаткиМатериалов Приход
      Движение = Движения.ОстаткиМатериалов.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Материал = ТекСтрокаМатериалы.Материал;
      Движение.Склад = Склад;
      Движение.Количество = ТекСтрокаМатериалы.Количество;
   //КонецЦикла;
   //Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
      // регистр СтоимостьМатериалов Приход
      Движение = Движения.СтоимостьМатериалов.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Материал = ТекСтрокаМатериалы.Материал;
      Движение.Стоимость = ТекСтрокаМатериалы.Сумма;
   КонецЦикла;
   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

В коде отсутствует строчка: Движения.ОстаткиМатериалов.Записать(); И при этом все равно записи в регистре появляются!!! Что за фигня? И в чем тогда назначение метода Записать?

З.Ы. Не ругайте, я пока новичок jytykk


Slin
  • Гость
После обработки проведения движения автоматически записываются. Такое неявное поведение рекомендуется фирмой 1С, особенно в конфигурациях, ориентированных на многопользовательскую работу.
Назначение метода "Записать" обычное, какое всегда было :). Его рекомендуется использовать только, если необходимо получить записи в регистрах до окончания обработки проведения. Обычно используется при выполнении расчетных задач.

P.S. Насколько помню, автоматическая запись движений появилось в 8.1.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
32 Сообщений
kiokiosan
17 Сообщений
alexandr_ll
13 Сообщений
DmitriyF DmitriyF
11 Сообщений
Мария2021
9 Сообщений
antoneus antoneus
9 Сообщений
alex0402 alex0402
8 Сообщений
Ивашка
7 Сообщений
kah
7 Сообщений

* Кто онлайн

  • Точка Гостей: 125
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск