Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Фев 2018, 02:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавить в отчет возможность выбора конкретного подразделения  (Прочитано 1444 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте. Помогите, плиз. У меня есть отчет "Оборотная ведомость наличия драг металлов в МЦ по МОЛ", но там выдает по всем подразделениям. А мене надо чтобы выдовало по всем + пользователь мог выбрать из справочника конкретное подразделение и в отчет пошла информация только по этому подразделению. В диалоге еще стоит выбор по материалу или по основному средству. Скажите. что нужно дописать в код, что-то не могу разобраться. Код такой:

//*******************************************
Процедура Сформировать()       
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица");
   Таб.ВывестиСекцию("Шапка");
   
   ТЗ = СоздатьОбъект("ТаблицаЗначений");
   ТЗ.НоваяКолонка("Материал","Справочник.Материалы");    //+ др.колонки

   ТЗ1 = СоздатьОбъект("ТаблицаЗначений");
   ТЗ1.НоваяКолонка("Материал","Справочник.Материалы");
   ТЗ1.НоваяКолонка("Сотрудник","Справочник.Сотрудники");   //+ др.колонки
   
   Ит = создатьОбъект("БухгалтерскиеИтоги");
   Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники,,1);
   Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,,1);
   Ит.ВыполнитьЗапрос(Дата1,Дата2,"10",,,,,5);
   Ит.ВыбратьСубконто(ВидыСубконто.Сотрудники);
   Пока Ит.ПолучитьСубконто(ВидыСубконто.Сотрудники) <> 0 Цикл
      Сотрудник = Ит.Субконто(ВидысУбконто.Сотрудники);
      Ит.ВыбратьСубконто(ВИдыСубконто.Материалы);
      Пока Ит.ПолучитьСубконто(ВидыСубконто.Материалы) <> 0 Цикл
         Материал = Ит.Субконто(ВидыСубконто.Материалы);
         СпрДМ = СоздатьОбъект("Справочник.НаличиеДрагметалловВМатериалах");
         СпрДМ.ИспользоватьВладельца(Материал);
         Если СпрДМ.ВыбратьЭлементы() <> 0 Тогда
            ТЗ.НоваяСтрока();
            ТЗ.Сотрудник = Сотрудник;
            ТЗ.Материал = Материал;
            Пока СпрДМ.ПолучитьЭлемент() <> 0 Цикл 
               Если СпрДМ.ПометкаУдаления() = 1 ТОгда
                  ПРодолжить;
               КонецЕсли;
               
               Вес = СпрДМ.ВесДМ;
               Если СпрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Золото Тогда
                  ТЗ.ЗолотоОстатокНач = Ит.СНД("К")*Вес;
                  ТЗ.ЗолотоПриход     = Ит.ДО("К") *Вес;
                  ТЗ.ЗолотоРАсход     = ИТ.КО("К") *Вес;
                  ТЗ.ЗолотоОстатокКон = Ит.СКД("К")*Вес;
               ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Серебро Тогда
                  ТЗ.СереброОстатокНач = Ит.СНД("К")*Вес;
                  ТЗ.СереброПриход     = Ит.ДО("К") *Вес;
                  ТЗ.СереброРАсход     = ИТ.КО("К") *Вес;
                  ТЗ.СереброОстатокКон = Ит.СКД("К")*Вес;
               ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Платина Тогда
                  ТЗ.ПлатинаОстатокНач = Ит.СНД("К")*Вес;
                  ТЗ.ПлатинаПриход     = Ит.ДО("К") *Вес;
                  ТЗ.ПлатинаРАсход     = ИТ.КО("К") *Вес;
                  ТЗ.ПлатинаОстатокКон = Ит.СКД("К")*Вес;
               ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Палладий Тогда
                  ТЗ.ПалладийОстатокНач = Ит.СНД("К")*Вес;
                  ТЗ.ПалладийПриход     = Ит.ДО("К") *Вес;
                  ТЗ.ПалладийРАсход     = ИТ.КО("К") *Вес;
                  ТЗ.ПалладийОстатокКон = Ит.СКД("К")*Вес;
               Иначе
                  ТЗ.ПрочееОстатокНач = Ит.СНД("К")*Вес;
                  ТЗ.ПрочееПриход     = Ит.ДО("К") *Вес;
                  ТЗ.ПрочееРАсход     = ИТ.КО("К") *Вес;
                  ТЗ.ПрочееОстатокКон = Ит.СКД("К")*Вес;
               КонецЕсли;               
            КонецЦикла;
         КонецЕсли;         
      КонецЦикла;     
   КонецЦикла;   
   Сотр = "";
   ТЗ.ВыбратьСтроки();
   Пока ТЗ.ПолучитьСтроку() <> 0 Цикл
      Если (ТЗ.ЗолотоОстатокНач = 0) и (ТЗ.СереброОстатокНач = 0) и (ТЗ.ПлатинаОстатокНач = 0) и (ТЗ.ПалладийОстатокНач = 0) и (ТЗ.ПрочееОстатокНАч = 0)
         и (ТЗ.ЗолотоПриход = 0) и (ТЗ.СереброПриход = 0) и (ТЗ.ПлатинаПриход = 0) и (ТЗ.ПалладийПриход = 0) и (ТЗ.ПрочееПриход = 0)
         и (ТЗ.ЗолотоРасход = 0) и (ТЗ.СереброРасход = 0) и (ТЗ.ПлатинаРасход = 0) и (ТЗ.ПалладийРасход = 0) и (ТЗ.ПрочееРасход = 0)
         и (ТЗ.ЗолотоОстатокКон = 0) и (ТЗ.СереброОстатокКон = 0) и (ТЗ.ПлатинаОстатокКон = 0) и (ТЗ.ПалладийОстатокКон = 0) и (ТЗ.ПрочееОстатокКон = 0) Тогда
         Продолжить;
      КонецЕсли;
     
      Если ТЗ.НомерСтроки = 1 ТОгда
         Сотр = ТЗ.Сотрудник;
      КонецЕсли;
     
      Если (Сотр <> ТЗ.Сотрудник) Тогда           
         Таб.ВывестиСекцию("Сотрудник");
         ТЗ1.ВыбратьСтроки();
         Пока ТЗ1.ПолучитьСтроку() <> 0 Цикл
            Таб.ВывестиСекцию("Строка");
         КонецЦикла;         
         ТЗ1.УдалитьСтроки();             
         Сотр = ТЗ.Сотрудник;
      КонецЕсли;
      ТЗ1.НоваяСтрока();
      ТЗ1.Сотрудник = ТЗ.Сотрудник;
      ТЗ1.Материал = ТЗ.Материал;
      ТЗ1.ЗолотоОстатокНач = ТЗ.ЗолотоОстатокНач;  //+ др.колонки
     
   КонецЦикла;     
   Таб.ВывестиСекцию("Сотрудник");
   ТЗ1.ВыбратьСтроки();
   Пока ТЗ1.ПолучитьСтроку() <> 0 Цикл
      Таб.ВывестиСекцию("Строка");
   КонецЦикла;         
 КонецПроцедуры             
//*******************************************
Процедура Сформировать1()       
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица1");
   Таб.ВывестиСекцию("Шапка");
   
   ТЗ = СоздатьОбъект("ТаблицаЗначений");
   ТЗ.НоваяКолонка("ОС","Справочник.ОсновныеСредства");
   ТЗ.НоваяКолонка("Сотрудник","Справочник.Сотрудники");  //+ др.колонки
     
   ТЗ1 = СоздатьОбъект("ТаблицаЗначений");
   ТЗ1.НоваяКолонка("ОС","Справочник.ОсновныеСредства");
   ТЗ1.НоваяКолонка("Сотрудник","Справочник.Сотрудники");
   ТЗ1.НоваяКолонка("ЗолотоОстатокНач","Число");  //+ др.колонки
   
      ТЗМол = СоздатьОбъект("ТаблицаЗначений");
   ТЗМол.НоваяКолонка("Сотрудник","Справочник.Сотрудники");
   
   Ит = создатьОбъект("БухгалтерскиеИтоги");
   //Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники,,1);
   Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства,,1);
   Ит.ВыполнитьЗапрос(Дата1,Дата2,"01",,,,,);
   Ит.ВыбратьСубконто(ВИдыСубконто.ОсновныеСредства);
   Пока Ит.ПолучитьСубконто(ВидыСубконто.ОсновныеСредства) <> 0 Цикл
      ТЗМол.УдалитьСтроки();
     
      ОС = Ит.Субконто(ВидыСубконто.ОсновныеСредства);
      СпрДМ = СоздатьОбъект("Справочник.НаличиеДрагметалла");
      СпрДМ.ИспользоватьВладельца(ОС);
      Если СпрДМ.ВыбратьЭлементы() <> 0 Тогда
         Если Ит.СНД() <> 0 ТОгда       
            Если СпрДМ.ПометкаУдаления() =1 Тогда
               Продолжить;
            КОнецЕсли;
           
            ПериодическийРеквизит = СоздатьОбъект("Периодический");
            ПериодическийРеквизит.ИспользоватьОбъект("МОЛ", ОС);
            ПериодическийРеквизит.ВыбратьЗначения(Дата1, Дата2);
            Пока ПериодическийРеквизит.ПолучитьЗначение() <> 0 Цикл
               Если ПустоеЗначение(ПериодическийРеквизит.Значение) = 1 ТОгда
                  Продолжить;
               КонецЕсли;               
               ТЗМол.НоваяСтрока();
               ТЗМол.Сотрудник = ПериодическийРеквизит.Значение;
            КонецЦикла;
                        Если ТЗМол.КоличествоСТрок() <> 0 Тогда
               ТЗ.НоваяСтрока();
               ТЗ.Сотрудник = ОС.МОЛ.Получить(Дата1);
               ТЗ.ОС = ОС;
               Пока СпрДМ.ПолучитьЭлемент() <> 0 Цикл
                  Вес = СпрДМ.ВесДМ;       
                  Если СпрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Золото Тогда
                     ТЗ.ЗолотоОстатокНач = Вес;
                     ТЗ.ЗолотоПриход = 0;
                     ТЗ.ЗолотоРасход = Вес;
                     ТЗ.ЗолотоОстатокКон = 0;
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Серебро Тогда
                     ТЗ.СереброОстатокНач = Вес;
                     ТЗ.СереброПриход = 0;
                     ТЗ.СереброРасход = Вес;
                     ТЗ.СереброОстатокКон = 0;
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Платина Тогда
                     ТЗ.ПлатинаОстатокНач = Вес;
                     ТЗ.ПлатинаПриход = 0;
                     ТЗ.ПлатинаРасход = Вес;
                     ТЗ.ПлатинаОстатокКон = 0;
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Палладий Тогда
                     ТЗ.ПалладийОстатокНач = Вес;
                     ТЗ.ПалладийПриход = 0;
                     ТЗ.ПалладийРасход = Вес;
                     ТЗ.ПалладийОстатокКон = 0;
                  Иначе
                     ТЗ.ПрочееОстатокНач = Вес;
                     ТЗ.ПрочееПриход = 0;
                     ТЗ.ПрочееРасход = Вес;
                     ТЗ.ПрочееОстатокКон = 0;
                  КонецЕсли;   
               КонецЦикла;   
               ТЗМол.ВыбратьСтроки();
               Пока ТЗМол.ПолучитьСтроку() <> 0 Цикл
                  ТЗ.НоваяСтрока();
                  ТЗ.Сотрудник = ТЗМОЛ.Сотрудник;
                  ТЗ.ОС = ОС;
                  СпрДМ.ИспользоватьВладельца(ОС);
                  СпрДМ.ВыбратьЭлементы(); 
                  Пока СпрДМ.ПолучитьЭлемент() <> 0 Цикл
                     Вес = СпрДМ.ВесДМ;       
                     Если СпрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Золото Тогда
                        ТЗ.ЗолотоОстатокНач = 0;
                        ТЗ.ЗолотоПриход = Вес;
                        Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                           ТЗ.ЗолотоРасход = Вес;
                           ТЗ.ЗолотоОстатокКон = 0;
                        Иначе
                           ТЗ.ЗолотоРасход = 0;
                           ТЗ.ЗолотоОстатокКон = Вес;
                        КонецЕсли;                       
                     ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Серебро Тогда
                        ТЗ.СереброОстатокНач = 0;
                        ТЗ.СереброПриход = Вес;
                        Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                           ТЗ.СереброРасход = Вес;
                           ТЗ.СереброОстатокКон = 0;
                        Иначе
                           ТЗ.СереброРасход = 0;
                           ТЗ.СереброОстатокКон = Вес;
                        КонецЕсли;                       
                     ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Платина Тогда
                        ТЗ.ПлатинаОстатокНач = Вес;
                        ТЗ.ПлатинаПриход = 0;
                        Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                           ТЗ.ПлатинаРасход = Вес;
                           ТЗ.ПлатинаОстатокКон = 0;
                        Иначе
                           ТЗ.ПлатинаРасход = 0;
                           ТЗ.ПлатинаОстатокКон = Вес;
                        КонецЕсли;                       
                     ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Палладий Тогда
                        ТЗ.ПалладийОстатокНач = 0;
                        ТЗ.ПалладийПриход = Вес;
                        Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                           ТЗ.ПалладийРасход = Вес;
                           ТЗ.ПалладийОстатокКон = 0;
                        Иначе
                           ТЗ.ПалладийРасход = 0;
                           ТЗ.ПалладийОстатокКон = Вес;
                        КонецЕсли;                       
                     Иначе
                        ТЗ.ПрочееОстатокНач = 0;
                        ТЗ.ПрочееПриход = Вес;
                        Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                           ТЗ.ПрочееРасход = Вес;
                           ТЗ.ПрочееОстатокКон = 0;
                        Иначе
                           ТЗ.ПрочееРасход = 0;
                           ТЗ.ПрочееОстатокКон = Вес;
                        КонецЕсли;                       
                     КонецЕсли;   
                  КонецЦикла;   
               КонецЦикла;           
            Иначе     
               ТЗ.НоваяСтрока();
               ТЗ.Сотрудник = ОС.МОЛ.Получить(Дата1);
               ТЗ.ОС = ОС;
               СпрДМ.ИспользоватьВладельца(ОС);
               СпрДМ.ВыбратьЭлементы(); 
               Пока СпрДМ.ПолучитьЭлемент() <> 0 Цикл
                  Вес = СпрДМ.ВесДМ;
                  Если СпрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Золото Тогда
                     ТЗ.ЗолотоОстатокНач = Вес;
                     ТЗ.ЗолотоПриход     = 0;
                     Если ИТ.СКД() <> 0 Тогда
                        ТЗ.ЗолотоРАсход     = 0;
                        ТЗ.ЗолотоОстатокКон = Вес;
                     Иначе
                        ТЗ.ЗолотоРАсход     = Вес;
                        ТЗ.ЗолотоОстатокКон = 0;
                     КонецЕсли;                     
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Серебро Тогда
                     ТЗ.СереброОстатокНач = Вес;
                     ТЗ.СереброПриход     = 0;
                     Если ИТ.СКД() <> 0 Тогда
                        ТЗ.СереброРасход     = 0;
                        ТЗ.СереброОстатокКон = Вес;
                     Иначе
                        ТЗ.СереброРАсход     = Вес;
                        ТЗ.СереброОстатокКон = 0;
                     КонецЕсли;                     
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Платина Тогда
                     ТЗ.ПлатинаОстатокНач = Вес;
                     ТЗ.ПлатинаПриход     = 0;
                     Если ИТ.СКД() <> 0 Тогда
                        ТЗ.ПлатинаРасход     = 0;
                        ТЗ.ПлатинаОстатокКон = Вес;
                     Иначе
                        ТЗ.ПлатинаРАсход     = Вес;
                        ТЗ.ПлатинаОстатокКон = 0;
                     КонецЕсли;                     
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Палладий Тогда
                     ТЗ.ПалладийОстатокНач = Вес;
                     ТЗ.ПалладийПриход     = 0;
                     Если ИТ.СКД() <> 0 Тогда
                        ТЗ.ПалладийРасход     = 0;
                        ТЗ.ПалладийОстатокКон = Вес;
                     Иначе
                        ТЗ.ПалладийРАсход     = Вес;
                        ТЗ.ПалладийОстатокКон = 0;
                     КонецЕсли;                     
                  Иначе
                     ТЗ.ПрочееОстатокНач = Вес;
                     ТЗ.ПрочееПриход     = 0;
                     Если ИТ.СКД() <> 0 Тогда
                        ТЗ.ПрочееРасход     = 0;
                        ТЗ.ПрочееОстатокКон = Вес;
                     Иначе
                        ТЗ.ПрочееРАсход     = Вес;
                        ТЗ.ПрочееОстатокКон = 0;
                     КонецЕсли;                     
                  КонецЕсли;               
               КонецЦикла;
            КонецЕсли;               
         ИначеЕсли (Ит.СНД() = 0) и (Ит.ДО() <> 0) ТОгда
            ПериодическийРеквизит = СоздатьОбъект("Периодический");
            ПериодическийРеквизит.ИспользоватьОбъект("МОЛ", ОС);
            ПериодическийРеквизит.ВыбратьЗначения(Дата1, Дата2);
            Пока ПериодическийРеквизит.ПолучитьЗначение() <> 0 Цикл
               Если ПустоеЗначение(ПериодическийРеквизит.Значение) = 1 Тогда
                  Продолжить;
               КонецЕсли;               
               ТЗМол.НоваяСтрока();
               ТЗМол.Сотрудник = ПериодическийРеквизит.Значение;
            КонецЦикла;
           
            ТЗМол.ВыбратьСтроки();
            Пока ТЗМол.ПолучитьСтроку() <> 0 Цикл
               ТЗ.НоваяСтрока();
               ТЗ.Сотрудник = ТЗМОЛ.Сотрудник;
               ТЗ.ОС = ОС;
               СпрДМ.ИспользоватьВладельца(ОС);
               СпрДМ.ВыбратьЭлементы(); 
               Пока СпрДМ.ПолучитьЭлемент() <> 0 Цикл
                  Вес = СпрДМ.ВесДМ;       
                  Если СпрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Золото Тогда
                     ТЗ.ЗолотоОстатокНач = 0;
                     ТЗ.ЗолотоПриход = Вес;
                     Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                        ТЗ.ЗолотоРасход = Вес;
                        ТЗ.ЗолотоОстатокКон = 0;
                     Иначе
                        ТЗ.ЗолотоРасход = 0;
                        ТЗ.ЗолотоОстатокКон = Вес;
                     КонецЕсли;                       
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Серебро Тогда
                     ТЗ.СереброОстатокНач = 0;
                     ТЗ.СереброПриход = Вес;
                     Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                        ТЗ.СереброРасход = Вес;
                        ТЗ.СереброОстатокКон = 0;
                     Иначе
                        ТЗ.СереброРасход = 0;
                        ТЗ.СереброОстатокКон = Вес;
                     КонецЕсли;                       
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Платина Тогда
                     ТЗ.ПлатинаОстатокНач = 0;
                     ТЗ.ПлатинаПриход = Вес;
                     Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                        ТЗ.ПлатинаРасход = Вес;
                        ТЗ.ПлатинаОстатокКон = 0;
                     Иначе
                        ТЗ.ПлатинаРасход = 0;
                        ТЗ.ПлатинаОстатокКон = Вес;
                     КонецЕсли;                       
                  ИначеЕсли СПрДМ.ВидДМ.ТипДрагМатериала = Перечисление.ТипыДрагМатериалов.Палладий Тогда
                     ТЗ.ПалладийОстатокНач = 0;
                     ТЗ.ПалладийПриход = Вес;
                     Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                        ТЗ.ПалладийРасход = Вес;
                        ТЗ.ПалладийОстатокКон = 0;
                     Иначе
                        ТЗ.ПалладийРасход = 0;
                        ТЗ.ПалладийОстатокКон = Вес;
                     КонецЕсли;                       
                  Иначе
                     ТЗ.ПрочееОстатокНач = 0;
                     ТЗ.ПрочееПриход = Вес;
                     Если ТЗМол.КоличествоСтрок() > ТЗМол.НомерСтроки Тогда
                        ТЗ.ПрочееРасход = Вес;
                        ТЗ.ПрочееОстатокКон = 0;
                     Иначе
                        ТЗ.ПрочееРасход = 0;
                        ТЗ.ПрочееОстатокКон = Вес;
                     КонецЕсли;                       
                  КонецЕсли;   
               КонецЦикла;   
            КонецЦикла;           
         КонецЕсли;
      КонецЕсли;         
   КонецЦикла;     
   Сотр = "";
   ТЗ.Сортировать("Сотрудник");
   ТЗ.ВыбратьСтроки();
   Пока ТЗ.ПолучитьСтроку() <> 0 Цикл   
      Если ТЗ.НомерСтроки = 1 ТОгда
         Сотр = ТЗ.Сотрудник;
      КонецЕсли;
     
      Если (Сотр <> ТЗ.Сотрудник) Тогда           
         Таб.ВывестиСекцию("Сотрудник");
         ТЗ1.ВыбратьСтроки();
         Пока ТЗ1.ПолучитьСтроку() <> 0 Цикл
            Таб.ВывестиСекцию("Строка");
         КонецЦикла;         
         ТЗ1.УдалитьСтроки();             
         Сотр = ТЗ.Сотрудник;
      КонецЕсли;   
      ТЗ1.НоваяСтрока();
      ТЗ1.Сотрудник = ТЗ.Сотрудник;
      ТЗ1.ОС = ТЗ.ОС;
      ТЗ1.ЗолотоОстатокНач = ТЗ.ЗолотоОстатокНач;  //+ др.колонки
   
   КонецЦикла;             
   Таб.ВывестиСекцию("Сотрудник");
   ТЗ1.ВыбратьСтроки();
   Пока ТЗ1.ПолучитьСтроку() <> 0 Цикл
      Таб.ВывестиСекцию("Строка");
   КонецЦикла;         
 
КонецПроцедуры








Оффлайн sail

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-08
  • Сайт: 
  • Профессия: Программист 8.1
Не могу понять, для чего создается ТЗ1

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Это случаем не отчеты по драгметалам для госучреждений? Я когда-то писал под БГУ 1.1 (Воинская часть).
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
217 Сообщений
AIFrame AIFrame
78 Сообщений
alexandr_ll
41 Сообщений
MuI_I_Ika MuI_I_Ika
38 Сообщений
BuhRust
29 Сообщений
wise wise
27 Сообщений
andron81_81
25 Сообщений
pavl_vs
23 Сообщений
ildar32 ildar32
22 Сообщений
oleg-x
22 Сообщений

* Кто онлайн

  • Точка Гостей: 216
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal