Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 11:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка дает ошибку: Перед выполнением откройте базу!  (Прочитано 1908 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн desc84

  • ***
  • Сообщений: 113
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Ребят прислали обработку, говорят на месте разработки все работает у нас нет. выдает ошибку Перед выполнением откройте базу!
Что и где посмотреть для исправления ошибки?
 Вот код
Процедура ВыполнитьНаСервере()
   
   ДБФ = Новый Xbase;
   Дбф.поля.Добавить("NumDoc","s",20);
   Дбф.поля.Добавить("Code","s",20);
   Дбф.поля.Добавить("Kol","n",14,2);
   Дбф.поля.Добавить("SUmNDS","n",14,2);
   Дбф.поля.Добавить("Sum","n",14,2);
   Дбф.поля.Добавить("Opisanie","s",255);                                                   
   ДБФ.СоздатьФайл("\\srv\1c\Славяне\A"+Прав("0"+День(Объект.Дата),2)+Прав("0"+Месяц(Объект.Дата),2)+Прав(Формат(Год(Объект.Дата),"ЧГ=0"),2)+".dbf");
   //ДБФ.СоздатьФайл("d:\Dsuh\A"+Прав("0"+День(Объект.Дата),2)+Прав("0"+Месяц(Объект.Дата),2)+Прав(Формат(Год(Объект.Дата),"ЧГ=0"),2)+".dbf");
   ДБФ.Кодировка = КодировкаXBase.OEM;
   Зап = Новый Запрос;   
   Зап.Параметры.Вставить("ДН", НачалоДня(Объект.Дата));
   Зап.Параметры.Вставить("ДК", КонецДня(Объект.Дата));
   Зап.Параметры.Вставить("Контр", Объект.Контрагент);
   
   Зап.Текст =   "ВЫБРАТЬ
                 |   РеализацияТоваровУслуг.Номер КАК Номер,
                 |   РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
                 |   РеализацияТоваровУслугТовары.Количество,
                 |   РеализацияТоваровУслугТовары.Сумма,
                 |   РеализацияТоваровУслугТовары.СуммаНДС,
                 |   РеализацияТоваровУслуг.Ссылка КАК Ссылка,
                 |   ПОДСТРОКА(РеализацияТоваровУслугТовары.Номенклатура.Комментарий, 0, 75) КАК КодНом
                 |ИЗ
                 |   Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                 |      ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                 |      ПО РеализацияТоваровУслугТовары.Ссылка = РеализацияТоваровУслуг.Ссылка
                 |ГДЕ
                 |   РеализацияТоваровУслуг.Дата МЕЖДУ &ДН И &ДК
                 |   И РеализацияТоваровУслуг.Проведен = ИСТИНА
                 |   И РеализацияТоваровУслуг.Контрагент = &Контр
                 |
                 |СГРУППИРОВАТЬ ПО
                 |   РеализацияТоваровУслуг.Номер,
                 |   РеализацияТоваровУслугТовары.Номенклатура,
                 |   РеализацияТоваровУслугТовары.Количество,
                 |   РеализацияТоваровУслугТовары.Сумма,
                 |   РеализацияТоваровУслугТовары.СуммаНДС,
                 |   РеализацияТоваровУслуг.Ссылка,
                 |   ПОДСТРОКА(РеализацияТоваровУслугТовары.Номенклатура.Комментарий, 0, 75),
                 |   ПОДСТРОКА(РеализацияТоваровУслугТовары.Номенклатура.Комментарий, 0, 75)
                 |
                 |УПОРЯДОЧИТЬ ПО
                 |   Ссылка,
                 |   Номер,
                 |   Номенклатура
                 |ИТОГИ ПО
                 |   Ссылка";
   //н = Новый Справочники.Номенклатура;
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   //ОблШ   = Макет.ПолучитьОбласть("Шапка");
   //ОблД   = Макет.ПолучитьОбласть("Док");
   //ОблС   = Макет.ПолучитьОбласть("Строка");
   //ОблШ.Параметры.Шап = "Дата:"+Объект.Дата+" контрагент:"+Объект.Контрагент;
   //ТабДокумент.Вывести(ОблШ);
   //
   ТЗ = Зап.Выполнить().Выбрать();
   Пока ТЗ.Следующий()=1 Цикл
      Дбф.Добавить();
      Если ПустаяСтрока(ТЗ.номенклатура) Тогда
         ДБФ.numdoc = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(ТЗ.Номер,Истина,Истина);
         ДБФ.opisanie = ТЗ.ссылка.Комментарий;
   //      ОблД.Параметры.НД = ТЗ.Номер;
   //      ОблД.Параметры.Опис = ТЗ.ссылка.Комментарий;
   //      ТабДокумент.Вывести(ОблД);
   //      
      Иначе
         ДБФ.code = ТЗ.КодНом;
         ДБФ.kol = ТЗ.Количество;
         ДБФ.Sum = ТЗ.Сумма;
         ДБФ.SumNDS = ТЗ.СуммаНДС;
   //      ОблС.Параметры.Код = ТЗ.Номенклатура.комментарий+"-("+ТЗ.Номенклатура.Наименование+")";
   //      ОблС.Параметры.Кол = ТЗ.Количество;
   //      ОблС.Параметры.Сум = ТЗ.Сумма;
   //      ОблС.Параметры.СумНДС = ТЗ.СуммаНДС;
   //      ТабДокумент.Вывести(ОблС);
   //      
      КонецЕсли;
      дбф.Записать();
   КонецЦикла;   
   ДБФ.ЗакрытьФайл();
   Сообщить("Выгрузка прошла успешно!!!");
   //ТабДокумент.Показать();      
   
   
КонецПроцедуры


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
А зачем из 8-ки создавать ДБФ-файл? Вперед - в прошлое?? :xfbnsdfb:
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
53 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 245
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal