Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Ноя 2018, 03:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как реализовать проверку  (Прочитано 2652 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vidok

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
  • Профессия: Ученик 1С
В диалоге формы есть Поле ввода, при его изменении идет запрос с данным условием:

Если РезультатЗапроса.Пустой()=Истина  Тогда
Ответ = Вопрос("На выбранную машину бригады нет. Выбрать другую машину?", РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да);
Если Ответ = КодВозвратаДиалога.Да Тогда
Транспорт=Справочники.ТранспортныеСредства;
ФормаСписка=Транспорт.ПолучитьФормуВыбора();
 Если Не ФормаСписка.Открыта() Тогда
 ФормаСписка.ОткрытьМодально();
 // ???
 КонецЕсли;
Иначе Закрыть();  
   КонецЕсли;
КонецЕсли;        

при открытии формы списка, проверка уже не осуществляется. Подскажите, как правильнее реализовать проверку? Можно конечно условие в условие раз 10 вставить, но это как-то не красиво


Slin
  • Гость
Форма списка это уже другая форма и другой код. Не так ли?

Оффлайн vidok

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
Форма списка это уже другая форма и другой код. Не так ли?

получается что так

Slin
  • Гость
В форме списка нужно отбор сделать
какая проверка то должна быть?

Оффлайн vidok

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
  • Профессия: Ученик 1С
в модуле формы:

Процедура ТранспортноеСредствоПриИзменении(Элемент)				
Запрос= Новый Запрос;
ТекстЗапроса=
"ВЫБРАТЬ
| СоставБригадыСрезПоследних.Транспорт,
| СоставБригадыСрезПоследних.Водитель,
| СоставБригадыСрезПоследних.Грузчик1,
| СоставБригадыСрезПоследних.Грузчик2
|ИЗ
| РегистрСведений.СоставБригады.СрезПоследних(&РабочаяДата, ) КАК СоставБригадыСрезПоследних
|ГДЕ
| СоставБригадыСрезПоследних.Транспорт = &Транспорт";

Запрос.УстановитьПараметр("Транспорт", ЭлементыФормы.ТранспортноеСредство.Значение);
Запрос.УстановитьПараметр("РабочаяДата",РабочаяДата);
Запрос.Текст=ТекстЗапроса;
РезультатЗапроса=Запрос.Выполнить();

Если РезультатЗапроса.Пустой()=Истина  Тогда
Ответ = Вопрос("На выбранную машину бригады нет. Выбрать другую машину?", РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да);
Если Ответ = КодВозвратаДиалога.Да Тогда
Транспорт=Справочники.ТранспортныеСредства;
ФормаСписка=Транспорт.ПолучитьФормуВыбора();
  Если Не ФормаСписка.Открыта() Тогда
  ФормаСписка.ОткрытьМодально();
  // ???
  КонецЕсли;
Иначе Закрыть();  
    КонецЕсли;
КонецЕсли;                                                 
КонецПроцедуры

проверка должна осуществляться по выбранному транспортному средству.

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Лучше всего будет реализовать подписку на данное событие.....


Теги:
 

Подскажите как реализовать "планинг"?

Автор cannabis_86Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2445
Последний ответ 20 Июн 2011, 10:29
от cska-fanat-kz
Система компоновки данных – как в макете реализовать сложение(вычитание) ячеек?

Автор sapravkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4315
Последний ответ 14 Фев 2013, 22:34
от sapravka
Запись клиентов на определенную дату-время: подскажите как реализовать?

Автор nst1Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 988
Последний ответ 21 Июн 2017, 23:03
от oleg-x
1с: Розница. Как реализовать выдачу денежных средств поставщику через РМК

Автор RimmaBloomРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 294
Последний ответ 25 Апр 2018, 11:08
от Геннадий ОбьГЭС
Помогите, пожалуйста, реализовать возможность подбора сопутствующих товаров

Автор belekРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 62
Последний ответ 07 Ноя 2018, 14:54
от belek

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
47 Сообщений
alex0402
44 Сообщений
alexandr_ll
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 162
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal