Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Мая 2021, 01:45
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Как реализовать проверку  (Прочитано 3534 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vidok

  • *
  • Регистрация: 2010-03-31
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
В диалоге формы есть Поле ввода, при его изменении идет запрос с данным условием:

Если РезультатЗапроса.Пустой()=Истина  Тогда
Ответ = Вопрос("На выбранную машину бригады нет. Выбрать другую машину?", РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да);
Если Ответ = КодВозвратаДиалога.Да Тогда
Транспорт=Справочники.ТранспортныеСредства;
ФормаСписка=Транспорт.ПолучитьФормуВыбора();
 Если Не ФормаСписка.Открыта() Тогда
 ФормаСписка.ОткрытьМодально();
 // ???
 КонецЕсли;
Иначе Закрыть();  
   КонецЕсли;
КонецЕсли;        

при открытии формы списка, проверка уже не осуществляется. Подскажите, как правильнее реализовать проверку? Можно конечно условие в условие раз 10 вставить, но это как-то не красиво


Slin
  • Гость
Форма списка это уже другая форма и другой код. Не так ли?

Оффлайн vidok

  • *
  • Регистрация: 2010-03-31
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Цитировать
Форма списка это уже другая форма и другой код. Не так ли?

получается что так

Slin
  • Гость
В форме списка нужно отбор сделать
какая проверка то должна быть?

Оффлайн vidok

  • *
  • Регистрация: 2010-03-31
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
в модуле формы:

Процедура ТранспортноеСредствоПриИзменении(Элемент)				
Запрос= Новый Запрос;
ТекстЗапроса=
"ВЫБРАТЬ
| СоставБригадыСрезПоследних.Транспорт,
| СоставБригадыСрезПоследних.Водитель,
| СоставБригадыСрезПоследних.Грузчик1,
| СоставБригадыСрезПоследних.Грузчик2
|ИЗ
| РегистрСведений.СоставБригады.СрезПоследних(&РабочаяДата, ) КАК СоставБригадыСрезПоследних
|ГДЕ
| СоставБригадыСрезПоследних.Транспорт = &Транспорт";

Запрос.УстановитьПараметр("Транспорт", ЭлементыФормы.ТранспортноеСредство.Значение);
Запрос.УстановитьПараметр("РабочаяДата",РабочаяДата);
Запрос.Текст=ТекстЗапроса;
РезультатЗапроса=Запрос.Выполнить();

Если РезультатЗапроса.Пустой()=Истина  Тогда
Ответ = Вопрос("На выбранную машину бригады нет. Выбрать другую машину?", РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да);
Если Ответ = КодВозвратаДиалога.Да Тогда
Транспорт=Справочники.ТранспортныеСредства;
ФормаСписка=Транспорт.ПолучитьФормуВыбора();
  Если Не ФормаСписка.Открыта() Тогда
  ФормаСписка.ОткрытьМодально();
  // ???
  КонецЕсли;
Иначе Закрыть();  
    КонецЕсли;
КонецЕсли;                                                 
КонецПроцедуры

проверка должна осуществляться по выбранному транспортному средству.

Оффлайн Myti

  • *****
  • Регистрация: 2009-10-12
  • Сообщений: 678
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Лучше всего будет реализовать подписку на данное событие.....


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
82 Сообщений
LexaK
29 Сообщений
kiokiosan
18 Сообщений
alexandr_ll
16 Сообщений
Ивашка
12 Сообщений
kah
11 Сообщений
antoneus antoneus
9 Сообщений
alex0402 alex0402
9 Сообщений
DmitriyF DmitriyF
9 Сообщений
nvj84
7 Сообщений

* Кто онлайн

  • Точка Гостей: 162
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск