Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
01 Окт 2020, 10:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как реализовать проверку  (Прочитано 3303 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vidok

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
  • Профессия: Ученик 1С
В диалоге формы есть Поле ввода, при его изменении идет запрос с данным условием:

Если РезультатЗапроса.Пустой()=Истина  Тогда
Ответ = Вопрос("На выбранную машину бригады нет. Выбрать другую машину?", РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да);
Если Ответ = КодВозвратаДиалога.Да Тогда
Транспорт=Справочники.ТранспортныеСредства;
ФормаСписка=Транспорт.ПолучитьФормуВыбора();
 Если Не ФормаСписка.Открыта() Тогда
 ФормаСписка.ОткрытьМодально();
 // ???
 КонецЕсли;
Иначе Закрыть();  
   КонецЕсли;
КонецЕсли;        

при открытии формы списка, проверка уже не осуществляется. Подскажите, как правильнее реализовать проверку? Можно конечно условие в условие раз 10 вставить, но это как-то не красиво


Slin
  • Гость
Форма списка это уже другая форма и другой код. Не так ли?

Оффлайн vidok

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
Форма списка это уже другая форма и другой код. Не так ли?

получается что так

Slin
  • Гость
В форме списка нужно отбор сделать
какая проверка то должна быть?

Оффлайн vidok

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
  • Профессия: Ученик 1С
в модуле формы:

Процедура ТранспортноеСредствоПриИзменении(Элемент)				
Запрос= Новый Запрос;
ТекстЗапроса=
"ВЫБРАТЬ
| СоставБригадыСрезПоследних.Транспорт,
| СоставБригадыСрезПоследних.Водитель,
| СоставБригадыСрезПоследних.Грузчик1,
| СоставБригадыСрезПоследних.Грузчик2
|ИЗ
| РегистрСведений.СоставБригады.СрезПоследних(&РабочаяДата, ) КАК СоставБригадыСрезПоследних
|ГДЕ
| СоставБригадыСрезПоследних.Транспорт = &Транспорт";

Запрос.УстановитьПараметр("Транспорт", ЭлементыФормы.ТранспортноеСредство.Значение);
Запрос.УстановитьПараметр("РабочаяДата",РабочаяДата);
Запрос.Текст=ТекстЗапроса;
РезультатЗапроса=Запрос.Выполнить();

Если РезультатЗапроса.Пустой()=Истина  Тогда
Ответ = Вопрос("На выбранную машину бригады нет. Выбрать другую машину?", РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да);
Если Ответ = КодВозвратаДиалога.Да Тогда
Транспорт=Справочники.ТранспортныеСредства;
ФормаСписка=Транспорт.ПолучитьФормуВыбора();
  Если Не ФормаСписка.Открыта() Тогда
  ФормаСписка.ОткрытьМодально();
  // ???
  КонецЕсли;
Иначе Закрыть();  
    КонецЕсли;
КонецЕсли;                                                 
КонецПроцедуры

проверка должна осуществляться по выбранному транспортному средству.

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Лучше всего будет реализовать подписку на данное событие.....


Теги:
 

Всем добрый день,подскажите как реализовать в документе реализации товаров и услуг добавить расчет от всего то есть при вводе всего рассчитывается ндс и цена

Автор skynet7017Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 513
Последний ответ 04 Сен 2019, 10:15
от skynet7017
Подскажите как реализовать "планинг"?

Автор cannabis_86Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3231
Последний ответ 20 Июн 2011, 10:29
от cska-fanat-kz
Как реализовать "разделение" документа на два по отдельным позициям.

Автор Владимир СтароверовРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 322
Последний ответ 21 Апр 2020, 12:03
от Владимир Староверов
Система компоновки данных – как в макете реализовать сложение(вычитание) ячеек?

Автор sapravkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4988
Последний ответ 14 Фев 2013, 22:34
от sapravka
Запись клиентов на определенную дату-время: подскажите как реализовать?

Автор nst1Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 2147
Последний ответ 21 Июн 2017, 23:03
от oleg-x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
78 Сообщений
IL2016
32 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
oooo800
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
alexandr_ll
14 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 526
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal