Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 16:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: получение параметров из макета СКД  (Прочитано 5391 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Прошу помощи,
ситуация такая, строю отчет на СКД, источник данных - таблица значений к\ю получаю запросом в процедуре ПриКомпоновкеРезультата и передаю в СКД, запрос использует период, как вариант можно создать реквизит Период и задавать его значение в форме отчета, но хотел сделать красивее - создал параметр Период в самой СКД, но проблема в следующем, если я устанавливаю значение периода по умолчанию в конфигураторе в СКД, то такой период виден программно, если же я меняю период на форме, то значение не меняется, а остается заданным по умолчанию,
вопрос: как получить значение параметра СКД установленного в форме отчета программно?


Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
А у вас какая конфигурация? У меня в общем модуле есть функция.

Функция ПодготовитьВнешниеНаборыДанных(ОтчетОбъект) Экспорт
.....
ТиповыеОтчеты.ПолучитьПараметр(ОтчетОбъект.КомпоновщикНастроек, "ДатаОтчета").Значение.Дата;......КонецФункции

В общем модуле:
Функция ПолучитьПараметр(КомпоновщикНастроекКоллекцияЗначений, ИмяПараметра) Экспорт
   
   Если ТипЗнч(КомпоновщикНастроекКоллекцияЗначений) = Тип("КомпоновщикНастроекКомпоновкиДанных")
      ИЛИ ТипЗнч(КомпоновщикНастроекКоллекцияЗначений) = Тип("ДанныеРасшифровкиКомпоновкиДанных") Тогда
      ЗначениеПараметра = КомпоновщикНастроекКоллекцияЗначений.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных(ИмяПараметра));
   ИначеЕсли ТипЗнч(КомпоновщикНастроекКоллекцияЗначений) = Тип("КоллекцияЗначенийПараметровКомпоновкиДанных") Тогда
      ЗначениеПараметра = КомпоновщикНастроекКоллекцияЗначений.Найти(ИмяПараметра);
   ИначеЕсли ТипЗнч(КомпоновщикНастроекКоллекцияЗначений) = Тип("ОформлениеКомпоновкиДанных") Тогда
      ЗначениеПараметра = КомпоновщикНастроекКоллекцияЗначений.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных(ИмяПараметра));
   КонецЕсли;
   
   Возврат ЗначениеПараметра;
   
КонецФункции

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
создаю внешний отчет для УТ11, смотрю тут то же куча общих модулей связанных с отчетами, но это не решит проблему, т.к. параметры к\е передаются в эти модули откуда то же берутся, счас смотрю каждый отчет :xfbnsdfb: может что мне нужно и найду


Теги:
 

Получение начальных и конечных остатков из таблицы остатков и таблицы оборотов

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 281
Последний ответ 23 Фев 2018, 14:13
от AIFrame
Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10827
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Отображение HTML-макета в форме с HTML-полем.

Автор spikee666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3987
Последний ответ 21 Авг 2014, 17:51
от spikee666
Как при помощи СКД при формировании макета отчета данные связанного набора данных вывести в Параметр через ";"

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1186
Последний ответ 01 Мар 2016, 14:33
от sveta C
Получение налогового вычета компании, которая оформила договор купли-продажи товара и внесла в качестве аванса заемные средства

Автор topicsРаздел Статьи

Ответов: 1
Просмотров: 1116
Последний ответ 12 Окт 2014, 23:14
от lux4home

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 688
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal