Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 21:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: нужно вставить текущую дату  (Прочитано 2829 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн fagust1982

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-17
  • Сайт: 
  • Профессия: Программист 1С
 
//определить год по реквизиту дата сообщение
//документ дело
таб =  РеквизитФормыВЗначение("Объект");
р=таб.ДокументДело.Договор.НомерДоговора;
j=Формат(ТекущаяДата(),"ДФ= г");

//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
//Сообщение.Сообщить();
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=р;
//Сообщение.Сообщить();
з=Новый Запрос;
з.УстановитьПараметр("Номер",таб.ДокументДело.Договор);
з.Текст="ВЫБРАТЬ
| Заявление.Ссылка,
| Заявление.Договор.НомерДоговора
|ИЗ
| Документ.Заявление КАК Заявление
|ГДЕ
| Заявление.Договор = &Номер";
рез=з.Выполнить().Выгрузить();
  Для каждого тек из рез Цикл
  //ф=тек.Ссылка
// Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
//Сообщить(Формат(ТекущаяДата(),"ДФ= г"));
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=тек.Ссылка.НомерДелаЮА;
//Сообщение.Сообщить();
КонецЦикла;
з=Новый Запрос;
з.УстановитьПараметр("Номер",таб.ДокументДело);
з.Текст="ВЫБРАТЬ
| СтраховойАкт.Ссылка,
| СтраховойАкт.Заявление
|ИЗ
| Документ.СтраховойАкт КАК СтраховойАкт
|ГДЕ
| СтраховойАкт.Заявление = &Номер";
рез=з.Выполнить().Выгрузить();

Для каждого тек из рез Цикл
// j=Формат(ТекущаяДата(),"ДФ= г");
// Сообщение = Новый СообщениеПользователю;
// Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
//Сообщить(Формат(ТекущаяДата(),"ДФ= г"));

//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=тек.Ссылка.Номер;
//Сообщение.Сообщить();
КонецЦикла;
n=таб.ДокументДело.Договор.Продукт;
Если лев(СокрЛП(нрег(n)),5)=("каско") ИЛИ найти(n,"КАСКО")>0 Тогда

h=("к");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("к");
//Сообщение.Сообщить();
КонецЕсли;
Если лев(СокрЛП(нрег(n)),5)=("го") ИЛИ найти(n,"ГО")>0  Тогда
h=("о");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("о");
//Сообщение.Сообщить();
КонецЕсли;
Если лев(СокрЛП(нрег(n)),5)=("майно") ИЛИ найти(n,"Майно")>0 Тогда
h=("м");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("м");                                                         
//Сообщение.Сообщить();
КонецЕсли;       
Если лев(СокрЛП(нрег(n)),5)=("дго") ИЛИ найти(n,"ДГО")>0 Тогда
h=("д");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("д");
//Сообщение.Сообщить();
КонецЕсли;
// Если найти(n,"НомерДоговора")>0 Тогда
// Сообщение = Новый СообщениеПользователю;
// Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
// Сообщить(Формат(ТекущаяДата(),"ДФ= г"));
//
//КонецЕсли;

  t = р+h;
 
сообщить(t);
j=Формат(ТекущаяДата(),"ДФ= г");
выводит 1624.01.1213к, а нужно 1624.1301.12к.

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2013, 13:49


Оффлайн DmitriyF

  • *****
  • Сообщений: 730
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
//определить год по реквизиту дата сообщение
//документ дело
таб =  РеквизитФормыВЗначение("Объект");
р=таб.ДокументДело.Договор.НомерДоговора;
j=Формат(ТекущаяДата(),"ДФ= г");

//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
//Сообщение.Сообщить();
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=р;
//Сообщение.Сообщить();
з=Новый Запрос;
з.УстановитьПараметр("Номер",таб.ДокументДело.Договор);
з.Текст="ВЫБРАТЬ
| Заявление.Ссылка,
| Заявление.Договор.НомерДоговора
|ИЗ
| Документ.Заявление КАК Заявление
|ГДЕ
| Заявление.Договор = &Номер";
рез=з.Выполнить().Выгрузить();
  Для каждого тек из рез Цикл
  //ф=тек.Ссылка
// Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
//Сообщить(Формат(ТекущаяДата(),"ДФ= г"));
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=тек.Ссылка.НомерДелаЮА;
//Сообщение.Сообщить();
КонецЦикла;
з=Новый Запрос;
з.УстановитьПараметр("Номер",таб.ДокументДело);
з.Текст="ВЫБРАТЬ
| СтраховойАкт.Ссылка,
| СтраховойАкт.Заявление
|ИЗ
| Документ.СтраховойАкт КАК СтраховойАкт
|ГДЕ
| СтраховойАкт.Заявление = &Номер";
рез=з.Выполнить().Выгрузить();

Для каждого тек из рез Цикл
// j=Формат(ТекущаяДата(),"ДФ= г");
// Сообщение = Новый СообщениеПользователю;
// Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
//Сообщить(Формат(ТекущаяДата(),"ДФ= г"));

//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=тек.Ссылка.Номер;
//Сообщение.Сообщить();
КонецЦикла;
n=таб.ДокументДело.Договор.Продукт;
Если лев(СокрЛП(нрег(n)),5)=("каско") ИЛИ найти(n,"КАСКО")>0 Тогда

h=("к");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("к");
//Сообщение.Сообщить();
КонецЕсли;
Если лев(СокрЛП(нрег(n)),5)=("го") ИЛИ найти(n,"ГО")>0  Тогда
h=("о");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("о");
//Сообщение.Сообщить();
КонецЕсли;
Если лев(СокрЛП(нрег(n)),5)=("майно") ИЛИ найти(n,"Майно")>0 Тогда
h=("м");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("м");                                                         
//Сообщение.Сообщить();
КонецЕсли;       
Если лев(СокрЛП(нрег(n)),5)=("дго") ИЛИ найти(n,"ДГО")>0 Тогда
h=("д");
//Сообщение = Новый СообщениеПользователю;
//Сообщение.Текст=("д");
//Сообщение.Сообщить();
КонецЕсли;
// Если найти(n,"НомерДоговора")>0 Тогда
// Сообщение = Новый СообщениеПользователю;
// Сообщение.Текст=Формат(ТекущаяДата(),"ДФ= г");
// Сообщить(Формат(ТекущаяДата(),"ДФ= г"));
//
//КонецЕсли;

  t = р+h;
 
сообщить(t);
j=Формат(ТекущаяДата(),"ДФ= г");
выводит 1624.01.1213к, а нужно 1624.1301.12к.
Ты конечно извини но если стал работать с программирование то применяй общие правила.


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9365
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2762
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Нужно добавить к документу "Оригинал получен"

Автор ZnNuРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 736
Последний ответ 27 Окт 2016, 08:37
от alexandr_ll
Что нужно делать чтобы в отчете "Продажи по оплате" отображалась стоимость услуг?

Автор TonyMontanaSlotРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1311
Последний ответ 02 Апр 2015, 12:28
от Artemtriplex
Для всех документов нужно сделать проверку при проведении. Где это можно сделать?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 643
Последний ответ 04 Сен 2016, 04:20
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 215
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal