Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 13:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обход справочников  (Прочитано 4403 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Ребят... задача такая что нужно обойти справочник Книга, и обнулить реквизит "состояние". Пишу обработку, до поры до времени работает, а потом начинает брать и созданные группы (родитель) итого получаю ошибку "Реквизит недоступен для группы"


Процедура Обработать();
   
    // Сброс статусов всех книг
    СпрСсылка = Справочники.Книга.Выбрать();

    Пока СпрСсылка.Следующий() Цикл
       
       
        СпрОбъект = СпрСсылка.ПолучитьОбъект();
        СпрОбъект.Состояние = Перечисления.СостояниеКниги.ПустаяСсылка();
        СпрОбъект.Записать();
        Сообщить(СпрОбъект.Код);
       
    КонецЦикла;
   
КонецПроцедуры

Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ну так не обрабатывайте группы :)
варианты решения:
1. описать выборку при помощи запроса, в котором условие ЭтоГруппа = Ложь
2. попробовать использовать тот же метод менеджера справочника, но в отборе указать ЭтоГруппа = Ложь (там через структуру делается, не знаю, сработает ли)
3. в цикле при обходе проверять значение ЭтоГруппа и если ЭтоГруппа = Истина, не менять реквизит
Добавлено: 26 Дек 2013, 12:15

P.S. я бы сделал запросом.

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
так, щас попробую через условие...

Добавлено: 26 Дек 2013, 12:32

спасибо всё получилось, через условие.
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Процедура Обработать();
   
    // Сброс статусов всех книг
    СпрСсылка = Справочники.Книга.Выбрать();

    Пока СпрСсылка.Следующий() Цикл
       
        Если НЕ СпрСсылка.ЭтоГруппа Тогда
        СпрОбъект = СпрСсылка.ПолучитьОбъект();
        СпрОбъект.Состояние = Перечисления.СостояниеКниги.ПустаяСсылка();
        СпрОбъект.Записать();
        Сообщить(СпрОбъект.Код);
        КонецЕсли;
       
    КонецЦикла;
   
КонецПроцедуры


Теги:
 

Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3018
Последний ответ 29 Май 2013, 16:24
от leklerk
Re: 1c 8.2: Не могу получить программный доступ к Стандартному ревизиту Наименование одного из Справочников

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1395
Последний ответ 04 Сен 2014, 09:44
от cska-fanat-kz
некорректная работа групповой обработкой справочников и документов, плиз, помоги

Автор OlgaBShРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1716
Последний ответ 22 Дек 2012, 16:06
от OlgaBSh
Как в запросе сравнить коды элементов в табличных частях двух справочников

Автор ServalРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2978
Последний ответ 29 Окт 2014, 15:26
от Serval
Как 1С загружает данные из различных справочников/документов для объединения ссылок

Автор AlexSviridovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 517
Последний ответ 08 Май 2015, 18:46
от AlexSviridov

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 846
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal