Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавления макета типа Active Document.  (Прочитано 5754 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
В документе Приём на работу, нужно создать макет Active document, поместив в него Приказ о приёме на работу. Нужно чтобы ФИО в этом приказе изменялись на указанные в документе ФИО. Как это можно осуществить?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.


Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Подскажите, существует ли какое-нибудь пособие по работе с макетами?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Думаю, что в пособии по разработке. В стандартной поставке "Конфигурирование и администрирование" вроденет. хотя все может быть.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн ingenium

  • ingenium43.ru
  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • http://ingenium43.ru
  • Регистрация: 2014-01-03
  • Компания: ООО "Инжениум"
  • Профессия: Программист 1С
В документе Приём на работу, нужно создать макет Active document, поместив в него Приказ о приёме на работу. Нужно чтобы ФИО в этом приказе изменялись на указанные в документе ФИО. Как это можно осуществить?

Какая конфигурация и какой макет?
Компания Ingenium
http://ingenium43.ru

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
При создании печатной формы, добавляем макет в виде ActiveDocument.
То что нужно заменить к примеру в документе пишем %ЗаменитьЭто% и пошло, поехало в модуле объекта.

Процедура Напечатать Экспорт()
..............................
АктивныйДокумент = ПолучитьМакет(Макет);
КомОбъект = АктивныйДокумент.Получить();
..............................
КонецПроцедуры

Процедура ПрочитатьЗакладки()
..............................
ВывестиЗакладки("%ЗаменитьЭто%", Заполняем);
..............................
КонецПроцедуры

Процедура ВывестиЗакладки(НаименованиеЗакладки, ЗначениеЗакладки)
Заменить = КомОбъект.Content.Find;
Заменить.Execute(НаименованиеЗакладки,,,,,,,,,СокрЛП(ЗначениеЗакладки),2);
КонецПроцедуры



Оффлайн анна1992

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-02-27
  • Сайт: 
  • Профессия: Ученик 1С
а куда именно записывается этот код? при записи или в процедуру печати?


Теги:
 

Значение поля "Лицевой счет" содержит недопустимое значение типа лицевого счета

Автор unantedРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3835
Последний ответ 24 Июл 2012, 05:02
от unanted
При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 475
Последний ответ 20 Сен 2017, 09:10
от Геннадий ОбьГЭС
Значение не является значением объектного типа (Значение)

Автор НикитaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2955
Последний ответ 05 Мар 2014, 09:56
от KrivosheevEV
"Свой метод" типа Свернуть

Автор beztrudРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 4393
Последний ответ 17 Окт 2014, 12:44
от beztrud
Очистить значение типа "Хранилище значения"

Автор ЛеонидРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4728
Последний ответ 22 Ноя 2009, 17:45
от Никитина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal