Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 02:01

v7: Отображение остатка при выборе значения в реквизите шапки

Автор spyblack, 01 апр 2010, 15:37

0 Пользователей и 1 гость просматривают эту тему.

spyblack

Есть документ ПРОИЗВОДСТВО его дописали в Комплексную конфигурацию.
Так вот. При выборе реквизита  "Продукция" (изделие которое нужно произвести) нужно что бы отображался остаток по складу в документе.
Подскажете с помощью какой функции или запроса это можно реализовать?

1С 7.7 бухгалтерия+торговля+склад+зарплата+кадры 7.70.019 для Украины

Tatitutu

Во первых есть разница
при открытии нового документа
проведенного или из "архива"
разница бутет сам понимаешь

если даннные будет не нужны после проведения документа , т.е. они Вам нужны только для информации

напишите формулу в модуле докунта

Если Выбран()=0 Тогда
//документ Новый
Ост= РегОстатков.СводныйОстаток(Склад,Товар,,,,,"Количество");
Возврат Ост;
КонецЕсли;

*  MAGAZKA - лучшая программа для розничного магазина (с) *

spyblack

я хочу это сделать следующим образом: Текст на форму. На текст функцию. В функции вычисляешь остаток. Так же возможно?

Tatitutu

лучше при изменении реквизита - один раз получили остаток - приняли решение и.т.д.
если функция на форме - она будет многократно пересчитываться - от сюда тормоза

*  MAGAZKA - лучшая программа для розничного магазина (с) *

spyblack

Написал этот программный код в модуль дока. как понимаю при вводе нового должно выдаваться сообщение об остатке?

Если Выбран()=0 Тогда
//документ Новый
Ост= РегОстатков.СводныйОстаток(Склад,Товар,,,,,"Количество");
Возврат Ост;
КонецЕсли;

Tatitutu

нет не так
Вы просто скопировали мой пример , а это именно пример
Вам нужно узнасть в каком регистре "хранятся" остатки товаров
сколько реквизитов у регистра (например, фирма, склад, товар, размер, и.т.д.)

при открытии документа создать переменную
РегОстатков=СоздатьОбъект("Регистр.ВашРегистраОстатков");
и после этого в процедуре выбора значения можно будет получать остаток товара.

*  MAGAZKA - лучшая программа для розничного магазина (с) *

spyblack

Спасибо за помощь. Так мало людей которые помогают. Буду пробовать все это воплотить в жизнь)

Tatitutu

Обращайся - всегда готов подсказать, там ничего сложного - главное уловить суть и взаимосвязь объектов

*  MAGAZKA - лучшая программа для розничного магазина (с) *

spyblack

Процедура ВыборЗначения()
Что там писать? У меня в документе такой процедуры нет

Tatitutu

Процедура ОбработкаВыбораЗначения(<?>,,)
КонецПроцедуры
Синтаксис:
ОбработкаВыбораЗначения(<ВыбЗнач>,<ИдентЭлемДиалога>,<ФлагСтандОбр>)
Назначение:
Предопределенная процедура после выбора значения в форме выбора (выбор может быть инициирован в немодальном режиме интерактивно, при помощи элемента диалога с ''педалькой'').
<ВыбЗнач> - выбранный элемент справочника, документ или иной объект, передаваемый для обработки.
<ИдентЭлемДиалога> - идентификатор элемента диалога, которым инициализирован выбор значения.
<ФлагСтандОбр> - флаг, установка которого в теле процедуры в 0 (ноль) приведет к отмене стандартного присвоения значения.
Замечание:
Данная процедура может располагаться только в программном модуле формы.
Подробнее см. в документации, глава 'Системные


Пишешь

Процедура ОбработкаВыбораЗначения(ВыбЗнач,ЭлементДиалога,Флаг)
Если ЭлементДиалога = "твойРеквизит" Тогда
   //получаем остаток на складе для товара = ВыбЗнач
КонецЕсли;
КонецПроцедуры

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Теги:

Похожие темы (5)

7243

Ответов: 3
Просмотров: 2579

1858

Ответов: 3
Просмотров: 7422

69900

Ответов: 6
Просмотров: 2959

41778

Ответов: 9
Просмотров: 4457

Рейтинг@Mail.ru Rambler's Top100

Поиск