Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 14:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение счета в бухгалтерской операции  (Прочитано 1824 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rootvorg

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-25
  • Сайт: 
1с 8.2.19.76
Бухгалтерия государственного учреждения, редакция 1.0 (1.0.22.4)
В 1С до этого никогда не писал

Есть 5000 Бухгалтерский проводок с не правильным счетом. Нужно массово поменять с одного на другой.

погуглив написал следующее

Процедура Кнопка1Нажатие(Элемент)
   НачДата=Дата("20131129");
   КонДата=Дата("20131129");
   бухОперация=Документы.ОперацияБух.Выбрать(НачДата,КонДата);
   ии=0;
   сумм=0;
   Пока бухОперация.Следующий() Цикл
   рб=РегистрыБухгалтерии.ЕПСБУ.ВыбратьПоРегистратору(бухОперация.Ссылка);
   Пока рб.Следующий() Цикл
   Если (рб.СчетДт=ПланыСчетов.ЕПСБУ.НайтиПоКоду("109.61")) И (рб.КВД=Перечисления.КВД.СубсидииНаИныеЦели)
   Тогда
               //Сообщить(рб.СчетДт.Код);
               //рб.Сумма=100;
                   Сообщить(ии);
               ии=ии+1;
   сумм=сумм+рб.Сумма;
               //Сообщить(ии);
   для каждого ск из рб.СчетДт.ВидыСубконто цикл
                   Сообщить("*"+рб.СубконтоДт[ск.ВидСубконто]);
   Сообщить("*****"+ск.ВидСубконто);
   КонецЦикла

           КонецЕсли;
   КонецЦикла;
   
   НД = РегистрыБухгалтерии.ЕПСБУ.СоздатьНаборЗаписей();
   НД.Отбор.регистратор.установить(бухОперация.Ссылка);
   НД.Прочитать();
   
   Если не НД.Количество() = 0 Тогда
    Для каждого Запись Из НД Цикл // вот это - работает

    Запись.СчетДт = ПланыСчетов.ЕПСБУ.НайтиПоКоду("401.20");

    КонецЦикла;
   
   КонецЕсли;

   НД.Записать();

   
   КонецЦикла;
   Сообщить(ии);
   Сообщить(сумм);
КонецПроцедуры

Падает с ошибкой: Запись не верна! Вид субконто "Номенклатура" не доступен для этой записи!

Проблема в том что к 401.20 не привязано ни одно субконто. Как его удалить?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6649
  • РЕПУТАЦИЯ: 786
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Зпись.СубконтоДт.Номенклатура = Неопределено;

Как то так.


Теги:
 

Значение поля "Лицевой счет" содержит недопустимое значение типа лицевого счета

Автор unantedРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4219
Последний ответ 24 Июл 2012, 05:02
от unanted
Не выгружается документ основания для счета фактуры с типом возврат, когда документ основание поступление выгружается, КД 2

Автор Алексей ГеннадьевичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 707
Последний ответ 21 Апр 2017, 04:55
от Алексей Геннадьевич
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 521
Последний ответ 12 Окт 2017, 14:02
от wise
Как запретить пользователям с интерфейсом "Ввод табеля" изменение графы профессия у подобранного сотрудника в сдельном наряде и табеле учета рабочего времени

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1348
Последний ответ 15 Сен 2016, 02:46
от ksander-fars
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 520
Последний ответ 18 Авг 2017, 11:57
от ZSS

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
42 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
31 Сообщений

* Кто онлайн

  • Точка Гостей: 688
  • Точка Скрытых: 0
  • Точка Пользователей: 20
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal