Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 00:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: не могу розобратса как обновить значения справочника с документа  (Прочитано 1504 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fenix1993

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-20
  • Сайт: 
  • Профессия: Ученик 1С
 Процедура ТоварыТоварПриИзменении(Элемент)
   СтрокаТабличнойЧасти = Элементы.Товары.ТекущиеДанные;
   СтрокаТабличнойЧасти.Цена = НайтиЦену(СтрокаТабличнойЧасти.Товар);
КонецПроцедуры

Функция НайтиЦену(Элемент)
   Цена = Справочники.Номенклатура.НайтиПоНаименованию(Элемент).Цена;
   Возврат Цена;
КонецФункции

Функция РасчитатьСумму(Цена,Количество)
   Сумма = Цена * Количество;
   Возврат Сумма;
КонецФункции
&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)
   СтрокаТабличнойЧасти =Элементы.Товары.ТекущиеДанные;
   СтрокаТабличнойЧасти.Сумма = РасчитатьСумму(СтрокаТабличнойЧасти.Цена,СтрокаТабличнойЧасти.Количество);
КонецПроцедуры

ето код документа РосходнаяНакладная. я хочу в процедуре ТоварыКоличествоПриИзменении(Элемент) зделать так, штоб менялись данние в справочнике (Номенклатура.Количество), тобиш штоб от предедущему значения отнималось то што записано в етом документе.
 помогите, срочно надо(((


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
ето код документа РосходнаяНакладная. я хочу в процедуре ТоварыКоличествоПриИзменении(Элемент) зделать так, штоб менялись данние в справочнике (Номенклатура.Количество), тобиш штоб от предедущему значения отнималось то што записано в етом документе.
 помогите, срочно надо(((
месье знает толк в извращениях


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
ето код документа РосходнаяНакладная. я хочу в процедуре ТоварыКоличествоПриИзменении(Элемент) зделать так, штоб менялись данние в справочнике (Номенклатура.Количество), тобиш штоб от предедущему значения отнималось то што записано в етом документе.
 помогите, срочно надо(((
месье знает толк в извращениях

:D:D:D:zebzdr:



Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15931
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7744
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4781
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1584
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 206
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal