Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите решить проблему  (Прочитано 1273 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jogurt12

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-18
  • Сайт: 
  • Профессия: Бухгалтер
После отладки конфигуратор выдает следующую ошибку :{ОбщийМодуль.ОбщепитДокументы.Модуль(722)}: Поле объекта не обнаружено (ОбщепитТаблицаСуммСписания)
   
Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) и выделяет следующую область :
Функция ОбщепитТоварыПриВыводеСтроки(ЭтаФорма, ТабличноеПоле, Элемент, ОформлениеСтроки, ДанныеСтроки) Экспорт
Если ТабличноеПоле.Колонки.Найти("СуммаСписания") = Неопределено
ИЛИ НЕ ТабличноеПоле.Колонки.СуммаСписания.Видимость Тогда
Возврат 0;
КонецЕсли;

СуммаСписания = 0;
Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура)
И ЭтаФорма.ЭтотОбъект.Проведен
И НЕ ЭтаФорма.ОбщепитТаблицаСуммСписания.Количество() = 0 Тогда

СтрокаСуммСписания =  ЭтаФорма.ОбщепитТаблицаСуммСписания.Найти(ДанныеСтроки.Номенклатура ,"Номенклатура");
Если СтрокаСуммСписания <> Неопределено Тогда
СуммаСписания = СтрокаСуммСписания.Сумма;
КонецЕсли;

КонецЕсли;

ОформлениеСтроки.Ячейки.СуммаСписания.Выравнивание=ГоризонтальноеПоложение.Право;
Если СуммаСписания < 0 Тогда
ОформлениеСтроки.Ячейки.СуммаСписания.ЦветТекста = WebЦвета.Красный;
КонецЕсли;
ОформлениеСтроки.Ячейки.СуммаСписания.УстановитьТекст(Формат(СуммаСписания,"ЧЦ=15; ЧДЦ=2; ЧРГ=' '; ЧН=0.00"));
КонецФункции


Последний раз редактировалось: MuI_I_Ika; 18 Дек 2013, 16:30


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Вы привели функцию из какой-то формы, а у вас ошибка в общем модуле:

ОбщийМодуль.ОбщепитДокументы.Модуль


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4292
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5550
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5885
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4365
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 841
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal