Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 00:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Загрузка групп верхнего уровня СКД в Таблицу Значений  (Прочитано 3693 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн amina1000

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-19
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет. Создала отчет СКД с иерархией, загрузила данные отчета в Таблицу значений на форму, выгружается весь отчет в таблицу. Мне нужно чтоб выгружались только группы верхнего уровня. как сделать это программно, не меняя структуры СКД?


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
странно, а чем не подходит изменение СКД, не выводите область детальных записей и у вас будут только группировки

Оффлайн amina1000

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-19
  • Сайт: 
  • Профессия: Ученик 1С
не подходить так как загрузка данных идет в несколько таблиц. Нужны все поля. Как реализовать обход по группам программно?

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
непойму чего вы хотите, СКД выгружает данные не "в таблицу значений на форме" в табличный документ к\й отображается на форме
больше давайте информации
Добавлено: 18 Дек 2013, 18:09

кажется я понял чего вы хотите, сделайте в Другие настройки > Отображение полей группировок > Отдельно и только в итогах, тогда в ТЗ будет строка на уровне группировки содержать значение, а на уровне детальных записей будет null или неопределено, т.о. при обходе строк по значению в этой колонке вы сможете отловить группировки,
если же у вас настройки сделаны без Отдельно и только в итогах, то можно объявить переменную перед обходом ТЗ в к\й вы будете сохранять значение группировки, при каждом обходе строки проверять если равна эта переменная предыдущему значению, то это детальные записи, если нет то это уровень группировки

Последний раз редактировалось: Besart; 18 Дек 2013, 18:09. Причина: Объединение сообщений

Оффлайн amina1000

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-19
  • Сайт: 
  • Профессия: Ученик 1С
Решила просто удалить повторяющиеся строки в ТабЗн. вот мой код
Процедура Команда1(Команда)
      
   МаксимальныйИндекс = Таб.количество() -1;
Пока МаксимальныйИндекс > 0 Цикл
   если таб.Получить(МаксимальныйИндекс)=таб.Получить(МаксимальныйИндекс-1)
      тогда
       Таб.Удалить(МаксимальныйИндекс)
       конецЕсли;
МаксимальныйИндекс = МаксимальныйИндекс -1;
КонецЦикла
      
   КонецПроцедуры
ничего не удаляется. Как можно сравнить две строки текущую и след. в таб? Если можно примеры

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Я как то для обработки такую конструкцию использовал (которую, кстати по поиску из нета вытащил)
Функция УдалитьСтрокиПовторяющихсяКонтрагентов(ТаблицаЗначений) Экспорт
Для Каждого Строка Из ТаблицаЗначений Цикл

Отбор = Новый Структура("Контрагент", Строка.Контрагент);
    НайденноеЗначение = ТаблицаЗначений.НайтиСтроки(Отбор);
КолвоЭлементовВМассиве = НайденноеЗначение.Количество();

Если КолвоЭлементовВМассиве = 1 Тогда
Продолжить;
Иначе
Для ОбратныйИндекс = 1 По (КолвоЭлементовВМассиве - 1) Цикл
ЭлементМассива = НайденноеЗначение[КолвоЭлементовВМассиве - ОбратныйИндекс];
ТаблицаЗначений.Удалить(ЭлементМассива);
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецФункции

Оффлайн amina1000

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-19
  • Сайт: 
  • Профессия: Ученик 1С
Вопрос решила вот так
   Процедура Команда1(Команда)
      
   сч = Таб.количество() -1;
Пока сч > 0 Цикл
   если Элементы.таб.ДанныеСтроки(сч).Заказы=Элементы.таб.ДанныеСтроки(сч-1).Заказы
      тогда
       Таб.Удалить(сч)
       иначе сообщить(Элементы.таб.ДанныеСтроки(сч).Заказы)
       конецЕсли;
сч = сч -1;
КонецЦикла
      
   КонецПроцедуры
Всем спасибо!


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 685
Последний ответ 20 Мар 2018, 16:54
от alex0402
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 9308
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
загрузка из "клиента банка"

Автор miximlРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3010
Последний ответ 19 Июн 2012, 09:49
от miximl
Загрузка в 1С Управление Торговлей 11.1.5.16 электронных выписок из клиент банка "Альфа-Банк"

Автор regnusРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 13329
Последний ответ 11 Июл 2014, 17:22
от regnus
Проблема с внешней обработкой "Загрузка банк-клиент.erp"

Автор razielРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2588
Последний ответ 24 Сен 2015, 20:13
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
30 Сообщений

* Кто онлайн

  • Точка Гостей: 191
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal