Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 02:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Простая обработка  (Прочитано 1448 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lindstorm

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-15
  • Сайт: 
Здравствуйте. Я в 1С новичок, поэтому заранее извиняюсь за беспокойство.
У меня 1С конфигурация связана с выдачей кредитов  - клиент заполняет анкету о доходах,
данные заносятся в справочник и оттуда данные нужно считать, решив  - давать кредит или нет.
Я создал обработку - на ней выбирается клиент(ссылка на справочник Клиенты) и пытаюсь в поле Реквизит1 вынести значение. Но ничего не выводит..

&НаКлиенте
Процедура ДатьКредит(Команда)
   Клиент = Объект.Клиент;
   ДатьКредитНаСервере(Клиент);
КонецПроцедуры

&НаСервере
Процедура ДатьКредитНаСервере(Клиент)
      Запрос = Новый Запрос;
      Запрос.УстановитьПараметр("Клиент", Клиент);
      Запрос.Текст = "
      |ВЫБРАТЬ
      |     Анкеты.ЕжемесячныеДоходы
      |ИЗ Справочник.АнкетыКлиентов КАК Анкеты
      |ГДЕ
      |    Анкеты.ФИО =  &Клиент";
      Рез =  Запрос.Выполнить().Выбрать();
      Пока Рез.Следующий()  Цикл
         Реквизит1 = Рез;
      КонецЦикла;
      
Скажите пожалуйста, что неправильно? И возможно тут нужна не обработка.
         


Оффлайн sdilshod

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 11
  • КПД: 14%
  • Регистрация: 2013-09-30
  • Сайт: 
  • Профессия: Программист 1С
    |     Анкеты.ЕжемесячныеДоходы
      |ИЗ Справочник.АнкетыКлиентов КАК Анкеты
      |ГДЕ
      |    Анкеты.ФИО =  &Клиент";
      Рез =  Запрос.Выполнить().Выбрать();
      Пока Рез.Следующий()  Цикл
         Реквизит1 = Рез; //Здесь надо передать поля из выборки результата запроса. [b]Рез.ЕжемесячныеДоходы[/b]

      КонецЦикла;

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Я бы еще до вывода результата в тексте запроса дописал бы условие на проверку по количеству доходов - можно давать кредит или нет!
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 157
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal