Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Продажа по сч41, и 43  (Прочитано 1990 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Помогите разобраться как можно выбирать на форме ГруппыНоменклатуры и присваивать значение по счету 41.2:
 
процедура ЗаполнитьТзИтоги(тзитоги,сч);
   
   грПакеты = "000000001";
   грФурнитура = "000000002";
   би = создатьОбъект("БухгалтерскиеИтоги");
   би.ИспользоватьСубконто(ВидыСубконто.Номенклатура,,1);
   би.ИспользоватьСубконто(ВидыСубконто.МестаХранения,константа.МхСГП,2);
   если сч = счетПокоду("41.2") тогда
      если грНом.выбран() = 1 тогда
         //би.ИспользоватьСубконто(видыСубконто.Контрагенты,грНом,2);
      КонецЕсли;
   КонецЕсли;
   би.ВыполнитьЗапрос(датаНач,датаНач,сч,,,,,"К");    //датаКон,
   би.Выбратьсубконто(1);
   пока би.получитьСубконто(1) = 1 цикл
      номенклатура = би.Субконто(1);
      если пустоеЗначение(номенклатура) = 1 тогда
         продолжить;
      КонецЕсли;
      если (номенклатура.Родитель.Код <> грПакеты) и (номенклатура.родитель.Код <> грФурнитура) тогда
         продолжить;
      КонецЕсли;
   
      продажа = би.КО("К");
      если продажа = 0 тогда
         продолжить;
      КонецЕсли; 
   
      тзитоги.НоваяСтрока();
      тзитоги.Номенклатура = номенклатура;
      тзИтоги.Наименование = номенклатура.Наименование;
      тзитоги.количество = продажа;
      тзитоги.Программа = номенклатура.Программа;
   конецЦикла;


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
продажа = би.КО("К");

Странная запись. Тебе нужны остатки для заполнения продажного документа, т.е. тебе нужно Дебетовое дебетом счета и кредитом счета.">сальдо по счету учета товаров.

Продажа = БИ.СКД("К"); // сальдо конечное дебетовое по счетам
так понятнее?

Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
продажа = би.КО("К");

Странная запись. Тебе нужны остатки для заполнения продажного документа, т.е. тебе нужно Дебетовое сальдо по счету учета товаров.

Продажа = БИ.СКД("К"); // сальдо конечное дебетовое по счетам
так понятнее?
Спс, но мне надо чтобы при Выборе группыноменклатуры он выводил по счету 41.2 значение на печать, до этого выбирались контрагенты, а теперь надо группыномеклатуры... (На рисунке)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 131
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal