Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 03:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить номер без префикса  (Прочитано 6987 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С

Очень часто при разработке собственных решений на 1с требуется получать номера документов или коды справочников без префикса. Это нужно, например, для вывода номера на печать.


Однако средствами платформы произвести такую трансформацию не получается. Поэтому каждый разработчик сам для себя решает данную задачу. В данном примере я предлагаю вычислять префикс путем отделения в номере числовой части от буквенной:


Функция ПолучитьНомерБезПрефикса(Номер)

Результат = Номер;

Для к = 1 по СтрДлина(Номер) Цикл

Символ = Сред(Номер,к,1);

Попытка
ЧислоСимвола = Число(Символ);
Исключение
ЧислоСимвола = Неопределено;
КонецПопытки;

Если ЧислоСимвола <> Неопределено Тогда

Результат = Сред(Номер,к);
Прервать;

КонецЕсли;

КонецЦикла;

Возврат Результат;

КонецФункции


Теги:
 

как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1441
Последний ответ 02 Дек 2016, 12:58
от Jalib
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2374
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 9927
Последний ответ 07 Май 2015, 14:38
от Opty
Как получить цену товара контрагента и количество реализованного товара

Автор kbukaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1894
Последний ответ 08 Сен 2015, 15:46
от Klyacksa
Не удалось получить свойство "length" ссылки

Автор MuI_I_IkaРаздел Ошибки 1С:Предприятия

Ответов: 0
Просмотров: 1238
Последний ответ 24 Ноя 2016, 10:28
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Alter
29 Сообщений
ilyay ilyay
29 Сообщений
Анюта17
29 Сообщений

* Кто онлайн

  • Точка Гостей: 198
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal