Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Мая 2021, 20:55
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Проблема с переменными в Конфигураторе 8.1  (Прочитано 4271 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex NORD

  • *
  • Регистрация: 2010-03-24
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Добрый день, уважаемые.
Начал изучение программирования и столкнулся с небольшой но неприятной проблемой в конфигураторе: когда прописываешь какую-либо процедуру аналогичную ранее прописанной, вылетает ошибка - переменная не определена. Если просто скопипастить ранее прописанную процедуру и переориентировать её на нужную строку таблицы, например, всё отлично прокатывает. С чем это связанно, и можно ли как-то эту заковыку разрешить?
Копипастить в принципе не проблема, хотя и не удобно, когда набиваешь руку и желательно больше писать эти самые процедуры, чтоб лучше запоминать, но не так давно такая же проблема возникла с написанием процедуры, которую я еще не прописывал, и скопипастить её соответственно нельзя.
Само-собой тексты процедур перепроверял десять раз и сверял с умными книжками.

Для освоения использую вполне официальную 1С Версию для обучения программирования.


Оффлайн Tatitutu

Цитировать
когда прописываешь какую-либо процедуру аналогичную ранее прописанной
что значит аналогичныю и прописываешь
если не трудно приведите на примере
и где Вы этот код пишите ?
Цитировать
Если просто скопипастить ранее прописанную процедуру и переориентировать её на нужную строку таблицы
вот с этого места по подробнее, опишите свои действия - лучше с примером.
P/S есть процедуры предопределенные

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн Alex NORD

  • *
  • Регистрация: 2010-03-24
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Да, даже самой простецкой типа автопересчета суммы в форме документа при изменении количества или цены какого либо элемента номенклатуры

Создаю и прописываю Общий модуль расчета суммы "РаботаСДокументами":
  Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество*СтрокаТабличнойЧасти.Цена;
  КонецПроцедуры

В форме документа в колонке Количество прописываю процедуру "При изменении":
  Процедура МатериалыКоличествоПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры

В колонке Цена "При изменении":
 Процедура МатериалыЦенаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры

Если процедуру для Цены набить вручную - ругается, что переменная СтрокаТабличнойЧасти не определена, а если скопипастить процедуру для Количества и подправить (заменив Количество на Цена) всё прокатывает.
Такая вот штука.

Slin
  • Гость
А можно пример того, что вы пишете?

Оффлайн Alex NORD

  • *
  • Регистрация: 2010-03-24
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Создаю и прописываю Общий модуль расчета суммы "РаботаСДокументами":
  Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество*СтрокаТабличнойЧасти.Цена;
  КонецПроцедуры

В форме документа в колонке Количество прописываю процедуру "При изменении":
  Процедура МатериалыКоличествоПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры

В колонке Цена "При изменении":
 Процедура МатериалыЦенаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
34 Сообщений
kiokiosan
18 Сообщений
alexandr_ll
13 Сообщений
DmitriyF DmitriyF
11 Сообщений
Мария2021
9 Сообщений
antoneus antoneus
9 Сообщений
Ивашка
9 Сообщений
alex0402 alex0402
8 Сообщений
kah
8 Сообщений

* Кто онлайн

  • Точка Гостей: 270
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск