Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2020, 22:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с переменными в Конфигураторе 8.1  (Прочитано 4149 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex NORD

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-24
  • Сайт: 
Добрый день, уважаемые.
Начал изучение программирования и столкнулся с небольшой но неприятной проблемой в конфигураторе: когда прописываешь какую-либо процедуру аналогичную ранее прописанной, вылетает ошибка - переменная не определена. Если просто скопипастить ранее прописанную процедуру и переориентировать её на нужную строку таблицы, например, всё отлично прокатывает. С чем это связанно, и можно ли как-то эту заковыку разрешить?
Копипастить в принципе не проблема, хотя и не удобно, когда набиваешь руку и желательно больше писать эти самые процедуры, чтоб лучше запоминать, но не так давно такая же проблема возникла с написанием процедуры, которую я еще не прописывал, и скопипастить её соответственно нельзя.
Само-собой тексты процедур перепроверял десять раз и сверял с умными книжками.

Для освоения использую вполне официальную 1С Версию для обучения программирования.


Оффлайн Tatitutu

Цитировать
когда прописываешь какую-либо процедуру аналогичную ранее прописанной
что значит аналогичныю и прописываешь
если не трудно приведите на примере
и где Вы этот код пишите ?
Цитировать
Если просто скопипастить ранее прописанную процедуру и переориентировать её на нужную строку таблицы
вот с этого места по подробнее, опишите свои действия - лучше с примером.
P/S есть процедуры предопределенные

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн Alex NORD

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-24
  • Сайт: 
Да, даже самой простецкой типа автопересчета суммы в форме документа при изменении количества или цены какого либо элемента номенклатуры

Создаю и прописываю Общий модуль расчета суммы "РаботаСДокументами":
  Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество*СтрокаТабличнойЧасти.Цена;
  КонецПроцедуры

В форме документа в колонке Количество прописываю процедуру "При изменении":
  Процедура МатериалыКоличествоПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры

В колонке Цена "При изменении":
 Процедура МатериалыЦенаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры

Если процедуру для Цены набить вручную - ругается, что переменная СтрокаТабличнойЧасти не определена, а если скопипастить процедуру для Количества и подправить (заменив Количество на Цена) всё прокатывает.
Такая вот штука.

Slin
  • Гость
А можно пример того, что вы пишете?

Оффлайн Alex NORD

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-24
  • Сайт: 
Создаю и прописываю Общий модуль расчета суммы "РаботаСДокументами":
  Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество*СтрокаТабличнойЧасти.Цена;
  КонецПроцедуры

В форме документа в колонке Количество прописываю процедуру "При изменении":
  Процедура МатериалыКоличествоПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры

В колонке Цена "При изменении":
 Процедура МатериалыЦенаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
  КонецПроцедуры


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2162
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6610
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5655
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4667
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4860
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
33 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
25 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 169
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal