Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 18:18

Автоматическое заполнение элемента формы

Автор wtfgod, 07 дек 2013, 19:22

0 Пользователей и 1 гость просматривают эту тему.

wtfgod

Здравствуйте,товарищи!
Необходима помощь.

На форме есть элемент Склад, вид Поле ввода.
Там выбиратся склад 1,склад 2, склад 3. (Справочник.Ссылка.Склады)
И есть элемент Склад 1, как поле флажка (Булево).

Так вот, нужно, чтоб при установке флажка Склад 1, в поле Склад автоматически проставлялся Склад 1. И нельзя было бы изменить.

Знаю,что для элемента формы флажка нужно назначить процедуру При изменении, но я не силен во встроенном языке, ибо новичок.
Помогите,плз,что нужно сделать?

LordWizard

Привязать к этому значку процедуру заполнения другого поля.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

wtfgod

Цитата: LordWizard от 07 дек 2013, 19:41
Привязать к этому значку процедуру заполнения другого поля.
Я понимаю. Мне бы код)

LordWizard

Код на модуле твоей формы. Откуда мну знать что у тебя там? К флажку привязываешь процедуру, в которой опрашиваешь значение флажка и соответственно передаешь значения.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

SanSay

Если правильно понял, что нужно, то:

Процедура Флажок1ПриИзменении(Элемент)
ЭлементыФормы.ПолеВвода1.Значение = Справочники.Склады.НайтиПоНаименованию("Склад1");
ЭлементыФормы.ПолеВвода1.Доступность = Ложь;
КонецПроцедуры

LordWizard

Да, и привяжи ее на форме к флажку функции "Нажатие" - ПКМ - Свойства и в ищи в самом низу, где привязываются процедуры и функции к элементам формы. Иначе работать не будет - хоть жми, хоть не жми.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

pavl_vs

Кроме того тело процедуры #4 необходимо вложить в условие, например:

Процедура Флажок1ПриИзменении(Элемент)
    Если Флажок1 = Истина Тогда
        ЭлементыФормы.ПолеВвода1.Значение = Справочники.Склады.НайтиПоНаименованию("Склад1");
        ЭлементыФормы.ПолеВвода1.Доступность = Ложь;
    Иначе
        ЭлементыФормы.ПолеВвода1.Доступность = Истина;
    КонецЕсли;
КонецПроцедуры


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск