Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 13:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: сумма документа  (Прочитано 8093 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Как создать общую Сумму документа


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: сумма документа
« Ответ #1: 05 Дек 2013, 16:00 »
СуммаПараметра = Итог("Колонка");

Где Колонка  - название нужного параметра, по которому собирается сумма в объеме колонки по вертикали
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Re: сумма документа
« Ответ #2: 05 Дек 2013, 16:08 »
&НаКлиенте
Процедура НоменклатураПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
Объект.ОбщаяСумма = Объект.Сумма.Итог("Сумма");
КонецПроцедуры

&НаКлиенте
Процедура НоменклатураПослеУдаления(Элемент)
Объект.ОбщаяСумма= Объект.Сумма.Итог("Сумма");
КонецПроцедуры

Сделал так но почему то не заполняется поле общая сумма

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: сумма документа
« Ответ #3: 05 Дек 2013, 16:13 »
&НаКлиенте
Процедура НоменклатураПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
Объект.ОбщаяСумма = Объект.Сумма.Итог("Сумма");
КонецПроцедуры

&НаКлиенте
Процедура НоменклатураПослеУдаления(Элемент)
Объект.ОбщаяСумма= Объект.Сумма.Итог("Сумма");
КонецПроцедуры

Сделал так но почему то не заполняется поле общая сумма
Не заполняется вообще или не меняется - разные вещи. Ты делаешь это непосредственно в документе (т.е. открываешь его и редактируешь табличную часть документа) или с помощью обработки? И после всех манипуляций где запись объекта?
Объект.ОбщаяСумма....
Объект.Записать(ПараметрыЗаписи);
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Re: сумма документа
« Ответ #4: 05 Дек 2013, 16:16 »
делаю именно в документе(заполняю таблчасть)но вот Объект.ОбщаяСумма не заполняется при этом

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: сумма документа
« Ответ #5: 05 Дек 2013, 16:28 »
Форма.ОбщаяСумма = Объект.Товары.Итог("Сумма");
попробуй что-то типа этого или как там у тебя табличная часть называется (Товары, Услуги).
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Re: сумма документа
« Ответ #6: 05 Дек 2013, 16:31 »
Переменная Форма не определена

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: сумма документа
« Ответ #7: 05 Дек 2013, 16:37 »
Переменная Форма не определена
Объект = Форма.Объект;
а если поставить перед?
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Re: сумма документа
« Ответ #8: 05 Дек 2013, 16:40 »
Переменная Форма не определена
Объект = Форма.Объект;
а если поставить перед?

И что это??? ничего не меняется переменная не определена.

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: сумма документа
« Ответ #9: 05 Дек 2013, 16:47 »
это обращение к форме документа - по крайней мере в 3.0 БП работает. что у тебя за конфа?
Добавлено: 05 Дек 2013, 16:50

Процедура ОбновитьИтоги(Форма)

Объект = Форма.Объект;

Форма.ИтогиВсего    = Объект.Товары.Итог("Всего");
Форма.ИтогиВсегоНДС = Объект.Товары.Итог("СуммаНДС");

Если НЕ Форма.ЭтоОтгрузка Тогда
Форма.ИтогиВсего = Форма.ИтогиВсего
+ Объект.Услуги.Итог("Всего")
+ Объект.АгентскиеУслуги.Итог("Всего");
Форма.ИтогиВсегоНДС = Форма.ИтогиВсегоНДС
+ Объект.Услуги.Итог("СуммаНДС")
+ Объект.АгентскиеУслуги.Итог("СуммаНДС");
КонецЕсли;

Форма.ЕстьСтрокиВозвратнойТары   = Объект.ВозвратнаяТара.Количество() > 0;
Форма.ОтметкаНезаполненногоСклад = Форма.ЕстьСтрокиВозвратнойТары ИЛИ Объект.Товары.Количество() > 0;

КонецПроцедуры

Это пример из БП 3.0
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4475
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15938
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4200
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 631
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7746
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
46 Сообщений
AIFrame
46 Сообщений
andron81_81
41 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal