Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 05:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: переделать код документа с версии 7.7 на 8.2  (Прочитано 1170 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fire

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-04
  • Сайт: 
  • Профессия: Ученик 1С
Доброе утро. Есть нетиповая база по защите топливных талонов на версии 7.7. В базе есть документ Поступление, который формирует топливные талоны и присваивает им штрих-код.
 Нужно  сделать аналогичный документ в  базе на версии 8.8.  В модуле документа Поступление  в процедуре формирования талонов вылазиют ошибки. Если кто-то разбирается в 8.8 можете помочь? Зарание спасибо.

Процедура СоздатьТалоны() 
Талон = СоздатьОбъект("Справочник.Талоны");
Тал = СоздатьОбъект("Справочник.Талоны");

таб.Очистить();
таб.Новаяколонка("Тал","Справочник.Талоны");
таб.НоваяКолонка("ШК","Строка",13);
Если созд = 1  Тогда
    СтатусВозврата(0);
Возврат;
КонецЕсли;
записать();
Провести();
если проведен() = 0 тогда
возврат;
КонецЕсли;
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 цикл
н = 1;
Пока н<=количество цикл

Талон.Новый();
    Талон.Владелец1 = Получатель;
Талон.Литраж   =  Литраж;
Талон.Процент  =  Процент;
Талон.Использован = 0;
Талон.НовыйТ      = 1;
Талон.Док      = текущийДокумент();
Талон.Записать();

КодТовара = ДополнитьСтрокуЛ(Число(СокрЛ(Прав(Талон.Код, 6))), "0", 7);

Для Сч = 1 По 999 Цикл

ДопКод = ДополнитьСтрокуЛ(Строка(Сч), "0", 3);
ВремШтрихкод = СформироватьШтрихкод("20", КодТовара + ДопКод);

Если Тал.НайтиПоРеквизиту("ШтрихКод", ВремШтрихкод, 1) = 0 Тогда
СформировалиУникальныйШтрихкод = 1;
Прервать;
КонецЕсли;

КонецЦикла;

Если СформировалиУникальныйШтрихкод = 0 Тогда

// Сформируем штрих-код независимо от кода номенклатуры

Для Сч = 1 По 9999999999 Цикл // 10 разрядов

ДопКод = ДополнитьСтрокуЛ(Строка(Сч), "0", 10);
ВремШтрихкод = СформироватьШтрихкод("20", ДопКод);

Если Тал.НайтиПоРеквизиту("Штрихкод", ВремШтрихкод, 1) = 0 Тогда
СформировалиУникальныйШтрихкод = 1;
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;

Талон.ШтрихКод = ВремШтрихкод;

Талон.Записать();

таб.НоваяСтрока();
таб.тал = Талон.ТекущийЭлемент();


н = н+1;
конецЦикла;

КонецЦикла;
созд  = 1;

КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 04 Дек 2013, 10:20


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Ну так в 8-ке сначала ввести справочники соответствующие,потом допиливать.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15921
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 624
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal