Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 08:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите реализовать!!!  (Прочитано 2417 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день помогите пожайлуста!!! На внешним отчете есть поле выбора, где тип Документ." Название документа" при выборе любого документа, чтобы  появлялись значение в поле со списком вложенных значений в этом документе...


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
что-то я запутался.. не совсем понятно что именно нужно. переформулируйте вопрос.

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
На внешним отчете есть поле в свойствах поля стоит тип Документ."Ссылка на документ где выбираются данные в этом документе"... Есть поле со списком на форме, нужно при выборе документа, чтобы значение сохраненные в этом документе передавались в поле со списком... Например документ 1 в этом документе вложена номенклатура по пакетам и мне нужно выбрать определенный пакет!!!

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
т.е. вы выбираете документ, а в списке должны показываться реквизиты данного документа?
Добавлено: 03 Дек 2013, 12:06

все реквизиты нужно отображать или какие-то конкретные?

Последний раз редактировалось: Herby; 03 Дек 2013, 12:06. Причина: Объединение сообщений

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
т.е. вы выбираете документ, а в списке должны показываться реквизиты данного документа?
Добавлено: 03 Дек 2013, 12:06

все реквизиты нужно отображать или какие-то конкретные?

нет только реквизиты табличной части документа...

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
нет только реквизиты табличной части документа..

и цены и суммы и товары? тогда здесь не список нужен, а таблица значений.
и колонки этой таблицы значений придется формировать динамически, в зависимости от реквизитов табличной части

если делать универсально, то через метаданные, например:


сзСписокРеквизитовТЧ = СоздатьОбъект("СписокЗначений");

// формирование колонок в таблице значений
Для сч = 1 По Метаданные.Документ(Вид).РеквизитТабличнойЧасти() Цикл
 идРекв = Метаданные.Документ(Вид).РеквизитТабличнойЧасти(сч).Идентификатор;
 сзСписокРеквизитовТЧ.ДобавитьЗначение(идРекв);
 ТабЗн.НоваяКолонка(идРекв);
КонецЦикла;

// заполнение таблицы значений реквизитами табличной части выбранного документа
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку() = 1 Цикл
  ТабЗн.НоваяСтрока();
  ТекСтрока = ТабЗн.КоличествоСтрок();
  Для сч = 1 по сзСписокРеквизитовТЧ.РазмерСписка() Цикл
    идРекв = сзСписокРеквизитовТЧ.ПолучитьЗначение(сч);
    ТабЗн.УстановитьЗначение(ТекСтрока,идРекв, Док.ПолучитьАтрибут(идРекв));
  КонецЦикла;
КонецЦикла;

// где Док - документ, выбранный в вашем поле
// Вид - Вид документа вашего выбранного документа
// ТабЗн - ваша таблица значений на форме, в которой будут отображаться вложенные реквизиты
// выбранного документа

может быть не совсем рационально, но суть должна быть понятна.

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
А если значения реквизитов а не сами реквизиты, то просто:
тз = СоздатьОбъект("ТаблицаЗначений");
док.ВыгрузитьТабличнуюЧасть(тз,);


привет, Форум.  Давно здесь не был ...
у-у-у-ух как давно )))


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 521
  • Точка Скрытых: 1
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal