Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проверка уникальности артикула  (Прочитано 5195 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fiasko

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-11
  • Сайт: 
Как сделать, чтобы можно было проверять не совпадает ли открытая форма с уже записанным элементом и позволяла записывать если так??
Процедура ПриЗаписи()
Спр = СоздатьОбъект("Справочник.Номенклатура");
   Если Спр.НайтиПоРеквизиту("Артикул", Артикул, 1) = 1 Тогда
              Сообщить(Артикул+"уже существует");
              СтатусВозврата(0);
              Возврат;
   КонецЕсли; 
КонецПроцедуры


Оффлайн DDD

  • ****
  • Сообщений: 374
  • РЕПУТАЦИЯ: 23
  • КПД: 6%
  • Регистрация: 2008-07-12
  • Сайт: 
Процедура ПередЗаписью


Запрос = Новый Запрос;
        ТекстЗапроса = "ВЫБРАТЬ
                       |    Номенклатура.Артикул
                       |ИЗ
                       |    Справочник.Номенклатура КАК Номенклатура
                       |ГДЕ
                       |    Номенклатура.Артикул <> &Артикул";
        Запрос.Текст = ТекстЗапроса;
        Запрос.УстановитьПараметр("Артикул", Артикул);
        РезультатЗапроса = Запрос.Выполнить();
        Если Не РезультатЗапроса.Пустой() Тогда
                        Предупреждение("Номенклатура  с таким Артикул существует.");    
        КонецЕсли;

Оффлайн Fiasko

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-11
  • Сайт: 
Это в 1С ++ реализуется же??

Оффлайн Tatitutu

нет , это была реклама 1С 8.* версии

*  MAGAZKA - лучшая программа для розничного магазина (с) *


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 246
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal