Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 11:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура "Подсчет площади"  (Прочитано 3045 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Seregin63

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Вопрос чайника. :nhsrm:

В документе есть реквизиты "Длина", "Ширина", "Площадь". (Они не в табличной части)
Нужно написать процедуру автоподсчета площади.
Умом то понимаю, что надо длину умножить на ширину, а как написать не знаю :)
Подскажите алгоритм выполнения подобной процедуры.

ПроцедураДлинаПриИзменении
Стр(?) = Элементы(?).ТекущиеДанные;
Стр.Площадь=Стр.Длина*Стр.Ширина;
КронецПроцедуры

При таком написании пишет, что поле объекта Длина не обнаружено.

Платформа 1С 8.3 (Учебная версия)





Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Если речь идет об управляемой форме, то так:

Объект.Площадь = Объект.Длина * Объект.Ширина;

Если форма обычная то

Площадь = Длина * Ширина;

Оффлайн Seregin63

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Форма управляемая
написал так:
Процедура ДлинаПриИзменении(Элемент)
    Объект=Объект.ТекущиеДанные;
    Объект.Площадь=Объект.Длина*Объект.Ширина;
 КонецПроцедуры

Выдал ошибку:
{Документ.ОказаниеУслугиСтекло.Форма.ФормаДокумента.Форма(34)}: Поле объекта не обнаружено (ТекущиеДанные)
    Объект=Объект.ТекущиеДанные;


Оффлайн wise

  • *****
  • Сообщений: 508
  • РЕПУТАЦИЯ: 65
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
УБЕРИ ВООБЩЕ эту строчку...

объект - это ОСНОВНОЙ реквизит формы.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Seregin63

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо огромное!Помогло
Добавлено: 28 Ноя 2013, 13:59

Теперь делаю процедуру подсчета суммы. Нужно рассчитать общую длинну сторон стекла.
как вытащить значение из объекта Ширина? В таком виде значение всегда равно единице:

Процедура СторонаВПриИзменении(Элемент)
      Если Объект.СторонаВ=Истина
      Тогда
      Объект.СторонаВ=Объект.Ширина (???????)
   Иначе Объект.СторонаВ=0;
      КонецЕсли;
      Объект.ДлинаОбщая=Объект.СторонаА+Объект.СторонаА1+Объект.СторонаВ+Объект.СторонаВ1;

      КонецПроцедуры

Последний раз редактировалось: Seregin63; 28 Ноя 2013, 13:59. Причина: Объединение сообщений


 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 684
Последний ответ 20 Мар 2018, 16:54
от alex0402
1c 8.2: как называется процедура/функция, которая вызывается при вводе значения в поле на форме?

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1884
Последний ответ 08 Сен 2014, 08:28
от cska-fanat-kz
Какие ответственные лица могут быть указаны в регистре сведений "Ответственные л

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4559
Последний ответ 25 Ноя 2008, 11:07
от DDD
Процедура госрегистрации ИП и юрлиц будет проходить в течение трех дней

Автор newsРаздел Новости

Ответов: 0
Просмотров: 856
Последний ответ 03 Апр 2014, 15:16
от news
Процедура Инициализации при создании внешней обработки таб. частей

Автор crow1983Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 12660
Последний ответ 23 Авг 2010, 16:51
от crow1983

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
151 Сообщений
oleg-x
69 Сообщений
alex0402
65 Сообщений
AIFrame AIFrame
54 Сообщений
wise wise
37 Сообщений
buketov.av buketov.av
36 Сообщений
KOI8-R
34 Сообщений
Alter
26 Сообщений
BuhRust
22 Сообщений
trialex3
21 Сообщений

* Кто онлайн

  • Точка Гостей: 883
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal