Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура "Подсчет площади"  (Прочитано 2619 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Seregin63

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Вопрос чайника. :nhsrm:

В документе есть реквизиты "Длина", "Ширина", "Площадь". (Они не в табличной части)
Нужно написать процедуру автоподсчета площади.
Умом то понимаю, что надо длину умножить на ширину, а как написать не знаю :)
Подскажите алгоритм выполнения подобной процедуры.

ПроцедураДлинаПриИзменении
Стр(?) = Элементы(?).ТекущиеДанные;
Стр.Площадь=Стр.Длина*Стр.Ширина;
КронецПроцедуры

При таком написании пишет, что поле объекта Длина не обнаружено.

Платформа 1С 8.3 (Учебная версия)





Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Если речь идет об управляемой форме, то так:

Объект.Площадь = Объект.Длина * Объект.Ширина;

Если форма обычная то

Площадь = Длина * Ширина;

Оффлайн Seregin63

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Форма управляемая
написал так:
Процедура ДлинаПриИзменении(Элемент)
    Объект=Объект.ТекущиеДанные;
    Объект.Площадь=Объект.Длина*Объект.Ширина;
 КонецПроцедуры

Выдал ошибку:
{Документ.ОказаниеУслугиСтекло.Форма.ФормаДокумента.Форма(34)}: Поле объекта не обнаружено (ТекущиеДанные)
    Объект=Объект.ТекущиеДанные;


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
УБЕРИ ВООБЩЕ эту строчку...

объект - это ОСНОВНОЙ реквизит формы.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Seregin63

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо огромное!Помогло
Добавлено: 28 Ноя 2013, 13:59

Теперь делаю процедуру подсчета суммы. Нужно рассчитать общую длинну сторон стекла.
как вытащить значение из объекта Ширина? В таком виде значение всегда равно единице:

Процедура СторонаВПриИзменении(Элемент)
      Если Объект.СторонаВ=Истина
      Тогда
      Объект.СторонаВ=Объект.Ширина (???????)
   Иначе Объект.СторонаВ=0;
      КонецЕсли;
      Объект.ДлинаОбщая=Объект.СторонаА+Объект.СторонаА1+Объект.СторонаВ+Объект.СторонаВ1;

      КонецПроцедуры

Последний раз редактировалось: Seregin63; 28 Ноя 2013, 13:59. Причина: Объединение сообщений


 

1c 8.2: как называется процедура/функция, которая вызывается при вводе значения в поле на форме?

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1570
Последний ответ 08 Сен 2014, 08:28
от cska-fanat-kz
Процедура госрегистрации ИП и юрлиц будет проходить в течение трех дней

Автор newsРаздел Новости

Ответов: 0
Просмотров: 750
Последний ответ 03 Апр 2014, 15:16
от news
Какие ответственные лица могут быть указаны в регистре сведений "Ответственные л

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4312
Последний ответ 25 Ноя 2008, 11:07
от DDD
Процедура Инициализации при создании внешней обработки таб. частей

Автор crow1983Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 11700
Последний ответ 23 Авг 2010, 16:51
от crow1983
Получение данных о номенклатуре, в Процедура ПриЗаписи(Отказ)

Автор ВоительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 3536
Последний ответ 21 Ноя 2011, 21:12
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 125
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal