Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ВызватьИсключение  (Прочитано 3711 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Есть след. функция:
Функция ОтправитьПочтСообщение(знач УчетнаяЗапись,
                                   знач ПараметрыПисьма) Экспорт
 
  Если ПараметрыПисьма = Неопределено Тогда
  ВызватьИсключение НСтр("ru = 'Не заданы параметры отправки.'");
 КонецЕсли;
 
 Кому = "";
 Если ПараметрыПисьма.Свойство("Кому", Кому) Тогда
  Если ТипЗнч(Кому) = Тип("Строка") Тогда
   ПараметрыПисьма.Кому = ОбщегоНазначенияКлиентСервер.РазобратьСтрокуСПочтовымиАдресами(Кому);
  КонецЕсли;
 Иначе
  ВызватьИсключение НСтр("ru = 'Не указан ни один получатель письма.'");
 КонецЕсли;
 
......
 Возврат ОтправитьСообщение(УчетнаяЗапись, ПараметрыПисьма);
 
КонецФункции

На какую конструкцию правильнее будет заменить "ВызватьИсключение", чтобы пользователю выдавалось только сообщение, без кнопок "подробно" и ничего не писалось бы в журнал регистрации? Заранее спасибо.


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
возвратом педавай СВОИ параметры и обрабатывай их в вызывающей процедуре
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 

ВызватьИсключение

Автор НовенькаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4957
Последний ответ 26 Фев 2013, 00:08
от Yura063
ВызватьИсключение

Автор 1cwikiРаздел Синтаксис

Ответов: 0
Просмотров: 476
Последний ответ 18 Июл 2015, 15:10
от 1cwiki

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 164
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal