Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 00:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отчет по группировкам  (Прочитано 3023 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток. Ситуация вот в чем создал отчет. При формировании отчета   появляются 2 пустые строки.  подскажите как их убрать?


Процедура КнопкаСформироватьНажатие(Кнопка)
Макет = ОтчетОбъект.ПолучитьМакет("Макет");
ТабДок = Новый ТабличныйДокумент;
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ТабДок.Вывести(ОбластьЗаголовок);
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ТабДок.Вывести(ОбластьШапка);
ОбластьДетали = Макет.ПолучитьОбласть("Детали");
ТабДок.Вывести(ОбластьДетали);
ОбластьГруппа = Макет.ПолучитьОбласть("Группа");
ТабДок.Вывести(ОбластьГруппа);
ТабДок.НачатьАвтогруппировкуСтрок();

Запрос = Новый запрос;
Запрос.Текст= "ВЫБРАТЬ
              | ВнутренниеЗаказыОбороты.Номенклатура КАК Номенклатура,
              | ВнутренниеЗаказыОбороты.КоличествоПриход КАК Количество,
              | ВнутренниеЗаказыОбороты.ВнутреннийЗаказ.Дата КАК Дата,
              | ВнутренниеЗаказыОбороты.Заказчик КАК Заказчик
              |ИЗ
              | РегистрНакопления.ВнутренниеЗаказы.Обороты(, , , ) КАК ВнутренниеЗаказыОбороты
              |ГДЕ
              | ВнутренниеЗаказыОбороты.ВнутреннийЗаказ.Дата МЕЖДУ &ДатаН И &ДатаК
              | И ВЫБОР
              | КОГДА &Заказчик <> ЗНАЧЕНИЕ(Справочник.Подразделения.ПустаяСсылка)
              | ТОГДА ВнутренниеЗаказыОбороты.Заказчик = &Заказчик
              | ИНАЧЕ ИСТИНА
              | КОНЕЦ
              |
              |УПОРЯДОЧИТЬ ПО
              | Заказчик,
              | Дата
              |ИТОГИ
              | СУММА(Количество)
              |ПО
              | Заказчик";
 
Запрос.УстановитьПараметр("Заказчик",Подразделение);
Запрос.УстановитьПараметр("ДатаН",НачалоДня(ДатаН));
Запрос.УстановитьПараметр("ДатаК",КонецДня(ДатаК));

РезультатЗапроса = Запрос.Выполнить();

ВыборкаГруппа = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаГруппа.Следующий() Цикл
ОбластьГруппа.Параметры.Заполнить(ВыборкаГруппа);
ТабДок.Вывести(ОбластьГруппа,ВыборкаГруппа.Уровень());

ВыборкаДетальныеЗаписи = ВыборкаГруппа.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетали.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ТабДок.Вывести(ОбластьДетали,ВыборкаДетальныеЗаписи.Уровень());
КонецЦикла;
КонецЦикла;


ТабДок.ОтображатьСетку = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Показать();

КонецПроцедуры


Оффлайн andryscha92

  • ****
  • Сообщений: 267
  • РЕПУТАЦИЯ: 4
  • КПД: 1%
  • Регистрация: 2012-01-31
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток. Ситуация вот в чем создал отчет. При формировании отчета   появляются 2 пустые строки.  подскажите как их убрать?


Процедура КнопкаСформироватьНажатие(Кнопка)
Макет = ОтчетОбъект.ПолучитьМакет("Макет");
ТабДок = Новый ТабличныйДокумент;
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ТабДок.Вывести(ОбластьЗаголовок);
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ТабДок.Вывести(ОбластьШапка);
ОбластьДетали = Макет.ПолучитьОбласть("Детали");
ТабДок.Вывести(ОбластьДетали);
ОбластьГруппа = Макет.ПолучитьОбласть("Группа");
ТабДок.Вывести(ОбластьГруппа);
ТабДок.НачатьАвтогруппировкуСтрок();

Запрос = Новый запрос;
Запрос.Текст= "ВЫБРАТЬ
              | ВнутренниеЗаказыОбороты.Номенклатура КАК Номенклатура,
              | ВнутренниеЗаказыОбороты.КоличествоПриход КАК Количество,
              | ВнутренниеЗаказыОбороты.ВнутреннийЗаказ.Дата КАК Дата,
              | ВнутренниеЗаказыОбороты.Заказчик КАК Заказчик
              |ИЗ
              | РегистрНакопления.ВнутренниеЗаказы.Обороты(, , , ) КАК ВнутренниеЗаказыОбороты
              |ГДЕ
              | ВнутренниеЗаказыОбороты.ВнутреннийЗаказ.Дата МЕЖДУ &ДатаН И &ДатаК
              | И ВЫБОР
              | КОГДА &Заказчик <> ЗНАЧЕНИЕ(Справочник.Подразделения.ПустаяСсылка)
              | ТОГДА ВнутренниеЗаказыОбороты.Заказчик = &Заказчик
              | ИНАЧЕ ИСТИНА
              | КОНЕЦ
              |
              |УПОРЯДОЧИТЬ ПО
              | Заказчик,
              | Дата
              |ИТОГИ
              | СУММА(Количество)
              |ПО
              | Заказчик";
 
Запрос.УстановитьПараметр("Заказчик",Подразделение);
Запрос.УстановитьПараметр("ДатаН",НачалоДня(ДатаН));
Запрос.УстановитьПараметр("ДатаК",КонецДня(ДатаК));

РезультатЗапроса = Запрос.Выполнить();

ВыборкаГруппа = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаГруппа.Следующий() Цикл
ОбластьГруппа.Параметры.Заполнить(ВыборкаГруппа);
ТабДок.Вывести(ОбластьГруппа,ВыборкаГруппа.Уровень());

ВыборкаДетальныеЗаписи = ВыборкаГруппа.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетали.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ТабДок.Вывести(ОбластьДетали,ВыборкаДетальныеЗаписи.Уровень());
КонецЦикла;
КонецЦикла;


ТабДок.ОтображатьСетку = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Показать();

КонецПроцедуры

в макете, когда задаешь имя для области(вероятно шапка или заголовок) удали пустые строки, либо когда задаешь имя для области не включай эти пустые строки в область.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
пустых строк нету, вот сам макет
Добавлено: 21 Ноя 2013, 10:30

разобрался, тема закрыта

Последний раз редактировалось: ls600; 21 Ноя 2013, 10:30. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal