Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 08:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отобразить данные регистра сведений в форме  (Прочитано 3182 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maxx79

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2013-10-29
  • Компания: Nissan-Part
  • Профессия: Программист 1С
Добрый день!

Есть справочник "Валюты" и его форма элемента с добавленным реквизитом "СписокКурсаВалюты" с типом РегистрСведенийНаборЗаписей.КурсыВалют (при создании реквизита колонки Период, Валюта, Курс проставились автоматически).

Задача: при открытии формы элемента (допустим с Долларом США) заполнить таблицу СписокКурсаВалюты курсами валюты из регистра сведений.



В модуле формы:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
Валюта = Объект.Наименование;
ЗаполнитьСписокКурсаВалюты(Валюта);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗаполнитьСписокКурсаВалюты(Валюта)
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
    |КурсыВалют.Период,
    |КурсыВалют.Валюта,
    |КурсыВалют.Курс
   |ИЗ
|РегистрСведений.КурсыВалют КАК КурсыВалют
   |ГДЕ
|КурсыВалют.Валюта = &Валюта";

Запрос.УстановитьПараметр("Валюта", Валюта);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Пока Выборка.Следующий() Цикл
//Сообщить(Выборка.Курс);
КонецЦикла;
КонецПроцедуры

Почему не выбираются записи из регистра сведений?



Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Ну как минимум, вот это надо исправить:
Валюта = Объект.Наименование;
наименование - это строка, а в регистра хранится ссылка!
Попробуйте
Валюта = Объект.Ссылка;

Оффлайн Maxx79

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2013-10-29
  • Компания: Nissan-Part
  • Профессия: Программист 1С
Теперь ГУД!
В предыдущей своей теме точно на этом же был затык. Теперь кажется начинаю чего-то понимать :lol:


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1843
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 333
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2348
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4942
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 383
Последний ответ 25 Сен 2017, 09:00
от Св Ч

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 549
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal