Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отобразить данные на форме  (Прочитано 2814 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maxx79

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2013-10-29
  • Компания: Nissan-Part
  • Профессия: Программист 1С
Добрый день!

Не судите начинающего строго.

Есть справочник "Валюты" и его форма списка с добавленным реквизитом "ТекущийКурс" ввиде надписи.
Есть регистр сведений "КурсыВалют": измерение "Валюта", ресурс "Курс".

Задача: при выделении строки (допустим с Долларом США) в форме списка справочника (т.е. когда щелкнули мышкой 1 раз и она стала синей), надо заполнить "ТекущийКурс" последней записью регистра сведений по выделенной валюте.

В модуле формы:
&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
ОбновитьКурс(Элементы.Список.ТекущиеДанные.Наименование, ТекущийКурс);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ОбновитьКурс(Валюта, ТекущийКурс)
ТекущийКурс = ОбщиеМеханизмы.ПолучитьТекущийКурс(Валюта);
КонецПроцедуры

В Общем модуле:
Функция ПолучитьТекущийКурс(Валюта, Знач Дата = Неопределено) Экспорт
Дата = ?(Дата = Неопределено, ТекущаяДата(), Дата);

Отбор = Новый Структура;
Отбор.Вставить("Валюта", Валюта);

ТекущийКурс = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(Дата, Отбор);

Возврат ТекущийКурс.Курс;

КонецФункции

Ошибок не выдает, но и курс не отображает.  Возврат ТекущийКурс.Курс;  возвращает 0, хотя запись (в т.ч. и на сегодня 18.11.2013) в регистре есть.
Что я делаю не так?


Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Элементы.Список.ТекущиеДанные.Наименование - тип какой имеет? скорее всего ты передаешь просто наименование валюты.
В функции: Функция ПолучитьТекущийКурс(Валюта, Знач Дата = Неопределено) Экспорт
   Дата = ?(Дата = Неопределено, ТекущаяДата(), Дата);
   
   Отбор = Новый Структура;
   Отбор.Вставить("Валюта", Валюта);
   
   ТекущийКурс = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(Дата, Отбор);
   
   Возврат ТекущийКурс.Курс;
   
КонецФункции
Валюта должна иметь тип СправочникСсылка.Валюты...
Добавлено: 18 Ноя 2013, 17:27

&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
   ОбновитьКурс(Элементы.Список.ТекущиеДанные.Валюта);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ОбновитьКурс(Валюта)   
   Объект.ТекущийКурс = ОбщиеМеханизмы.ПолучитьТекущийКурс(Валюта);
КонецПроцедуры
на первый взгляд как-то так.........

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Элементы.Список.ТекущиеДанные.Наименование возвращает строку, а Элементы.Список.ТекущаяСтрока ссылку

Оффлайн Maxx79

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2013-10-29
  • Компания: Nissan-Part
  • Профессия: Программист 1С
Цитировать
Элементы.Список.ТекущиеДанные.Наименование возвращает строку, а Элементы.Список.ТекущаяСтрока ссылку

Заработало!
Только объясните для понимания, КАК программа понимает, что я выделил именно доллар а не евро. Как в итоге я получаю нужное мне значение измерения для отбора из регистра сведений.

Ведь в моем случае Элементы.Список.ТекущиеДанные.Наименование  я получал не ссылку а именно значение. Понимаю, что все элементарно, но не могу понять логику!


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Только объясните для понимания, КАК программа понимает, что я выделил именно доллар а не евро
название процедуры СписокПриАктивизацииСтроки, соответственно какую строку активировали, данный той строки и можно обрабатывать


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1755
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 267
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2273
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 290
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2754
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 844
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal