Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 20:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: управляемая форма 1с (ПОМОЩЬ)  (Прочитано 2083 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
В конфигурации есть две процедуры, это расчет пробега и начальные данные

 &НаСервере
 Процедура РасчетаПробега()
   
     Объект.КонечныйСпидометр =  Объект.НачальныйСпидометр + Объект.ПробегЗаПутевку;
    Объект.Расход = Объект.ПробегЗаПутевку * Объект.РасходНа100Км / 100;
    Объект.ОстатокТопливаПриВозвращении = Объект.ОстатокТопливаПриВыезде - Объект.Расход;
   
   
 КонецПроцедуры

 &НаСервере
 Процедура НачальныеДанныеНаСервере(ТранспортноеСредство,Дата)
....
....
....
    Если Выборка.Количество()>0 Тогда
       Выборка.Следующий();
       Объект.Водитель = Выборка.Водитель;
       Объект.НачальныйСпидометр =Выборка.КонечныйСпидометрОстаток;
       Объект.ОстатокТопливаПриВыезде  = Выборка.ОстатокГСМ;
       Объект.РасходНа100Км = Выборка.НормаРасхода;
       НомерАвтомобиля = Выборка.НомерАвтомобиля;
       НомерПрицепа = Выборка.НомерПрицепа;
       Объект.Механик = Выборка.Механик;
       Объект.МедРаботник = Выборка.МедРаботник;
Объект.Заправлено = Выборка.Заправлено;

Объект.ОстатокТопливаПриВыезде = Объект.Заправлено;
      

       КонецЕсли;   
 КонецПроцедуры


К этой строчке нужно сделать проверку (если новый документ тогда выполнять присвоение иначе не выполнять)(строчка ниже)
Объект.ОстатокТопливаПриВыезде = Объект.Заправлено;


Не могу понять как это осуществить 1с 8.2


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
создаете в модуе объекта эскпортную функцию, из которой возвращаете ЭтоНовый()
Добавлено: 14 Ноя 2013, 23:39

забыл добавить: вызов экспортной функции из модуля формы делайте так
ДокОбъект = РеквизитФормыВЗначение("Объект");
ДокОбъект.Проверить();// вернет истину или ложь. ставьте этот флаг в нужное место
ЗначениеВРеквизитФормы(ДокОбъект, "Объект")

Последний раз редактировалось: Besart; 14 Ноя 2013, 23:39. Причина: Объединение сообщений

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
создаете в модуе объекта эскпортную функцию, из которой возвращаете ЭтоНовый()
Добавлено: 14 Ноя 2013, 23:39

забыл добавить: вызов экспортной функции из модуля формы делайте так
ДокОбъект = РеквизитФормыВЗначение("Объект");
ДокОбъект.Проверить();// вернет истину или ложь. ставьте этот флаг в нужное место
ЗначениеВРеквизитФормы(ДокОбъект, "Объект")

Спасибо, на проверку вывел через пустой ключ, чу чуть что то не получилось, сегодня-завтра плотно займусь фомой,

Спасибо за ответ

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Должно и так сработать:
Если Объект.Ссылка.Пустая() Тогда
Объект.ОстатокТопливаПриВыезде = Объект.Заправлено;

КонецЕсли;


Теги:
 

Нужна помощь про "Отчет о смене без гашение" и "Z отчет"

Автор Serg85Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3756
Последний ответ 23 Ноя 2014, 12:36
от дфтын
Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7044
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Внешняя обработка (внешняя печатная форма УТ ЗаказПокупателя)

Автор RusadmРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4302
Последний ответ 27 Май 2011, 15:23
от cska-fanat-kz
Печатная форма "Акт сверки взаиморасчетов"

Автор NikolosРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4248
Последний ответ 11 Сен 2012, 08:18
от Nikolos
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4646
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 315
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal