Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расчет на 1С  (Прочитано 1358 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GoldMen

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-10
  • Сайт: 
  • Профессия: Программист 8.1
На 1С делал процедуры для расчета в общем модуле

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт

Если (СтрокаТабличнойЧасти.Толщина > 1/2) И (СтрокаТабличнойЧасти.Толщина <= 2) Тогда
        СтрокаТабличнойЧасти.Допуск = 10;
    ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 2) И (СтрокаТабличнойЧасти.Толщина <= 5) Тогда
        СтрокаТабличнойЧасти.Допуск = 16;
    ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 5) И (СтрокаТабличнойЧасти.Толщина <= 10) Тогда
        СтрокаТабличнойЧасти.Допуск = 20;
    Иначе
        Сообщить("Не корректные данные");
        Возврат;
    КонецЕсли;
    СтрокаТабличнойЧасти.Размер = ((СтрокаТабличнойЧасти.Длина + СтрокаТабличнойЧасти.Допуск) *
(СтрокаТабличнойЧасти.Ширина + СтрокаТабличнойЧасти.Допуск)) / 1000000;

СтрокаТабличнойЧасти.ОбщПотребность = СтрокаТабличнойЧасти.Размер *
СтрокаТабличнойЧасти.КоличествоДетали;
             
КонецПроцедуры


Процедура РассчитатьСуммуЛ(СтрокаТабличнойЧасти) Экспорт

СтрокаТабличнойЧасти.ПотребностьЛаз =  (СтрокаТабличнойЧасти.ТочПлощадь/0.7);

СтрокаТабличнойЧасти.ОбщПотребностьЛаз =  (СтрокаТабличнойЧасти.ПотребностьЛаз *
СтрокаТабличнойЧасти.КоличествоДетали);

КонецПроцедуры


Процедура РассчитатьСумму1(СтрокаТабличнойЧасти) Экспорт

СтрокаТабличнойЧасти.Размер = (СтрокаТабличнойЧасти.Длина * СтрокаТабличнойЧасти.Ширина) / 1000000;

СтрокаТабличнойЧасти.ОбщПотребность = СтрокаТабличнойЧасти.Размер *
СтрокаТабличнойЧасти.КоличествоДетали;

КонецПроцедуры     


А в форме документе

&НаКлиенте
Процедура ДанныеПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Данные.ТекущиеДанные;
Если СтрокаТабличнойЧасти.Толщина <> 0 Тогда
РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецЕсли;
РаботаСДокументами.РассчитатьСуммуЛ(СтрокаТабличнойЧасти);
РаботаСДокументами.РассчитатьСумму1(СтрокаТабличнойЧасти);
КонецПроцедуры

Выводится один результат один из двух процедур РассчитатьСумму1, а процедура РассчитатьСумму не срабатывается. Мож что нужно добавить туда какое условие?

Последний раз редактировалось: MuI_I_Ika; 14 Ноя 2013, 14:48


Оффлайн Kironten

  • *****
  • Сообщений: 900
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчет на 1С
« Ответ #1: 14 Ноя 2013, 16:42 »
А что у вас в колонке "толщина" табличной части данные указывается?

Оффлайн GoldMen

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-10
  • Сайт: 
  • Профессия: Программист 8.1
Re: Расчет на 1С
« Ответ #2: 14 Ноя 2013, 16:48 »
А что у вас в колонке "толщина" табличной части данные указывается?
Да, толщины вводятся вручную и автоматически выводятся допуски для обычной резки. Такое условие

Оффлайн Kironten

  • *****
  • Сообщений: 900
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расчет на 1С
« Ответ #3: 14 Ноя 2013, 17:20 »
Ну, на вид вроде все нормально. Проверяйте тогда, если вообще входит в процедуру рассчитатьсумму() то тогда берите отладчик, и смотрите на каком из реквизитов строки  спотыкается.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4291
Последний ответ 24 Дек 2015, 15:34
от дфтын
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3178
Последний ответ 21 Мар 2015, 20:24
от дфтын
1с82 ЗУП: Расчет по среднему:надбавка учитывается и не учитывается

Автор PushastРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3830
Последний ответ 05 Окт 2011, 11:13
от Pushast
Отчет о НЕ уволенных сотрудниках и расчет начислений, как для уволенных

Автор medoedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3669
Последний ответ 02 Фев 2012, 14:49
от medoed
Расчет процента автоматической скидки и скидки наценки

Автор Max99990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 4475
Последний ответ 31 Янв 2016, 02:33
от дфтын

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 295
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal