Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Фев 2018, 04:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нужна помощь с запросом  (Прочитано 2277 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DmitriyF

  • *****
  • Сообщений: 738
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Здравствуйте.
Есть Функция которая получает данные для печати М4

   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("ТекущийДокумент",ЭтотОбъект.СсылкаНаОбъект);
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ПоступлениеТоваровУслуг.Номер КАК Номер,
   |   ПоступлениеТоваровУслуг.Дата КАК ДатаСоставления,
   |   ПоступлениеТоваровУслуг.НомерВходящегоДокумента КАК НомерСопроводительногоДокумента,
   |   ПоступлениеТоваровУслуг.Организация,
   |   ПоступлениеТоваровУслуг.Организация КАК ЮрФизЛицо,
   |   ПоступлениеТоваровУслуг.Склад КАК МестоПриемки,
   |   ПоступлениеТоваровУслуг.Склад.Представление КАК СкладНаименование,
   |   ПоступлениеТоваровУслуг.Контрагент.Код КАК ПоставщикКод,
   |   ПоступлениеТоваровУслуг.Контрагент КАК Поставщик,
   |   ЕСТЬNULL(ПоступлениеТоваровУслуг.ДоговорКонтрагента.РасчетыВУсловныхЕдиницах, ЛОЖЬ) КАК РасчетыВУсловныхЕдиницах,
   |   ПоступлениеТоваровУслуг.ВалютаДокумента,
   |   ПоступлениеТоваровУслуг.КурсВзаиморасчетов КАК Курс,
   |   ПоступлениеТоваровУслуг.КратностьВзаиморасчетов КАК Кратность,
   |   ПоступлениеТоваровУслуг.УчитыватьНДС,
   |   ПоступлениеТоваровУслуг.СуммаВключаетНДС,
   |   ПоступлениеТоваровУслуг.СчетУчетаРасчетовСКонтрагентом КАК СубСчет
   |ИЗ
   |   Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
   |ГДЕ
   |   ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент";
   
   Шапка = Запрос.Выполнить().Выбрать();
   Шапка.Следующий();
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   ЗапросПоТоварам = Новый Запрос();
   ЗапросПоТоварам.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);
   ЗапросПоТоварам.УстановитьПараметр("Курс",            ЗаполнениеДокументов.КурсДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));
   ЗапросПоТоварам.УстановитьПараметр("Кратность",       ЗаполнениеДокументов.КратностьДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));
   ЗапросПоТоварам.Текст = "ВЫБРАТЬ
                           |   ПоступлениеТоваровУслуг.Номенклатура КАК Номенклатура,
                           |   ПоступлениеТоваровУслуг.Номенклатура.Код КАК ТоварКод,
                           |   ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК ЕдиницаИзмеренияНаименование,
                           |   ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Код КАК ЕдиницаИзмеренияКод,
                           |   ПоступлениеТоваровУслуг.СтавкаНДС КАК СтавкаНДС,
                           |   СУММА(ПоступлениеТоваровУслуг.Количество) КАК КоличествоПринято,
                           |   СУММА(ПоступлениеТоваровУслуг.Сумма * &Курс / &Кратность) КАК Стоимость,
                           |   СУММА(ПоступлениеТоваровУслуг.СуммаНДС * &Курс / &Кратность) КАК СуммаНДС,
                           |   СУММА(ПоступлениеТоваровУслуг.НомерСтроки) КАК НомерСтроки,
                           |   ВЫРАЗИТЬ(ПоступлениеТоваровУслуг.Содержание КАК СТРОКА(1000)) КАК ТоварНаименование
                           |ИЗ
                           |   Документ.ПоступлениеТоваровУслуг.Услуги КАК ПоступлениеТоваровУслуг
                           |ГДЕ
                           |   ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент
                           |
                           |СГРУППИРОВАТЬ ПО
                           |   ПоступлениеТоваровУслуг.СтавкаНДС,
                           |   ПоступлениеТоваровУслуг.Номенклатура,
                           |   ВЫРАЗИТЬ(ПоступлениеТоваровУслуг.Содержание КАК СТРОКА(1000)),
                           |   ПоступлениеТоваровУслуг.Номенклатура.Код,
                           |   ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Наименование,
                           |   ПоступлениеТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Код
                           |
                           |УПОРЯДОЧИТЬ ПО
                           |   НомерСтроки";
   
   
   Если Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить() = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
      ЗапросПоТоварам.Текст = СтрЗаменить(ЗапросПоТоварам.Текст, "Номенклатура.Код","Номенклатура.Артикул");
   КонецЕсли;
   
   ЗапросТовары = ЗапросПоТоварам.Выполнить().Выгрузить();
   //admL   
   //ЗапросМестоХранения = ЗапросПоТоварам.Выполнить().Выгрузить();
   //ЗапросМестоХранения.Свернуть("МестоХранения");
   //end
   Если СсылкаНаОбъект.Проведен И (Шапка.РасчетыВУсловныхЕдиницах
      ИЛИ (Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета И ТекущаяДата() >= '20090101000000')) Тогда
      
      Запрос = Новый Запрос;
      Запрос.УстановитьПараметр("Ссылка", ЭтотОбъект.СсылкаНаОбъект);
      Запрос.УстановитьПараметр("СчетУчетаРасчетовСКонтрагентом", ЭтотОбъект.СсылкаНаОбъект.СчетУчетаРасчетовСКонтрагентом);
      Текст =
      "ВЫБРАТЬ
      |   СУММА(Хозрасчетный.Сумма) КАК Сумма
      |ИЗ
      |   РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
      |ГДЕ
      |   Хозрасчетный.Регистратор = &Ссылка
      |   И Хозрасчетный.СчетКт = &СчетУчетаРасчетовСКонтрагентом
      |   И Хозрасчетный.СчетДт В
      |         (ВЫБРАТЬ РАЗЛИЧНЫЕ
      |            ПоступлениеТоваровУслуг.СчетУчета
      |         ИЗ
      |            Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг
      |         ГДЕ
      |            ПоступлениеТоваровУслуг.Ссылка = &Ссылка
      |
      |           ОБЪЕДИНИТЬ
      |
      |         ВЫБРАТЬ РАЗЛИЧНЫЕ
      |            ПоступлениеТоваровУслуг.СчетУчетаНДС
      |         ИЗ
      |            Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг
      |         ГДЕ
      |            ПоступлениеТоваровУслуг.Ссылка = &Ссылка)";
      
      Запрос.Текст = Текст;
      СуммаВзаиморасчетов = Запрос.Выполнить().Выгрузить()[0].Сумма;
      
      РасчетСуммыНДСПоСтавке =  УчетНДС.РасчетНДСвРубляхПоСтавкеДокумента(Шапка.ДатаСоставления);
      
      Если НЕ СуммаВзаиморасчетов = NULL Тогда
         
         ЗапросТовары.Колонки.Добавить("СуммаБезНДС");
         
         МассивРаспределения = Новый Массив;
         
         Для Каждого СтрокаТовар Из ЗапросТовары Цикл
            
            СуммаСНДС = СтрокаТовар.Стоимость + ?(Шапка.СуммаВключаетНДС, 0, СтрокаТовар.СуммаНДС);
            СуммаБезНДС = СуммаСНДС - СтрокаТовар.СуммаНДС;
            
            МассивРаспределения.Добавить(СуммаСНДС);
            СтрокаТовар.СуммаБезНДС = СуммаБезНДС;
            
         КонецЦикла;
         
         ЗапросТовары.Колонки.Добавить("СуммаРублевая");
         УчетНДС.РаспределитьСуммуПоСтолбцу(МассивРаспределения, СуммаВзаиморасчетов, ЗапросТовары, "СуммаРублевая");
         
         Для Каждого СтрокаТовар Из ЗапросТовары Цикл
            
            Если РасчетСуммыНДСПоСтавке Тогда
               //Выделение суммы НДС, Расчет суммы без НДС
               ЗначениеСтавкиНДС = УчетНДС.ПолучитьСтавкуНДС(СтрокаТовар.СтавкаНДС);
               
               СтрокаТовар.СуммаНДС = ?(ЗначениеСтавкиНДС = 0, 0, Окр(СтрокаТовар.СуммаРублевая * ЗначениеСтавкиНДС/(100+ЗначениеСтавкиНДС),2));
               СтрокаТовар.Стоимость = СтрокаТовар.СуммаРублевая - СтрокаТовар.СуммаНДС;
               
            Иначе
               МассивРаспределения.Очистить();
               МассивРаспределения.Добавить(СтрокаТовар.СуммаБезНДС);
               МассивРаспределения.Добавить(СтрокаТовар.СуммаНДС);
               МассивРаспределенныхСумм = ОбщегоНазначения.РаспределитьПропорционально(СтрокаТовар.СуммаРублевая, МассивРаспределения);
               Если МассивРаспределенныхСумм <> Неопределено Тогда
                  СтрокаТовар.Стоимость = МассивРаспределенныхСумм[0];
                  СтрокаТовар.СуммаНДС = МассивРаспределенныхСумм[1];
               КонецЕсли;
            КонецЕсли;
            
            Если Шапка.СуммаВключаетНДС Тогда
               СтрокаТовар.Стоимость = СтрокаТовар.Стоимость+СтрокаТовар.СуммаНДС;
            КонецЕсли;
            
         КонецЦикла;
         
      КонецЕсли;
      
   КонецЕсли;
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   // Зададим параметры макета
   ТабДокумент.ПолеСверху         = 0;
   ТабДокумент.ПолеСлева          = 0;
   ТабДокумент.ПолеСнизу          = 0;
   ТабДокумент.ПолеСправа         = 0;
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   
   ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг_М4";
   
   //admL
   //Макет = ПолучитьОбщийМакет("М4");
   Макет = ПолучитьМакет("М4");
   //end   
   
   ОбластьМакетаШапка              = Макет.ПолучитьОбласть("Шапка");
   ОбластьМакетаЗаголовокДокумента = Макет.ПолучитьОбласть("ЗаголовокДокумента");
   ОбластьМакетаЗаголовокТаблицы   = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
   ОбластьМакетаСтрока             = Макет.ПолучитьОбласть("Строка");
   ОбластьМакетаПодвалСтрок        = Макет.ПолучитьОбласть("ПодвалСтрок");
   ОбластьМакетаИтого              = Макет.ПолучитьОбласть("Итого");
   ОбластьМакетаПодвал             = Макет.ПолучитьОбласть("Подвал");

   // Выводим общие реквизиты шапки
   СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.ЮрФизЛицо, Шапка.ДатаСоставления);
   
   ОбластьМакетаШапка.Параметры.Заполнить(Шапка);
   ОбластьМакетаШапка.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе);
   ОбластьМакетаШапка.Параметры.ОрганизацияПоОКПО        = СведенияОПокупателе.КодПоОКПО;
   ОбластьМакетаШапка.Параметры.НомерДокумента           = ОбщегоНазначения.ПолучитьНомерНаПечать(Шапка);
   
   ТабДокумент.Вывести(ОбластьМакетаШапка);
   
   // Выводим заголовок документа
   ОбластьМакетаЗаголовокДокумента.Параметры.Заполнить(Шапка);
   ОбластьМакетаЗаголовокДокумента.Параметры.ДатаСоставления = Шапка.ДатаСоставления;
   ПредставлениеКонтрагента = ФормированиеПечатныхФорм.ОписаниеОрганизации(
   УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Поставщик, Шапка.ДатаСоставления), "НаименованиеДляПечатныхФорм,");
   ОбластьМакетаЗаголовокДокумента.Параметры.ПоставщикНаименование = ПредставлениеКонтрагента;

   ТабДокумент.Вывести(ОбластьМакетаЗаголовокДокумента);
   
   // Выводим заголовок таблицы
   ТабДокумент.Вывести(ОбластьМакетаЗаголовокТаблицы);
   
   // Инициализация итогов в документе
   ИтогоКоличествоПринято = 0;
   ИтогоСуммаБезНДС       = 0;
   ИтогоСуммаНДС          = 0;
   ИтогоВсегоСНДС         = 0;
   Ном                    = 0;
   
   // Инициализация счетчиков страниц и строк
   НомерСтраницы   = 1;
   НомерСтроки     = 0;
   КоличествоСтрок = ЗапросТовары.Количество();

   Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл

      НомерСтроки = НомерСтроки + 1;
         
         ОбластьМакетаСтрока.Параметры.Заполнить(ВыборкаСтрок);
         
         Кратность = ?(Шапка.Кратность = 0, 1, Шапка.Кратность);
         ВсегоСНДС = (ВыборкаСтрок.Стоимость
         + ?(Шапка.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС));
         
         КоличествоПринято = ВыборкаСтрок.КоличествоПринято;
         СуммаНДС          = ВыборкаСтрок.СуммаНДС;
         Цена              = (ВсегоСНДС - СуммаНДС) / ?(КоличествоПринято = 0, 1, КоличествоПринято);
         
         ОбластьМакетаСтрока.Параметры.КоличествоПринято = КоличествоПринято;
         ОбластьМакетаСтрока.Параметры.ВсегоСНДС         = ВсегоСНДС;
         ОбластьМакетаСтрока.Параметры.СуммаБезНДС       = ВсегоСНДС - СуммаНДС;
         ОбластьМакетаСтрока.Параметры.СуммаНДС          = СуммаНДС;
         ОбластьМакетаСтрока.Параметры.Цена              = Цена;
         ОбластьМакетаСтрока.Параметры.ТоварНаименование = СокрЛП(ВыборкаСтрок.ТоварНаименование);
         // Проверим вывод
         СтрокаСПодвалом = Новый Массив;
         СтрокаСПодвалом.Добавить(ОбластьМакетаСтрока);
         Если НомерСтроки = КоличествоСтрок Тогда           // если последняя строка, должен
            СтрокаСПодвалом.Добавить(ОбластьМакетаИтого);  // помещаться и подвал документа
            СтрокаСПодвалом.Добавить(ОбластьМакетаПодвал);
         Иначе                                              // иначе - только подвал строк
            СтрокаСПодвалом.Добавить(ОбластьМакетаПодвалСтрок);
         КонецЕсли;
         
         Если НЕ ФормированиеПечатныхФорм.ПроверитьВыводТабличногоДокумента(ТабДокумент, СтрокаСПодвалом) Тогда
            
            ТабДокумент.Вывести(ОбластьМакетаПодвалСтрок);
            ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
            
            
            НомерСтраницы = НомерСтраницы + 1;
            ОбластьМакетаЗаголовокТаблицы.Параметры.НомерСтраницы = "Страница " + НомерСтраницы;
            
            ТабДокумент.Вывести(ОбластьМакетаЗаголовокТаблицы);
            
         КонецЕсли;
         
         ТабДокумент.Вывести(ОбластьМакетаСтрока);
         
         ИтогоКоличествоПринято = ИтогоКоличествоПринято + КоличествоПринято;
         ИтогоСуммаБезНДС       = ИтогоСуммаБезНДС       + ВсегоСНДС - СуммаНДС;
         ИтогоСуммаНДС          = ИтогоСуммаНДС          + СуммаНДС;
         ИтогоВсегоСНДС         = ИтогоВсегоСНДС         + ВсегоСНДС;
         
      КонецЦикла;
   //КонецЦикла;
   
   // Выводим итоги по документу
   ОбластьМакетаИтого.Параметры.ИтогоКоличествоПринято = ИтогоКоличествоПринято;
   ОбластьМакетаИтого.Параметры.ИтогоСуммаБезНДС       = ИтогоСуммаБезНДС;
   ОбластьМакетаИтого.Параметры.ИтогоСуммаНДС          = ИтогоСуммаНДС;
   ОбластьМакетаИтого.Параметры.ИтогоВсегоСНДС         = ИтогоВсегоСНДС;
   ТабДокумент.Вывести(ОбластьМакетаИтого);
   
   // Выводим итоги по документу
   ОбластьМакетаПодвал = Макет.ПолучитьОбласть("Подвал");
   ОбластьМакетаПодвал.Параметры.Заполнить(Шапка);
   ТабДокумент.Вывести(ОбластьМакетаПодвал);
   
   //ТабДокумент.Показать();
   //Возврат ТабДокумент;
   УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент,,,"Печать М4 Услуги");


Вопрос: подскажите в каком месте функция получает данные по ТЧ Товары второй час сижу не могу понять? Мне это нужно чтобы вывести на форму счета учета из ТЧ Товары и  счета затрат из ТЧ Услуги


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
   ЗапросТовары = ЗапросПоТоварам.Выполнить().Выгрузить();

Оффлайн DmitriyF

  • *****
  • Сообщений: 738
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
   ЗапросТовары = ЗапросПоТоварам.Выполнить().Выгрузить();

А каким образом? Ведь в том запросе получают данные из ТЧ Услуги.

Оффлайн sdilshod

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 11
  • КПД: 14%
  • Регистрация: 2013-09-30
  • Сайт: 
  • Профессия: Программист 1С
     "ВЫБРАТЬ
      |   СУММА(Хозрасчетный.Сумма) КАК Сумма
      |ИЗ
      |   РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
      |ГДЕ
      |   Хозрасчетный.Регистратор = &Ссылка
      |   И Хозрасчетный.СчетКт = &СчетУчетаРасчетовСКонтрагентом
      |   И Хозрасчетный.СчетДт В
      |         (ВЫБРАТЬ РАЗЛИЧНЫЕ
      |            ПоступлениеТоваровУслуг.СчетУчета
      |         ИЗ
      |            Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг
      |         ГДЕ
      |            ПоступлениеТоваровУслуг.Ссылка = &Ссылка
      |
      |           ОБЪЕДИНИТЬ
      |
      |         ВЫБРАТЬ РАЗЛИЧНЫЕ
      |            ПоступлениеТоваровУслуг.СчетУчетаНДС
      |         ИЗ
      |            Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг
      |         ГДЕ
      |            ПоступлениеТоваровУслуг.Ссылка = &Ссылка)";
     
      Запрос.Текст = Текст;
      СуммаВзаиморасчетов = Запрос.Выполнить().Выгрузить()[0].Сумма;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
189 Сообщений
AIFrame AIFrame
81 Сообщений
alexandr_ll
41 Сообщений
BuhRust
29 Сообщений
wise wise
27 Сообщений
oleg-x
26 Сообщений
MuI_I_Ika MuI_I_Ika
25 Сообщений
pavl_vs
22 Сообщений
Кейли Кейли
21 Сообщений
andron81_81
20 Сообщений

* Кто онлайн

  • Точка Гостей: 190
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal