Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как получить строку нормального содержания........  (Прочитано 1775 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте!


Есть код обработки (xml) строки :
Запись.ЗаписатьТекст ("CN=0"+Лев(СтрокаТаблицы.CN,3) , + ......
.........................................
.........................................

Запись.ЗаписатьКонецЭлемента();   
      
     КонецЦикла;


    Запись.ЗаписатьКонецЭлемента();
    Запись.Закрыть();


  КонецЦикла;


КонецПроцедуры




Получаем файл xml c строкой :CN=000 -111- 00 052, а должно бытьCN=000-111-00052 - без пробелов.
Как можно выйти из этого положения ?


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Можно например СтрЗаменить() воспользоваться.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
см. функции СокрЛ, СокрП, СокрЛП

Оффлайн Arkshamin

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-11-16
  • Сайт: 
  • Профессия: Программист 1С
Есть случаи в 1С8, когда не действует СтрЗаменить, СокрЛП и т.д. Например так нельзя превратить число СокрЛП(1000) (в 1С8 пишется "1 000") в строку "1000".
Чтобы например получить элемент справочника по коду "КодСотра" =1000 и более, приходится делать такой финт ушами:

      Для А=1 по СтрДлина(НачКодСотра) Цикл
         Если ПустаяСтрока(Сред(НачКодСотра,А,1))= Ложь Тогда
            КодСотра=КодСотра+Сред(НачКодСотра,А,1);
         КонецЕсли;
      КонецЦикла;   
 
НачКодСотра ("1 000") преобразуется в КодСотра ("1000") поразрядным перебором значений.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Вопрос еще один возник.Строка след.содержания : Москва г., необходимо сделать г. Москва какими функциями это можно сделать ? Был бы очень благодарен за пример. Спасибо. 

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Вопрос еще один возник.Строка след.содержания : Москва г., необходимо сделать г. Москва какими функциями это можно сделать ? Был бы очень благодарен за пример. Спасибо.

Ну перемести "г." в начало строки стандартными функциями 1с-ки для работ со строками.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
споткнулся на ровном месте есть строчка: 
",O=" + Лев (НРег(СтрокаТаблицы.StreetAddress, 6) + " " + \\ругается
Как правильно записать строчку с НРег ?


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4154
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1092
Последний ответ 02 Дек 2016, 12:58
от Jalib
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2155
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 8011
Последний ответ 07 Май 2015, 14:38
от Opty
Как получить цену товара контрагента и количество реализованного товара

Автор kbukaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1639
Последний ответ 08 Сен 2015, 15:46
от Klyacksa

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal