Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Установить значение реквизита  (Прочитано 2396 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zeus_God

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-01-16
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте!
Подскажите, пожалуйста, как установить значение реквизита. Делаю внешнюю обработку для ЗУП 2.5 документ "Справка о заработке для расчета пособий". Фрагмент кода:

          Пока РезультатЗапроса.Следующий() Цикл
ТабНомСотр = СокрЛП(РезультатЗапроса.Код);
ТабНомСотрЧисло = Число(ТабНомСотр);
КодВДок = СокрЛП(Лист.Cells(СтрокаФайла,ТабельныйНомер).Value);
КодВДокЧисло = Число(КодВДок);
НовыйДокумент.Записать();

Если ТабНомСотрЧисло = КодВДокЧисло Тогда
Док = НовыйДокумент.Сотрудник.Ссылка;
ДокСотр = док.ПолучитьОбъект();
ИмяСотр = СокрЛП(РезультатЗапроса.Наименование);
ДокСотр.Сотрудник.Наименование = ИмяСотр;
Прервать;
КонецЕсли;
КонецЦикла;

НовыйДокумент.Записать();
НовыйДокумент.Автозаполнение();
НовыйДокумент.Проведен = Истина;
Попытка
НовыйДокумент.Записать();
Исключение
Сообщить("Не удалось записать объект");
Сообщить(ОписаниеОшибки());
КонецПопытки;
В обработке программно создается НовыйДокумент. В этом фрагменте я получаю объект, чтобы изменить его реквизиты, но, почему то, реквизит так и остается незаполненным. Подскажите, что тут не так?


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
непонятно что вы хотите изменить, справочник или документ, если документ то где вы его получаете изначально не видно, если справочник Сотрудники, то тогда ДокСотр.Записать()

Оффлайн Zeus_God

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-01-16
  • Сайт: 
  • Профессия: Программист 1С
Спасибо. Я уже разобрался. Я неправильно получал объект. Вместо
Если ТабНомСотрЧисло = КодВДокЧисло Тогда
               Док = НовыйДокумент.Сотрудник.Ссылка;
               ДокСотр = док.ПолучитьОбъект();
               ИмяСотр = СокрЛП(РезультатЗапроса.Наименование);
               ДокСотр.Сотрудник.Наименование = ИмяСотр;
               Прервать;
КонецЕсли;
Надо было написать просто
Если ТабНомСотрЧисло = КодВДокЧисло Тогда					
НовыйДокумент.Сотрудник = РезультатЗапроса.Ссылка;
КонецЕсли;


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6860
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3227
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 965
Последний ответ 23 Ноя 2016, 12:53
от sertak
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8509
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6828
Последний ответ 18 Сен 2011, 16:07
от Хеля

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 321
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal