Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 17:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись в регистры  (Прочитано 1430 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dulingleb

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Есть такой код:

&НаКлиенте
Процедура Проверить(Команда)
    ЗаписатьДорожку();
    Записать(Новый Структура("РежимЗаписи", РежимЗаписиДокумента.Проведение));
    Закрыть();
КонецПроцедуры
 
&НаСервере
Процедура ЗаписатьДорожку()
НаборЗаписей = РегистрыСведений.Дорожки.СоздатьНаборЗаписей();
    НоваяЗапись = НаборЗаписей.Добавить();
    НоваяЗапись.Дорожка = Объект.НомерДорожки;
    НаборЗаписей.Записать();
КонецПроцедуры


Фишка в чем: когда я записываю, то в регистре сведений заменяются данные, а мне надо чтоб проверяло, есть ли такая дорожка, если нету - записать, иначе ошибка.


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6556
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Для этого надо сначала прочитать набор записей, проверить есть ли в нем записи, и дальше действовать как вам нужно.

Оффлайн dulingleb

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Для этого надо сначала прочитать набор записей, проверить есть ли в нем записи, и дальше действовать как вам нужно.
Подскажете, плиз, как это реализовать

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6556
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Проверить(Команда)
    ЗаписатьДорожку();
    Записать(Новый Структура("РежимЗаписи", РежимЗаписиДокумента.Проведение));
    Закрыть();
КонецПроцедуры
 
&НаСервере
Процедура ЗаписатьДорожку()
НаборЗаписей = РегистрыСведений.Дорожки.СоздатьНаборЗаписей();
НаборЗаписей.Прочитать();
Если НаборЗаписей.Количество() > 0 Тогда
    Возврат;
КонецЕсли;
    НоваяЗапись = НаборЗаписей.Добавить();
    НоваяЗапись.Дорожка = Объект.НомерДорожки;
    НаборЗаписей.Записать();
КонецПроцедуры


Теги:
 

Как понять запись ?(НачОстаток = Null,0,НачОстаток)

Автор olgahachnewРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2568
Последний ответ 07 Апр 2011, 17:38
от chuevsf
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14321
Последний ответ 11 Янв 2011, 10:04
от nomer13
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3601
Последний ответ 02 Фев 2014, 21:37
от LordWizard
Запись элемента справочника из модуля объекта другого справочника

Автор 12040Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1405
Последний ответ 05 Май 2016, 09:29
от LexaK
Запись регистра регистра сведений стали не уникальными: РасчетПереоценкиВалютныхСредств

Автор GinayatРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 169
Последний ответ 09 Ноя 2017, 21:42
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 717
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal