Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 06:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перенос данных из УСХП в камин  (Прочитано 1088 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Все привет вот кусочек кода
Выборка = Документы.КадровоеПеремещениеОрганизаций.Выбрать(ДатаНачала,ДатаКонца);
   НомерСтроки=0;
   Пока Выборка.Следующий() Цикл   
      

   Для Каждого ТекСтрокаРаботникиОрганизации Из Выборка.РаботникиОрганизации Цикл                 
         НомерСтроки=НомерСтроки+1;
         ТабНомер=ТекСтрокаРаботникиОрганизации.Сотрудник.Код;
         
         Лист.Cells(НомерСтроки, 1).Value = Строка("Перемещение");
         Лист.Cells(НомерСтроки, 2).Value = Дата(Выборка.Дата);             
         Лист.Cells(НомерСтроки, 3).Value = Строка(ТекСтрокаРаботникиОрганизации.Сотрудник.Код);
         Лист.Cells(НомерСтроки, 5).Value = Строка(ТекСтрокаРаботникиОрганизации.ПодразделениеОрганизации);
         Лист.Cells(НомерСтроки, 6).Value = Строка(ТекСтрокаРаботникиОрганизации.ОснованиеПеремещения);
         Лист.Cells(НомерСтроки, 7).Value = Дата(ТекСтрокаРаботникиОрганизации.ДатаНачала);
         Попытка
         Лист.Cells(НомерСтроки, 8).Value = Дата(ТекСтрокаРаботникиОрганизации.ДатаОкончания);   
      Исключение
         КонецПопытки;

         Лист.Cells(НомерСтроки, 9).Value = Строка(ТекСтрокаРаботникиОрганизации.Должность);
         Лист.Cells(НомерСтроки, 10).Value = Строка(ТекСтрокаРаботникиОрганизации.СпособРасчета);
         Лист.Cells(НомерСтроки, 11).Value = Строка(ТекСтрокаРаботникиОрганизации.ГрафикРаботы);
           
         КонецЦикла;   
   Для Каждого ТекСтрокаОсновныеНачисления Из Выборка.ОсновныеНачисления Цикл         
      Если ТабНомер=ТекСтрокаОсновныеНачисления.Сотрудник.Код Тогда
            Лист.Cells(НомерСтроки, 12).Value = Строка(ТекСтрокаОсновныеНачисления.Сотрудник);
             Лист.Cells(НомерСтроки, 13).Value = Строка(ТекСтрокаОсновныеНачисления.ВидРасчета);
            Лист.Cells(НомерСтроки, 14).Value = Строка(ТекСтрокаОсновныеНачисления.Действие);
            Лист.Cells(НомерСтроки, 15).Value = Строка(ТекСтрокаОсновныеНачисления.Показатель1);
         КонецЕсли;
         КонецЦикла;
             КонецЦикла;

Я столкнулся с такой ошибкой екСтрокаРаботникиОрганизации.ПодразделениеОрганизации это подразделение  на которое переводят сотрудника а с какого подразделения перводят я не нашёл
в документе есть 2 реквизита
ОбособленноеПодразделениеОткуда
ОбособленноеПодразделениеКуда
С типом СправочникСсылка.Организации
откудо мне лучше взять старое подразделение
если пишу так то ругается
Выборка = Документы.КадровоеПеремещениеОрганизаций.Выбрать(ДатаНачала,ДатаКонца);
   НомерСтроки=0;
   Пока Выборка.Следующий() Цикл   
Лист.Cells(НомерСтроки, 70).Value = Строка(Выборка.ОбособленноеПодразделениеОткуда);
Лист.Cells(НомерСтроки, 71).Value = Строка(Выборка.ОбособленноеПодразделениеКуда);
аналогичное происходит и с должностью. Может кто то делал подскажите


Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Едим дальше
написал вот такой код
   Выборка = Документы.КадровоеПеремещениеОрганизаций.Выбрать(ДатаНачала,ДатаКонца);
   НомерСтроки=0;
   Пока Выборка.Следующий() Цикл   
      
   Запрос1 = Новый Запрос;
   Запрос1.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
   
   ТекстЗапроса =
   "ВЫБРАТЬ
   |   Сотрудники.Сотрудник,
   |   Сотрудники.ДатаНачала
   |ПОМЕСТИТЬ ВТ_ТаблицаСотрудников
   |ИЗ
   |   &ТаблицаСотрудников КАК Сотрудники";
   
   Запрос1.УстановитьПараметр("ТаблицаСотрудников",   Выборка.Ссылка.РаботникиОрганизации);
   Запрос1.Текст = ТекстЗапроса;
   Запрос1.Выполнить();
   
   ДанныеРаботниковДоНазначения = КадровоеПеремещениеОрганизацийПереопределяемый.СформироватьЗапросПоДаннымРаботникаДоНазначения(Запрос1, Выборка.Ссылка).Выгрузить();
   
   Для Каждого ТекСтрокаРаботникиОрганизации Из Выборка.РаботникиОрганизации Цикл                 
         НомерСтроки=НомерСтроки+1;
         ТабНомер=ТекСтрокаРаботникиОрганизации.Сотрудник.Код;
         
         ДанныеРаботникаДоНазначения = ДанныеРаботниковДоНазначения.Найти(ТекСтрокаРаботникиОрганизации.Сотрудник,"Сотрудник");
         
         Лист.Cells(НомерСтроки, 1).Value = Строка("Перемещение");
         Лист.Cells(НомерСтроки, 2).Value = Дата(Выборка.Дата);             
         Лист.Cells(НомерСтроки, 3).Value = Строка(ТекСтрокаРаботникиОрганизации.Сотрудник.Код);
         Лист.Cells(НомерСтроки, 5).Value = Строка(ТекСтрокаРаботникиОрганизации.ПодразделениеОрганизации);
         Лист.Cells(НомерСтроки, 6).Value = Строка(ТекСтрокаРаботникиОрганизации.ОснованиеПеремещения);
         Лист.Cells(НомерСтроки, 7).Value = Дата(ТекСтрокаРаботникиОрганизации.ДатаНачала);
         Попытка
         Лист.Cells(НомерСтроки, 8).Value = Дата(ТекСтрокаРаботникиОрганизации.ДатаОкончания);   
         Лист.Cells(НомерСтроки, 16).Value = Строка(ДанныеРаботникаДоНазначения.ПодразделениеОрганизации);
         Лист.Cells(НомерСтроки, 17).Value = Строка(ДанныеРаботникаДоНазначения.Должность);
      Исключение
         КонецПопытки;

         Лист.Cells(НомерСтроки, 9).Value = Строка(ТекСтрокаРаботникиОрганизации.Должность);
         Лист.Cells(НомерСтроки, 10).Value = Строка(ТекСтрокаРаботникиОрганизации.СпособРасчета);
         Лист.Cells(НомерСтроки, 11).Value = Строка(ТекСтрокаРаботникиОрганизации.ГрафикРаботы);
           
         КонецЦикла;   
   Для Каждого ТекСтрокаОсновныеНачисления Из Выборка.ОсновныеНачисления Цикл         
      Если ТабНомер=ТекСтрокаОсновныеНачисления.Сотрудник.Код Тогда
            Лист.Cells(НомерСтроки, 12).Value = Строка(ТекСтрокаОсновныеНачисления.Сотрудник);
             Лист.Cells(НомерСтроки, 13).Value = Строка(ТекСтрокаОсновныеНачисления.ВидРасчета);
            Лист.Cells(НомерСтроки, 14).Value = Строка(ТекСтрокаОсновныеНачисления.Действие);
            Лист.Cells(НомерСтроки, 15).Value = Строка(ТекСтрокаОсновныеНачисления.Показатель1);
         КонецЕсли;
         КонецЦикла;
             КонецЦикла;

Строки 16 и 17 не заполняются,не могу понять почем,смотрю в отладчике всё пишет а вот в ексель нет, подскажите в чём может быть проблема?


Теги:
 

Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3961
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2223
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7649
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7130
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Как перенести конфу базы данных на новую конфу?

Автор dim3740Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 11528
Последний ответ 23 Авг 2010, 15:41
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Загрузка из Камин

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 351
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal