Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 20:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматимческое заполнение поля формы  (Прочитано 2252 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maxx79

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2013-10-29
  • Компания: Nissan-Part
  • Профессия: Программист 1С
Добрый день!

Не судите строго, я только начинаю свой путь.

Помогите разобраться в синтаксисе (8.2):

Есть поле "Наименование" и поле перечисление "Форма контрагента" (ООО, ЗАО и т.д.)
Надо чтобы при выборе формы контрагента автоматом заполнялось поле "Полное наименование" = "Форма контрагента" + "Наименование"

&НаСервереБезКонтекста
Функция ПолучитьРеквизитВыбранногоЗначения(ВыбранноеЗначение)

   Возврат ВыбранноеЗначение;

КонецФункции

&НаКлиенте
Процедура ФормаОрганизацииПриИзменении(Элемент)
ФормаОрг = Объект.ФормаОрганизации;
ФормаОргЗнач = ПолучитьРеквизитВыбранногоЗначения(Объект.ФормаОрганизации);


НаименованиеОрг = Объект.Наименование;
НаименованиеОргЗнач = ПолучитьРеквизитВыбранногоЗначения(Объект.Наименование);


Объект.НаименованиеПолное.Значение = ФормаОргЗнач + " " + НаименованиеОргЗнач;
КонецПроцедуры

Выдает ошибку "Значение не является значением объектного типа (Значение)"


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Достаточно будет

Объект.НаименованиеПолное = ФормаОргЗнач + " " + НаименованиеОргЗнач;

Оффлайн Maxx79

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2013-10-29
  • Компания: Nissan-Part
  • Профессия: Программист 1С

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Объект.НаименованиеПолное = СокрЛП(ФормаОргЗнач) + " " + СокрЛП(НаименованиеОргЗнач);

Оффлайн Maxx79

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2013-10-29
  • Компания: Nissan-Part
  • Профессия: Программист 1С
Спасибо! Работает!

Только понять бы, зачем и почему надо что-то сокращать в полученных данных? :mellow:

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Это не сокращение, а приведение к типу строка.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
И все тоже самое только короче...
&НаКлиенте
Процедура ФормаОрганизацииПриИзменении(Элемент)

   Объект.НаименованиеПолное.Значение = ""+Объект.ФормаОрганизации+ " " + Объект.Наименование;

КонецПроцедуры

""+Объект.ФормаОрганизации - не явное приведение к строковому типу платформой
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 633
Последний ответ 21 Сен 2017, 10:33
от Insider
Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 8596
Последний ответ 16 Авг 2012, 21:50
от Will
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 155
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5257
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3798
Последний ответ 12 Июл 2013, 15:35
от mikel10

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 265
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal