Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Фев 2018, 02:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С 8.2 Отбор на форме  (Прочитано 5310 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Помогите, При изменении Автомобиль отбор на какое то значение, должен показывать документы только от марки этой машины

Вот процедура, что сюда нужно добавить или изменить, а то так и не могу понять

&НаКлиенте
Процедура УстановитьФлажок()
   УдалитьФлажок();
   ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
   ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ТранспортноеСредство");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
   ЭлементОтбора.Использование = Истина;
   ЭлементОтбора.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
   ЭлементОтбора.ПравоеЗначение = АвтомобильОтбор;
   КонецПроцедуры
&НаКлиенте
Процедура УдалитьФлажок()

   ЭлементыОтбора = Список.Отбор.Элементы;
   ПолеКомпоновки = Новый ПолеКомпоновкиДанных("ТранспортноеСредство");

   Для каждого ЭлементОтбора Из ЭлементыОтбора Цикл

      Если ЭлементОтбора.ЛевоеЗначение = ПолеКомпоновки Тогда
         ЭлементыОтбора.Удалить(ЭлементОтбора);
      КонецЕсли;

   КонецЦикла;

КонецПроцедуры
&НаКлиенте
Процедура АвтомобильОтборПриИзменении(Элемент)
   Список.Отбор.
   Если НЕ АвтомобильОтбор.Пустая() Тогда
      Флажок = Истина
   КонецЕсли;
   
   Если Флажок Тогда
      УстановитьФлажок();
      Элементы.Список.Обновить();
   КонецЕсли;

КонецПроцедуры
&НаКлиенте
Процедура ФлажокПриИзменении(Элемент)
   Если Флажок тогда
      УстановитьФлажок();
   иначе
      УдалитьФлажок();
   КонецЕсли;
   Элементы.Список.Обновить();
КонецПроцедуры



//&НаКлиенте
//Процедура АвтомобильОтборОчистка(Элемент, СтандартнаяОбработка)
// Элементы.Список.Обновить();
//КонецПроцедуры


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
а какая ошибка?

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
а какая ошибка?
в том то и дело что никакой не выдает, но не работает

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
попробуйте после кода
Элементы.Список.Обновить();
добавить
ОбновитьИнтерфейс();

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
попробуйте после кода
Элементы.Список.Обновить();
добавить
ОбновитьИнтерфейс();

Не получается ((

Может у вас есть код примера ???

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
а так?
&НаКлиенте
Процедура УдалитьФлажок()
   ЭлементыОтбора = Список.Отбор.Элементы;
   Для каждого ЭлементОтбора Из ЭлементыОтбора Цикл
            ЭлементыОтбора.Удалить(ЭлементОтбора);
    КонецЦикла;
КонецПроцедуры

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
а так?
&НаКлиенте
Процедура УдалитьФлажок()
   ЭлементыОтбора = Список.Отбор.Элементы;
   Для каждого ЭлементОтбора Из ЭлементыОтбора Цикл
            ЭлементыОтбора.Удалить(ЭлементОтбора);
    КонецЦикла;
КонецПроцедуры

Тоже не как((

Ладно на днях спрошу у знакомого ))

Спасибо за помощь

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
у меня все работает

&НаКлиенте
Процедура ПроведенПриИзменении(Элемент)
ЭлементыОтбора = Список.Отбор.Элементы;
Для каждого ЭлементОтбора Из ЭлементыОтбора Цикл
ЭлементыОтбора.Удалить(ЭлементОтбора);
КонецЦикла;

ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Проведен");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = Проведен;
Элементы.Список.Обновить();
КонецПроцедуры

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
у меня все работает

&НаКлиенте
Процедура ПроведенПриИзменении(Элемент)
ЭлементыОтбора = Список.Отбор.Элементы;
Для каждого ЭлементОтбора Из ЭлементыОтбора Цикл
ЭлементыОтбора.Удалить(ЭлементОтбора);
КонецЦикла;

ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Проведен");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = Проведен;
Элементы.Список.Обновить();
КонецПроцедуры

О заработало, только обновляет когда заново окно открывается )))

Щас попробую доделать
Спасибо
Добавлено: 28 Окт 2013, 01:10

у меня все работает

&НаКлиенте
Процедура ПроведенПриИзменении(Элемент)
ЭлементыОтбора = Список.Отбор.Элементы;
Для каждого ЭлементОтбора Из ЭлементыОтбора Цикл
ЭлементыОтбора.Удалить(ЭлементОтбора);
КонецЦикла;

ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Проведен");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = Проведен;
Элементы.Список.Обновить();
КонецПроцедуры

О заработало, только обновляет когда заново окно открывается )))

Щас попробую доделать
Спасибо

Лишние процедуры удалил заработало, Спасибо большое_))))


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1917
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 372
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2399
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 479
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2947
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
217 Сообщений
AIFrame AIFrame
78 Сообщений
alexandr_ll
41 Сообщений
MuI_I_Ika MuI_I_Ika
38 Сообщений
BuhRust
29 Сообщений
wise wise
27 Сообщений
andron81_81
25 Сообщений
pavl_vs
23 Сообщений
ildar32 ildar32
22 Сообщений
oleg-x
22 Сообщений

* Кто онлайн

  • Точка Гостей: 214
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal