Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 окт 2021, 00:12

Проблемы с печатной формой

Автор Norman, 24 фев 2010, 10:27

0 Пользователей и 1 гость просматривают эту тему.

Norman

Создал Запрос:

Процедура Сформировать()
   Перем Запрос, ТекстЗапроса, Таб;
   Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |Период с ВыбНачПериода по ВыбКонПериода;
   |ОбрабатыватьДокументы все;
   |Обрабатывать НеПомеченныеНаУдаление;
   |Поставщики = Документ.ПрихНакл.Поставщики;
   |Товар = Документ.ПрихНакл.Товар;
   |Кол = Документ.ПрихНакл.Количество;
   |Сум = Документ.ПрихНакл.ОбщСум;
   |Функция КолЗакуп = Сумма(Кол);
   |Функция СумЗакуп = Сумма(Сум);
   |Группировка Поставщики упорядочить по Поставщики.Наименование;
   |Группировка Товар упорядочить по Товар.Наименование;
   |Условие(Поставщики в ВыбПоставщики);
   |"//}}ЗАПРОС
   ;
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;

   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   Таб.ВывестиСекцию("Заголовок");
   Состояние("Заполнение выходной таблицы...");
   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
   Пока Запрос.Группировка(1) = 1 Цикл
//      Таб.ВывестиСекцию("Поставщики");
      Пока Запрос.Группировка(2) = 1 Цикл
         Таб.ВывестиСекцию("Товар");
      КонецЦикла;
   КонецЦикла;
   Таб.ВывестиСекцию("Итого");
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать", "");
КонецПроцедуры

Таблица:



Norman


Norman


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск