Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
01 Окт 2020, 04:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблемы с печатной формой  (Прочитано 2859 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Norman

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-24
  • Сайт: 
Создал Запрос:

Процедура Сформировать()
   Перем Запрос, ТекстЗапроса, Таб;
   Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |Период с ВыбНачПериода по ВыбКонПериода;
   |ОбрабатыватьДокументы все;
   |Обрабатывать НеПомеченныеНаУдаление;
   |Поставщики = Документ.ПрихНакл.Поставщики;
   |Товар = Документ.ПрихНакл.Товар;
   |Кол = Документ.ПрихНакл.Количество;
   |Сум = Документ.ПрихНакл.ОбщСум;
   |Функция КолЗакуп = Сумма(Кол);
   |Функция СумЗакуп = Сумма(Сум);
   |Группировка Поставщики упорядочить по Поставщики.Наименование;
   |Группировка Товар упорядочить по Товар.Наименование;
   |Условие(Поставщики в ВыбПоставщики);
   |"//}}ЗАПРОС
   ;
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;

   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   Таб.ВывестиСекцию("Заголовок");
   Состояние("Заполнение выходной таблицы...");
   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
   Пока Запрос.Группировка(1) = 1 Цикл
//      Таб.ВывестиСекцию("Поставщики");
      Пока Запрос.Группировка(2) = 1 Цикл
         Таб.ВывестиСекцию("Товар");
      КонецЦикла;
   КонецЦикла;
   Таб.ВывестиСекцию("Итого");
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать", "");
КонецПроцедуры

Таблица:




Оффлайн Norman

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-24
  • Сайт: 
Результат работы:


Оффлайн Norman

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-24
  • Сайт: 
Как нужно:



Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
78 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
30 Сообщений
oooo800
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
alexandr_ll
14 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 148
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal