Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Ноя 2018, 00:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблемы с печатной формой  (Прочитано 2503 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Norman

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-24
  • Сайт: 
Создал Запрос:

Процедура Сформировать()
   Перем Запрос, ТекстЗапроса, Таб;
   Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |Период с ВыбНачПериода по ВыбКонПериода;
   |ОбрабатыватьДокументы все;
   |Обрабатывать НеПомеченныеНаУдаление;
   |Поставщики = Документ.ПрихНакл.Поставщики;
   |Товар = Документ.ПрихНакл.Товар;
   |Кол = Документ.ПрихНакл.Количество;
   |Сум = Документ.ПрихНакл.ОбщСум;
   |Функция КолЗакуп = Сумма(Кол);
   |Функция СумЗакуп = Сумма(Сум);
   |Группировка Поставщики упорядочить по Поставщики.Наименование;
   |Группировка Товар упорядочить по Товар.Наименование;
   |Условие(Поставщики в ВыбПоставщики);
   |"//}}ЗАПРОС
   ;
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;

   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   Таб.ВывестиСекцию("Заголовок");
   Состояние("Заполнение выходной таблицы...");
   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
   Пока Запрос.Группировка(1) = 1 Цикл
//      Таб.ВывестиСекцию("Поставщики");
      Пока Запрос.Группировка(2) = 1 Цикл
         Таб.ВывестиСекцию("Товар");
      КонецЦикла;
   КонецЦикла;
   Таб.ВывестиСекцию("Итого");
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать", "");
КонецПроцедуры

Таблица:




Оффлайн Norman

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-24
  • Сайт: 
Результат работы:


Оффлайн Norman

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-24
  • Сайт: 
Как нужно:



Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
63 Сообщений
AIFrame AIFrame
57 Сообщений
wise wise
55 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
46 Сообщений
alexandr_ll
45 Сообщений
alex0402
44 Сообщений
BuhRust
30 Сообщений
LexaK
26 Сообщений
andron81_81
24 Сообщений
byte777
21 Сообщений

* Кто онлайн

  • Точка Гостей: 197
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal