Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 08:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Команда Документа  (Прочитано 2234 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Есть команда "печать" в документе. Необходимо провести документ, если он непроведен перед печатью и перепровести, если были какие-либо изменения.
При таком раскладе:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
 
 Если Не ДокументПроведен(ПараметрКоманды) Тогда
  ТекстВопроса = "Для печати документ должен быть проведен. Продолжить?";
  КодВозврата = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ОКОтмена);
  Если КодВозврата = КодВозвратаДиалога.ОК Тогда
   ПровестиДок(ПараметрКоманды);
  Иначе
   Возврат;
  КонецЕсли;
 КонецЕсли;
 ТабДок = Новый ТабличныйДокумент;
 Печать(ТабДок, ПараметрКоманды);
  ТабДок.Показать();
 
КонецПроцедуры
&НаСервере
Функция ДокументПроведен(ПараметрКоманды)
 
 Док = ПараметрКоманды.ПолучитьОбъект();
  Док.Прочитать();
 Если Док.Модифицированность() ИЛИ Док.Проведен ТОгда
  Возврат Истина;
 Иначе
  Возврат Ложь;
 КонецЕсли;
 
КонецФункции
&НаСервере
Процедура ПровестиДок(ПараметрКоманды)
 НачатьТранзакцию();
 Попытка
  Док = ПараметрКоманды.ПолучитьОбъект();
  Док.Записать(РежимЗаписиДокумента.Проведение);
  Док.Прочитать();
  ЗафиксироватьТранзакцию();
 Исключение
  ОтменитьТранзакцию();
 КонецПопытки;
 
КонецПроцедуры
при попытке изменить что либо в форме документа после печати, вылетает ошибка : "Данные были изменены или удалены другим пользователем". Как правильно реализовать этот механизм?

Последний раз редактировалось: MuI_I_Ika; 23 Окт 2013, 16:29


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
команду печать вынесите в модуль формы и используйте в процедуре ПровестиДок()
ДокОбъект = РеквизитФормыВЗначение(Объект);
ДокОбъект.Записать(РежимЗаписиДокумента.Проведение);
ЗначениеВДанныеФормы(ДокОбъект, Объект);


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4467
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15899
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4194
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 616
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7730
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 594
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal