Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 окт 2021, 00:55

Печатная форма счета

Автор Nat-ule4ka, 22 фев 2010, 10:15

0 Пользователей и 1 гость просматривают эту тему.

Nat-ule4ka

Добрый день! Помогите пожалуйста, в бухгалтерии 7.7. не могу добавить в печатной форме счета "Номер телефона исполнителя", прописала в модуле имя пользователя и тел., имя пользователя отображается на печатной форме, а тел контактный нет, причем у других пользователей нормально  отображается телефон в печатной форме, а у одной(в примере: Степанова) только контактный тел.исполнителя не отображается :thwrt:,зато исполнитель отображается, в чем может быть причина? :dfbsdfbsdf: выглядит следующим образом:
Исп = ПолноеИмяПользователя();
  Тел = "";
  Если ИмяПользователя() = "Сидорова" Тогда
     Тел = "35-**-**";
  Иначе//КонецЕсли;
     Если ИмяПользователя() = "Иванова" Тогда
        Тел = "35-**-**";
     Иначе//КонецЕсли;
        Если ИмяПользователя() = "Петрова" Тогда
           Тел = "35-**-**";
        Иначе//КонецЕсли;     
           Если ИмяПользователя() = "Бух_1" Тогда
              Тел = "35-**-**";
           Иначе//КонецЕсли;
              Если ИмяПользователя() = "Бух_2" Тогда
                 Тел = "35-**-**";
              Иначе//КонецЕсли;
                 Если ИмяПользователя() = "Админ" Тогда
                    Тел = "35-**-**";
                 Иначе//КонецЕсли;
                    Если ИмяПользователя() = "Скворцова" Тогда
                       Тел = "35-**-**";
                    Иначе//КонецЕсли;   
                       Если ИмяПользователя() = "Степанова" Тогда
                       Тел = "35-**-**";
                    КонецЕсли;
                 КонецЕсли;
              КонецЕсли;
           КонецЕсли;
        КонецЕсли;
    КонецЕсли;
  КонецЕсли;
КонецЕсли;
  //________________

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск