Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 21:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с заполнением данных о сотруднике  (Прочитано 1466 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NatalyL8

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-10-18
  • Сайт: 
Добрый день,

помогите, пожалуйста, найти причину ошибку.

Есть стандартная процедура ПроставитьДанныеСтроки(Сотрудник, ДатаСобытия, ЭлементФормы), которую использована во внешней обработке.

Ошибка у меня возникает конкретно в этом куске кода:

// скорректируем даты заполнения датами приема увольнения сотрудника
      СкорректированнаяДатаНачала = Неопределено;
      ТекущиеДанные = ЭлементФормы;

     
   Если ТекущиеДанные <> Неопределено Тогда
      ДатыПриемаУвольнения = ОбщегоНазначенияЗК.ПолучитьЗначенияРеквизитов(Сотрудник, "ДатаПриемаНаРаботу,ДатаУвольнения");
      // корректируем дату, только она заполнена
      Если ЗначениеЗаполнено(ТекущиеДанные.ДатаНачала) Тогда
         
         // если дата начала начисления заполнена и раньше, чем сотрудника приняли на работу
         Если ТекущиеДанные.ДатаНачала < ДатыПриемаУвольнения.ДатаПриемаНаРаботу Тогда
            // если сотрудник принят в текущем месяце,
            // просто "сдвигаем" дату начала,
            Если ДатыПриемаУвольнения.ДатаПриемаНаРаботу < КонецМесяца(ТекущиеДанные.ДатаНачала) Тогда
               ТекущиеДанные.ДатаНачала = ДатыПриемаУвольнения.ДатаПриемаНаРаботу;
               СкорректированнаяДатаНачала = ДатыПриемаУвольнения.ДатаПриемаНаРаботу;
            Иначе
               // или очищаем обе даты совсем если он принят еще позже
               ТекущиеДанные.ДатаНачала = Неопределено;
               ТекущиеДанные.ДатаОкончания = Неопределено;
            КонецЕсли;
            // скорректируем и дату начала события
            Если ЭлементФормы.Колонки.Найти("ДатаНачалаСобытия") <> Неопределено Тогда // см. Точнее ниже
               ТекущиеДанные.ДатаНачалаСобытия = СкорректированнаяДатаНачала;
            КонецЕсли;
         КонецЕсли;
      КонецЕсли;


Точнее:
{ВнешняяОбработка.ExcelЗагрузкаНачисленийУдержаний.МодульОбъекта(28)}: Поле объекта не обнаружено (Колонки)
            Если ЭлементФормы.Колонки.Найти("ДатаНачалаСобытия") <> Неопределено Тогда


Как я выяснила данная ошибка возникает только, если сотрудник принят в тот же месяц, что и месяц начисления
(напр, период 01.09.2013-30.09.2013, сотрудник принят например 08.09.2013)
Если сотрудник принят раньше этого периода все работает нормально.

Возможно это поможет, если в начале процедуры вставить

Если ТипЗнч(ЭлементФормы) <> Тип("ТабличноеПоле") Тогда
      Возврат;
   КонецЕсли;

то процедура не выполняется вообще.

За ранее признательна за помощь.



Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
посмотри ЧТО передаётся в твоём ХИТРОМ
{Как я выяснила данная ошибка возникает только, если сотрудник принят в тот же месяц, что и месяц начисления
(напр, период 01.09.2013-30.09.2013, сотрудник принят например 08.09.2013)}

случае в процедуру параметром "ЭлементФормы"
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн NatalyL8

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-10-18
  • Сайт: 
посмотри ЧТО передаётся в твоём ХИТРОМ
{Как я выяснила данная ошибка возникает только, если сотрудник принят в тот же месяц, что и месяц начисления
(напр, период 01.09.2013-30.09.2013, сотрудник принят например 08.09.2013)}

случае в процедуру параметром "ЭлементФормы"

Я не совсем еще хорошо знакома с 1С, не подскажите как это сделать.
Добавлено: 18 Окт 2013, 16:05

Выяснила, что он не может найти Дату начала и Дату окончания события
добавив в начале код

Если ЭлементФормы.Колонки.Найти("ДатаНачала") <> Неопределено
      И ЭлементФормы.Колонки.Найти("ДатаОкончания") <> Неопределено Тогда

То выдается ошибка

{ВнешняяОбработка.ExcelЗагрузкаНачисленийУдержаний.МодульОбъекта(8)}: Поле объекта не обнаружено (Колонки)
   Если ЭлементФормы.Колонки.Найти("ДатаНачала") <> Неопределено

и тоже самое для даты окончания

Последний раз редактировалось: NatalyL8; 18 Окт 2013, 16:05. Причина: Объединение сообщений


 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7434
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3882
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2112
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7324
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6952
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 304
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal